Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Xubuntu Development (http://www.linux-archive.org/xubuntu-development/)
-   -   Unable to auth to new WEP network, NetworkManager "No agents were available for this request" (http://www.linux-archive.org/xubuntu-development/705690-unable-auth-new-wep-network-networkmanager-no-agents-were-available-request.html)

Chris Bainbridge 09-20-2012 01:35 AM

Unable to auth to new WEP network, NetworkManager "No agents were available for this request"
 
I'm using Xubuntu ("Precise" release) with all latest updates. When
trying to connect to a new protected wifi network (by clicking on the
network name in nm-applet from the taskbar) I get a timeout and error
from NetworkManager: "No agents were available for this request". I
have tried with several networks and get the same.

Syslog shows:

Aug 29 21:37:03 andrea NetworkManager[848]: <info> Activation (wlan0)
Stage 2 of 5 (Device Configure) complete.
Aug 29 21:37:28 andrea NetworkManager[848]: <warn> No agents were
available for this request.
Aug 29 21:37:28 andrea NetworkManager[848]: <info> (wlan0): device
state change: need-auth -> failed (reason 'no-secrets') [60 120 7]

I presume NetworkManager is trying to ask nm-applet for a passphrase
but this fails for some reason and the process times out after 25
seconds. I filed bug #1043551 on Launchpad
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1043551

Any ideas? I don't understand why I have not seen more reports of
others encountering this bug, it would seem to be very prominent. I
can connect to a network okay if I manually define it in nm-applet
("Edit Connections...") but not if I just click on the applet icon and
then click on the network name as I suppose most people would do.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel

Chris Bainbridge 09-20-2012 01:53 AM

Unable to auth to new WEP network, NetworkManager "No agents were available for this request"
 
On 20 September 2012 02:35, Chris Bainbridge <chris.bainbridge@gmail.com> wrote:
> I'm using Xubuntu ("Precise" release) with all latest updates. When
> trying to connect to a new protected wifi network (by clicking on the
> network name in nm-applet from the taskbar) I get a timeout and error
> from NetworkManager: "No agents were available for this request". I
> have tried with several networks and get the same.

Never mind, this appears to be a side effect of doing "eval
$(gnome-keyring-daemon --start)" in .profile to get rid of that
annoying pkcs11 message
(https://bugs.launchpad.net/ubuntu/+source/gnome-keyring/+bug/932177),
it does not occur on a standard install.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel


All times are GMT. The time now is 12:53 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.