FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Xubuntu Development

 
 
LinkBack Thread Tools
 
Old 04-18-2012, 10:02 AM
Nikola Velkovski
 
Default mono-runtime cannot be installed

Hello,

I'd like to report problems with installing mono-runtime on
Xubuntu 12.04 x86 and because of that docky cannot be installed.
Here's the info that I get when I try to install mono-runtime:



*aptitude install mono-runtime

The following NEW packages will be installed:

* binfmt-support{a} cli-common{a} libmono-corlib4.0-cil{a}

* libmono-i18n-west4.0-cil{a} libmono-i18n4.0-cil{a}

* libmono-security4.0-cil{a}
libmono-system-configuration4.0-cil{a}

* libmono-system-security4.0-cil{a} libmono-system-xml4.0-cil{a}

* libmono-system4.0-cil{a} mono-4.0-gac{a} mono-gac{a}
mono-runtime

0 packages upgraded, 13 newly installed, 0 to remove and 0 not
upgraded.

Need to get 4,225 kB of archives. After unpacking 12.4 MB will
be used.

The following packages have unmet dependencies:

* perl: Conflicts: mono-gac (< 2.10.8.1-1) but 2.10.5-1 is to
be installed.

* perl-base: Conflicts: mono-gac (< 2.10.8.1-1ubuntu1) but
2.10.5-1 is to be installed.

* perl-modules: Conflicts: mono-gac (< 2.10.8.1-1) but
2.10.5-1 is to be installed.

The following actions will resolve these dependencies:



***** Keep the following packages at their current version:

1)***** libmono-corlib4.0-cil [Not Installed]************

2)***** libmono-i18n-west4.0-cil [Not Installed]*********

3)***** libmono-i18n4.0-cil [Not Installed]**************

4)***** libmono-security4.0-cil [Not Installed]**********

5)***** libmono-system-configuration4.0-cil [Not Installed]

6)***** libmono-system-security4.0-cil [Not Installed]***

7)***** libmono-system-xml4.0-cil [Not Installed]********

8)***** libmono-system4.0-cil [Not Installed]************

9)***** mono-4.0-gac [Not Installed]*********************

10)**** mono-gac [Not Installed]*************************

11)**** mono-runtime [Not Installed]*********************







Accept this solution? [Y/n/q/?]






As an addition openssh-server cannot be installed also:





aptitude install openssh-server

The following NEW packages will be installed:

* openssh-server{b}

The following packages are RECOMMENDED but will NOT be
installed:

* ssh-import-id

0 packages upgraded, 1 newly installed, 0 to remove and 0 not
upgraded.

Need to get 339 kB of archives. After unpacking 897 kB will be
used.

The following packages have unmet dependencies:

* openssh-server: Depends: openssh-client (= 1:5.8p1-7ubuntu1)
but 1:5.9p1-5ubuntu1 is installed.

* libssl1.0.0: Breaks: openssh-server (< 1:5.9p1-4) but
1:5.8p1-7ubuntu1 is to be installed.

The following actions will resolve these dependencies:



**** Keep the following packages at their current version:

1)**** openssh-server [Not Installed]********************







Accept this solution? [Y/n/q/?]







--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-19-2012, 07:49 PM
Krister Alm
 
Default mono-runtime cannot be installed

Are you serious!



The reason for using XUbuntu is to have a slim,fast and responsible
system.

(Don't infest it with Microsoft bloatware.)



use Avant-Window-navigator and AWN if you want an OSX like
interface.









On 04/18/2012 12:02 PM, Nikola Velkovski wrote:


Hello,

I'd like to report problems with installing mono-runtime on
Xubuntu 12.04 x86 and because of that docky cannot be installed.
Here's the info that I get when I try to install mono-runtime:



*aptitude install mono-runtime

The following NEW packages will be installed:

* binfmt-support{a} cli-common{a} libmono-corlib4.0-cil{a}

* libmono-i18n-west4.0-cil{a} libmono-i18n4.0-cil{a}

* libmono-security4.0-cil{a}
libmono-system-configuration4.0-cil{a}

* libmono-system-security4.0-cil{a}
libmono-system-xml4.0-cil{a}

* libmono-system4.0-cil{a} mono-4.0-gac{a} mono-gac{a}
mono-runtime

0 packages upgraded, 13 newly installed, 0 to remove and 0 not
upgraded.

Need to get 4,225 kB of archives. After unpacking 12.4 MB will
be used.

The following packages have unmet dependencies:

* perl: Conflicts: mono-gac (< 2.10.8.1-1) but 2.10.5-1 is
to be installed.

* perl-base: Conflicts: mono-gac (< 2.10.8.1-1ubuntu1) but
2.10.5-1 is to be installed.

* perl-modules: Conflicts: mono-gac (< 2.10.8.1-1) but
2.10.5-1 is to be installed.

The following actions will resolve these dependencies:



***** Keep the following packages at their current version:

1)***** libmono-corlib4.0-cil [Not Installed]************

2)***** libmono-i18n-west4.0-cil [Not Installed]*********

3)***** libmono-i18n4.0-cil [Not Installed]**************

4)***** libmono-security4.0-cil [Not Installed]**********

5)***** libmono-system-configuration4.0-cil [Not Installed]

6)***** libmono-system-security4.0-cil [Not Installed]***

7)***** libmono-system-xml4.0-cil [Not Installed]********

8)***** libmono-system4.0-cil [Not Installed]************

9)***** mono-4.0-gac [Not Installed]*********************

10)**** mono-gac [Not Installed]*************************

11)**** mono-runtime [Not Installed]*********************







Accept this solution? [Y/n/q/?]






As an addition openssh-server cannot be installed also:





aptitude install openssh-server

The following NEW packages will be installed:

* openssh-server{b}

The following packages are RECOMMENDED but will NOT be
installed:

* ssh-import-id

0 packages upgraded, 1 newly installed, 0 to remove and 0 not
upgraded.

Need to get 339 kB of archives. After unpacking 897 kB will be
used.

The following packages have unmet dependencies:

* openssh-server: Depends: openssh-client (= 1:5.8p1-7ubuntu1)
but 1:5.9p1-5ubuntu1 is installed.

* libssl1.0.0: Breaks: openssh-server (< 1:5.9p1-4) but
1:5.8p1-7ubuntu1 is to be installed.

The following actions will resolve these dependencies:



**** Keep the following packages at their current version:

1)**** openssh-server [Not Installed]********************







Accept this solution? [Y/n/q/?]











--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-19-2012, 08:12 PM
Kaspar Kööp
 
Default mono-runtime cannot be installed

On Apr 19, 2012 9:49 PM, "Krister Alm" <krister.alm@gmail.com> wrote:

>

> Are you serious!

>

> The reason for using XUbuntu is to have a slim,fast and responsible system.

> (Don't infest it with Microsoft bloatware.)

>

> use Avant-Window-navigator and AWN if you want an OSX like interface.

>

>


Hi,


Your response is childish. Mono should be installable for those users that need/want it. Who are you to question the use of software on a persons system?


Kaspar







>

>

>

> On 04/18/2012 12:02 PM, Nikola Velkovski wrote:

>>

>> Hello,

>> I'd like to report problems with installing mono-runtime on Xubuntu 12.04 x86 and because of that docky cannot be installed. Here's the info that I get when I try to install mono-runtime:

>>

>> *aptitude install mono-runtime

>> The following NEW packages will be installed:

>> * binfmt-support{a} cli-common{a} libmono-corlib4.0-cil{a}

>> * libmono-i18n-west4.0-cil{a} libmono-i18n4.0-cil{a}

>> * libmono-security4.0-cil{a} libmono-system-configuration4.0-cil{a}

>> * libmono-system-security4.0-cil{a} libmono-system-xml4.0-cil{a}

>> * libmono-system4.0-cil{a} mono-4.0-gac{a} mono-gac{a} mono-runtime

>> 0 packages upgraded, 13 newly installed, 0 to remove and 0 not upgraded.

>> Need to get 4,225 kB of archives. After unpacking 12.4 MB will be used.

>> The following packages have unmet dependencies:

>> * perl: Conflicts: mono-gac (< 2.10.8.1-1) but 2.10.5-1 is to be installed.

>> * perl-base: Conflicts: mono-gac (< 2.10.8.1-1ubuntu1) but 2.10.5-1 is to be installed.

>> * perl-modules: Conflicts: mono-gac (< 2.10.8.1-1) but 2.10.5-1 is to be installed.

>> The following actions will resolve these dependencies:

>>

>> ***** Keep the following packages at their current version:

>> 1)***** libmono-corlib4.0-cil [Not Installed]************

>> 2)***** libmono-i18n-west4.0-cil [Not Installed]*********

>> 3)***** libmono-i18n4.0-cil [Not Installed]**************

>> 4)***** libmono-security4.0-cil [Not Installed]**********

>> 5)***** libmono-system-configuration4.0-cil [Not Installed]

>> 6)***** libmono-system-security4.0-cil [Not Installed]***

>> 7)***** libmono-system-xml4.0-cil [Not Installed]********

>> 8)***** libmono-system4.0-cil [Not Installed]************

>> 9)***** mono-4.0-gac [Not Installed]*********************

>> 10)**** mono-gac [Not Installed]*************************

>> 11)**** mono-runtime [Not Installed]*********************

>>

>>

>>

>> Accept this solution? [Y/n/q/?]

>>

>> ________________________________

>>

>> As an addition openssh-server cannot be installed also:

>>

>>

>> aptitude install openssh-server

>> The following NEW packages will be installed:

>> * openssh-server{b}

>> The following packages are RECOMMENDED but will NOT be installed:

>> * ssh-import-id

>> 0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.

>> Need to get 339 kB of archives. After unpacking 897 kB will be used.

>> The following packages have unmet dependencies:

>> * openssh-server: Depends: openssh-client (= 1:5.8p1-7ubuntu1) but 1:5.9p1-5ubuntu1 is installed.

>> * libssl1.0.0: Breaks: openssh-server (< 1:5.9p1-4) but 1:5.8p1-7ubuntu1 is to be installed.

>> The following actions will resolve these dependencies:

>>

>> **** Keep the following packages at their current version:

>> 1)**** openssh-server [Not Installed]********************

>>

>>

>>

>> Accept this solution? [Y/n/q/?]

>>

>>

>>

>

> --

> xubuntu-devel mailing list

> xubuntu-devel@lists.ubuntu.com

> https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel

>



--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-19-2012, 08:13 PM
Pasi Lallinaho
 
Default mono-runtime cannot be installed

While the mailing list subscribers might or might not agree on Mono
or any other thing, let's remember that the mailing list is Code of
Conduct [1] compliant at all times.



Let's keep the conversation civil and remember that different people
have different needs.



Original poster, can you file a bug report on this?



Cheers,

Pasi



[1] http://www.ubuntu.com/project/about-ubuntu/conduct



On 04/19/2012 10:49 PM, Krister Alm wrote:


Are you serious!



The reason for using XUbuntu is to have a slim,fast and
responsible system.

(Don't infest it with Microsoft bloatware.)



use Avant-Window-navigator and AWN if you want an OSX like
interface.









On 04/18/2012 12:02 PM, Nikola Velkovski wrote:


Hello,

I'd like to report problems with installing mono-runtime on
Xubuntu 12.04 x86 and because of that docky cannot be
installed. Here's the info that I get when I try to install
mono-runtime:



*aptitude install mono-runtime

The following NEW packages will be installed:

* binfmt-support{a} cli-common{a} libmono-corlib4.0-cil{a}

* libmono-i18n-west4.0-cil{a} libmono-i18n4.0-cil{a}

* libmono-security4.0-cil{a}
libmono-system-configuration4.0-cil{a}

* libmono-system-security4.0-cil{a}
libmono-system-xml4.0-cil{a}

* libmono-system4.0-cil{a} mono-4.0-gac{a} mono-gac{a}
mono-runtime

0 packages upgraded, 13 newly installed, 0 to remove and 0
not upgraded.

Need to get 4,225 kB of archives. After unpacking 12.4 MB
will be used.

The following packages have unmet dependencies:

* perl: Conflicts: mono-gac (< 2.10.8.1-1) but 2.10.5-1
is to be installed.

* perl-base: Conflicts: mono-gac (< 2.10.8.1-1ubuntu1)
but 2.10.5-1 is to be installed.

* perl-modules: Conflicts: mono-gac (< 2.10.8.1-1) but
2.10.5-1 is to be installed.

The following actions will resolve these dependencies:



***** Keep the following packages at their current version:

1)***** libmono-corlib4.0-cil [Not Installed]************

2)***** libmono-i18n-west4.0-cil [Not Installed]*********

3)***** libmono-i18n4.0-cil [Not Installed]**************

4)***** libmono-security4.0-cil [Not Installed]**********

5)***** libmono-system-configuration4.0-cil [Not Installed]

6)***** libmono-system-security4.0-cil [Not Installed]***

7)***** libmono-system-xml4.0-cil [Not Installed]********

8)***** libmono-system4.0-cil [Not Installed]************

9)***** mono-4.0-gac [Not Installed]*********************

10)**** mono-gac [Not Installed]*************************

11)**** mono-runtime [Not Installed]*********************







Accept this solution? [Y/n/q/?]






As an addition openssh-server cannot be installed also:





aptitude install openssh-server

The following NEW packages will be installed:

* openssh-server{b}

The following packages are RECOMMENDED but will NOT be
installed:

* ssh-import-id

0 packages upgraded, 1 newly installed, 0 to remove and 0
not upgraded.

Need to get 339 kB of archives. After unpacking 897 kB will
be used.

The following packages have unmet dependencies:

* openssh-server: Depends: openssh-client (=
1:5.8p1-7ubuntu1) but 1:5.9p1-5ubuntu1 is installed.

* libssl1.0.0: Breaks: openssh-server (< 1:5.9p1-4) but
1:5.8p1-7ubuntu1 is to be installed.

The following actions will resolve these dependencies:



**** Keep the following packages at their current version:

1)**** openssh-server [Not Installed]********************







Accept this solution? [Y/n/q/?]



















--
Pasi Lallinaho (knome) » http://open.knome.fi/
Leader of Xubuntu and Shimmer Project »*http://shimmerproject.org/
Graphic artist, webdesigner, Ubuntu member » http://xubuntu.org/


--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-19-2012, 08:32 PM
Elizabeth Krumbach
 
Default mono-runtime cannot be installed

Hi Nikola,

On Wed, Apr 18, 2012 at 3:02 AM, Nikola Velkovski <nvelkovski@gmail.com> wrote:
> Hello,
> I'd like to report problems with installing mono-runtime on Xubuntu 12.04
> x86 and because of that docky cannot be installed. Here's the info that I
> get when I try to install mono-runtime:

I just tried to duplicate your issue and wasn't able to (everything
installed fine).

I recommend running "sudo apt-get update" and then "sudo apt-get
upgrade" to get your system fully up to date and then trying again. I
suspect what happened here is you tried to install it while things
were slightly broken (it is in development, after all) or your sources
weren't completely up to date.

Good luck.

--
Elizabeth Krumbach // Lyz // pleia2
http://www.princessleia.com

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-19-2012, 08:42 PM
Nikola Velkovski
 
Default mono-runtime cannot be installed

On 04/19/2012 10:32 PM, Elizabeth Krumbach wrote:

Hi Nikola,

On Wed, Apr 18, 2012 at 3:02 AM, Nikola Velkovski <nvelkovski@gmail.com> wrote:


Hello,
I'd like to report problems with installing mono-runtime on Xubuntu 12.04
x86 and because of that docky cannot be installed. Here's the info that I
get when I try to install mono-runtime:



I just tried to duplicate your issue and wasn't able to (everything
installed fine).

I recommend running "sudo apt-get update" and then "sudo apt-get
upgrade" to get your system fully up to date and then trying again. I
suspect what happened here is you tried to install it while things
were slightly broken (it is in development, after all) or your sources
weren't completely up to date.

Good luck.



Hello Elizabeth,



thanks for the reply,* I am sure that update and upgrade are done
before trying to install mono-runtime ( docky ) but I will double
check that and If again it's not installed I'll file a bug. Thanks
for the support everyone.









--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-19-2012, 09:51 PM
Josef Latt
 
Default mono-runtime cannot be installed

Hi,

Am 19.04.2012 22:42, schrieb Nikola Velkovski:

On Xubuntu 11.10 I had no problem to install Mono.

You use Xubuntu 12.04 and I think you know that this version is still beta.

Regards
Josef

--
PGP Schlüssel: 311D1055
http://keyserver.pgp.com

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 

Thread Tools




All times are GMT. The time now is 05:28 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org