FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Xubuntu Development

 
 
LinkBack Thread Tools
 
Old 04-21-2008, 11:23 PM
Ryan Pavlik
 
Default Please update to version 2.6

Scrolling bit has already been mentioned - it's something weird with
Ubuntu only, will take a look later though I fear it's lower in the
stack than Abi and so I have little experience debugging down there.

Fixed the bug issues in the changelog. (formatting and location) I
tried to find the appropriate formatting before I made that, but google
only found me contradicting examples, so I picked one that looked
authoritative.

Ditched the libgoffice - see above discussion. The reason it
"worked"with 2.4.6 is because the configure will just disable plugins
whose deps aren't satisfied - there is no actual libgoffice plugin
installed on 2.4.6-3ubuntu3 (I checked). There is no way it will work
with 0.6 until we get a cairo backend and move to/add gtkprint instead
of libgnomeprint.

Fixed line length - another example of following bad examples. All
wrapped to 72 or less.

Poppler: We now look for pdftotext or pdftoabw (which come with
poppler) at runtime, there is actually no build dep I found out. (The
corresponding code was moved over to poppler.)

For the issues that are just changelog formatting, I re-formatted the
changelog. For the actual changes, I added a new changelog entry,
0ubuntu2. Hopefully this was the right thing to do - asked in ubuntu-
devel but it seems my time zones don't line up.

New package should be on my PPA. I have attached the debdiff from the
0ubuntu1 package reviewed.

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-21-2008, 11:29 PM
Ryan Pavlik
 
Default Please update to version 2.6

** Attachment added: "diff between 0ubuntu1 and 0ubuntu2"
http://launchpadlibrarian.net/13762989/fixes_to_abi2620ubuntu1.diff

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-22-2008, 01:38 AM
Michael Chang
 
Default Please update to version 2.6

I'm not a ubuntu dev; just a passer-by user, but since you check for
pdftoabw at runtime, perhaps you want to have poppler-utils as a
"suggests:" or "recommends:" now to match the dropped libpoppler
dependency?

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-22-2008, 03:30 PM
Ryan Pavlik
 
Default Please update to version 2.6

Good catch on poppler-utils, Michael, didn't realize that poppler was
split. I have had to update the package some more since the previous
package (2.4.6) left out some explicit dependencies to just be pulled in
by other libs which we don't use anymore. I have corrected those errors
- please review the latest package on my PPA. I have attached a debdiff
from 2.6.2-0ubuntu1 to 0ubuntu2+ppa2

** Attachment added: "from0ubuntu1to0ubuntu2ppa2.diff"
http://launchpadlibrarian.net/13825928/from0ubuntu1to0ubuntu2ppa2.diff

** Attachment removed: "diff between 0ubuntu1 and 0ubuntu2"

http://launchpadlibrarian.net/13762989/fixes_to_abi2620ubuntu1.diff

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-23-2008, 11:25 AM
Michael Chang
 
Default Please update to version 2.6

The tendency to split packages is a debian/ubuntu thing that sometimes
catches users (and developers!) off guard if you're unaware of it -- the
primary reason, IIRC, is to allow people to save space by removing parts
of software they don't need. (For example, there are separate linux-
image- (kernel image only), linux-headers- (kernel headers only), and
linux-source- (kernel source only) packages in Ubuntu/Debian.) This is
useful for e.g. embedded systems (Debian targets, I think, about 11
archs; some of which are for smaller form factors) and live CDs/DVDs and
other places where space is tight.

http://packages.ubuntu.com/ provides an interface to allow searching for
existing packages, as well as the contents of existing packages. (For
Debian, http://packages.debian.org/ is similar -- AFAIK the two are
based on the same codebase.)

I found poppler-utils by searching for packages which contained
"pdftoabw" on that page.

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-24-2008, 09:46 PM
Michael Chang
 
Default Please update to version 2.6

Just curious, did 2.6 make it into hardy, or is this now something that
must wait for hardy+1?

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-24-2008, 10:36 PM
Ryan Pavlik
 
Default Please update to version 2.6

I have it on word from folks in irc on #ubuntu-devel that we're going to
try to get it in 8.04.1 - the first hardy update in 3 months, when the
cd's are re-spun. The current CD's include the old AbiWord.

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-25-2008, 02:33 PM
Milan
 
Default Please update to version 2.6

And what about Internet updates? We don't need to wait for a new CD to
get it! Anyway, great work - even if we only get it via a backport, it's
easy to install.

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-27-2008, 11:00 AM
Milan
 
Default Please update to version 2.6

I've found an issue (I don't know if this is really a bug) in 2.6 about
the ordering of the fonts list not pushing at the end Arabic fonts
anymore, but I don't know whether this is Ubuntu-related. Since I cannot
report it in Ubuntu, I've put it here:
http://bugzilla.abisource.com/show_bug.cgi?id=11570. Would you have a
look?

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-29-2008, 05:08 AM
Jani Monoses
 
Default Please update to version 2.6

Ryan,

does this package provide python-abiword too? I do not see that in the
PPA. It is the component used by Sugar if available and it was buildable
from the svn sources of Abiword as of november 2007.

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 

Thread Tools




All times are GMT. The time now is 08:52 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org