FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Xubuntu Development

 
 
LinkBack Thread Tools
 
Old 04-15-2008, 10:30 AM
Ryan Pavlik
 
Default Please update to version 2.6

I just double-checked with Marc Maurer (abi dev) and I can in fact
safely delete the dev files (headers, pc, and .la files for plugins).
ppa20 will feature this change, and will be building soon. Apologies
for the misunderstanding.

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-15-2008, 06:38 PM
Eero Tamminen
 
Default Please update to version 2.6

Btw. does the AbiWord version currently being integrated into Hary suffer from this bug (abiword waking up twice a sec when idle):
https://bugzilla.redhat.com/show_bug.cgi?id=335551
?

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-15-2008, 07:08 PM
Ryan Pavlik
 
Default Please update to version 2.6

I would imagine so, since both the incoming Ubuntu version and the
Fedora version are fairly true to upstream, and that bug is confirmed in
2.6.2. The filer of that bug (or perhaps you) should take that upstream
(if it's not there already, I think I remember filing that back when I
learned strace).

At this time, since I don't want to distract from getting the time-
critical work (aka, final fixes, sponsorship, and uploading) done,
unless you think you've found a showstopper, please file a separate bug
and subscribe me. Thanks!

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-16-2008, 04:59 PM
Ryan Pavlik
 
Default Please update to version 2.6

Apologies for the "ping," but I am posting to let you know that the
ppa20 builds that incorporate all actionable feedback I received are
ready to go. At this point, I'd like to know if there are more material
changes I should be making, or if we are waiting for the availability of
a specific person, a specific non-public process to complete, or what
the next step is, since at this time I feel that the packages are well-
made, well-documented, and ready to go. (As an interesting note, they
also backport nicely, removing the dependencies that don't exist to
automatically disable those plugins, and they do upgrade the existing
2.4.x packages cleanly, as tested in Gutsy.)

I don't want Ubuntu users to miss out for the next three years because
this got overlooked at the last minute, so please excuse my insistence:
I do it in the best of interests If there is anything I can do to
speed the process of review, sponsorship, and upload along, please don't
hesitate to let me know. If I can correct the issue with a new package
run, I do not hesitate to push new builds to the PPA (as suggested by
the ~ppa20 in the version number of the latest release ;D )

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-16-2008, 06:28 PM
Steve Langasek
 
Default Please update to version 2.6

Ryan,

Thanks for the explanations of why the patches were dropped, but I did
mean that this should be documented in the changelog since that, rather
than this bug report, is where developers will look to understand the
package history later.

Can you please prepare a 2.6.2-0ubuntu1 package, including this one
change to list the patches that were dropped and why?

At this point I'm ready to ack this for inclusion in hardy; setting to
confirmed, now the package needs someone to sponsor the upload.

** Changed in: abiword (Ubuntu)
Status: New => Confirmed

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-16-2008, 08:00 PM
Ryan Pavlik
 
Default Please update to version 2.6

Ah, great, thanks, didn't get that Should I leave in all my
0ubuntu0~ppaXX changelog entries? Also, what's the call on the goffice
plugin? As long as I'm asking questions, should this final package go
on my PPA or should I just post a debdiff against ~ppa20 here to avoid a
non-PPA tagged build on my ppa?

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-16-2008, 09:52 PM
Martin Pitt
 
Default Please update to version 2.6

Ryan Pavlik [2008-04-16 20:00 -0000]:
> Ah, great, thanks, didn't get that Should I leave in all my
> 0ubuntu0~ppaXX changelog entries?

IMHO it is easier to read if all relevant changelog entries are
condensed into one version, since the PPA versions are not relevant
for the main Ubuntu archive. Also, you should drop changelog entries
which only described bug fixes between your PPA versions.

I. e. the purpose of the changelog is to be a conscise, but precise
explanation what happened since the previous Ubuntu version. It is
important to describe why a package or a patch was dropped, or why a
new patch was introduced, and it is *highly* important to state bug
numbers. With that in mind, common sense should tell you what belongs
in a changelog and what not. If in doubt, just check
/usr/share/doc/*/changelog.Debian.gz. :-)

Many thanks for your intense and great work on this!

Martin

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-17-2008, 10:33 PM
Ryan Pavlik
 
Default Please update to version 2.6

OK - I have uploaded the 0ubuntu1 version to my PPA, with a rewritten
summary changelog that goes in one step from the last ubuntu 2.4.6 (as
in, the version in the archive now) right to the 2.6.2-0ubuntu1,
combining all my PPA edits and the more formal discussion of patches
above. I also have noted all the LP bugs it fixes in the changelog -
they are all the ones "for sure" in the above list. When the package is
uploaded to the archive and this bug is resolved, I will remove the
package from my PPA if desired to avoid version chaos. (I will then
make new backports available in my PPA for Gutsy and Dapper as I am
working on right now. For users of those OS's, we'd like to at least
have PPA repository information on the AbiWord web site.)

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-18-2008, 10:05 AM
Martin Pitt
 
Default Please update to version 2.6

Thanks, Ryan!

Some notes/questions/problems:

- The two poppler patches don't apply any more -> that means that 2.6
now works correctly with poppler 0.6.4, or that the patches need to be
updated?

- "Changed libgoffice-0-6-dev to libgoffice-0-dev due to
incompatibility with 0-6." -> sorry, that doesn't work. The old
libgoffice 0.4 is in universe, and we do not want to support more than
one major version (even less so an ancient one). How come that the old
Abiword 2.4.6 works with the new libgoffice 0.6, but the new AbiWord 2.6
doesn't any more?

- "Closes: LP#3197" is not understood by Launchpad, so you have to
close bugs manually. You should use "LP: #3197" for bugs to be closed
automatically.

- Please append the bug references to the changelog line which
describes the change to fix the respective bug, don't put them all at
the end.

- changelog lines are too long, but don't bother for now.

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 
Old 04-20-2008, 09:14 PM
Åskar
 
Default Please update to version 2.6

I am having troubles scrolling with my mouse in this version, it is sort
of choppy..using abiword - 2.6.2-0ubuntu1

--
Please update to version 2.6
https://bugs.launchpad.net/bugs/202174
You received this bug notification because you are a member of Xubuntu
Developers, which is a direct subscriber.

--
xubuntu-devel mailing list
xubuntu-devel@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/xubuntu-devel
 

Thread Tools




All times are GMT. The time now is 10:10 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org