FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 05-18-2008, 07:45 PM
"Barry Bass"
 
Default ubuntu 8.04 libc6 problem

Hello All.

I'm trying to use gcc in ubuntu 8.04, but apparently libc6-dev is not
installed. Using Synaptic Package Manager to try and install it I get the
error message:

libc6-dev:
Depends: libc6 (=2.6.1-1ubuntu10) but 2.7-10ubuntu3 is to be
installed

I would interpret this to mean that the version of libc6 that is installed
is not compatible with the version of libc6-dev it would otherwise
install.

This would mean to me that the versioning needs to be fixed. Even trying
"Force Version" to load the available version of libc-dev does not load
the package.

Does anyone have a work around? Is this problem otherwise known and being
repaired?

Thanks.

Regards,

Barry

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-18-2008, 08:03 PM
Mike Bird
 
Default ubuntu 8.04 libc6 problem

On Sun May 18 2008 12:45:41 Barry Bass wrote:
> I'm trying to use gcc in ubuntu 8.04, but apparently libc6-dev is not
> installed. Using Synaptic Package Manager to try and install it I get the
> error message:
>
> libc6-dev:
> Depends: libc6 (=2.6.1-1ubuntu10) but 2.7-10ubuntu3 is to be
> installed
>
> I would interpret this to mean that the version of libc6 that is installed
> is not compatible with the version of libc6-dev it would otherwise
> install.
>
> This would mean to me that the versioning needs to be fixed. Even trying
> "Force Version" to load the available version of libc-dev does not load
> the package.
>
> Does anyone have a work around? Is this problem otherwise known and being
> repaired?

I'm assuming you have libc6 version 2.7-10ubuntu3 installed. You can use
"dpkg -s libc6" to verify this.

Try "sudo apt-get install libc6-dev=2.7-10ubuntu3" to see if it can find
the version of libc6-dev which matches your libc6.

Otherwise you'll probably have to update libc6 and then install libc6-dev.

--Mike Bird

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 04:26 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org