FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 11-30-2007, 09:42 AM
Dave M G
 
Default Mencoder broken in Ubuntu

Ubuntu List,

When I run Mencoder from the command line, I get the following error.

Audio LAVC, couldn't find encoder for codec mp3.

It's surprising because this was working fine in Feisty.

Some searching on Google has turned up the possibility that Mencoder is
broken in Ubuntu Gutsy.

However, I can not find any concrete information about a fix or workaround.

Is there a way to get around this error?

--
Dave M G
Ubuntu 7.10

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 11-30-2007, 10:11 AM
John L Fjellstad
 
Default Mencoder broken in Ubuntu

Dave M G <martin@autotelic.com> writes:

> Ubuntu List,
>
> When I run Mencoder from the command line, I get the following error.
>
> Audio LAVC, couldn't find encoder for codec mp3.
>
> It's surprising because this was working fine in Feisty.
>
> Some searching on Google has turned up the possibility that Mencoder is
> broken in Ubuntu Gutsy.
>
> However, I can not find any concrete information about a fix or workaround.
>
> Is there a way to get around this error?

mencoder works for me. Is lame installed? (or liblame0, I guess)

--
John L. Fjellstad
web: http://www.fjellstad.org/ Quis custodiet ipsos custodes


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 11-30-2007, 11:16 AM
Dave M G
 
Default Mencoder broken in Ubuntu

John,

Thank you for replying.

> Is lame installed? (or liblame0, I guess)

Yes. I have ensured that lame is installed, as well as w32codecs, and
any and every other codec that I could find.

By the way, this is the output I get:

MEncoder 2:1.0~rc2-0ubuntu1~gutsy1 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Pentium(R) D CPU 2.80GHz (Family: 15, Model: 6, Stepping: 2)
CPUflags: Type: 15 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
success: format: 0 data: 0x0 - 0x7dc70000
MPEG-PS file format detected.
VIDEO: MPEG2 720x480 (aspect 3) 29.970 fps 9100.0 kbps (1137.5 kbyte/s)
[V] filefmt:2 fourcc:0x10000002 size:720x480 fps:29.97 ftime:=0.0334
================================================== ========================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
================================================== ========================
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [scale w=720 h=480]
================================================== ========================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred colorspace: Mpeg PES)
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
================================================== ========================
Audio LAVC, couldn't find encoder for codec mp3.

--
Dave M G
Ubuntu 7.10



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 11-30-2007, 10:25 PM
James Takac
 
Default Mencoder broken in Ubuntu

On Friday 30 November 2007 21:11:19 John L Fjellstad wrote:
> Dave M G <martin@autotelic.com> writes:
> > Ubuntu List,
> >
> > When I run Mencoder from the command line, I get the following error.
> >
> > Audio LAVC, couldn't find encoder for codec mp3.
> >
> > It's surprising because this was working fine in Feisty.
> >
> > Some searching on Google has turned up the possibility that Mencoder is
> > broken in Ubuntu Gutsy.
> >
> > However, I can not find any concrete information about a fix or
> > workaround.
> >
> > Is there a way to get around this error?
>
> mencoder works for me. Is lame installed? (or liblame0, I guess)
>
> --
> John L. Fjellstad
> web: http://www.fjellstad.org/ Quis custodiet ipsos custodes


Hi John

I get that from the error message as well, i.e. a missing codec, likely lame

James

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-01-2007, 06:54 AM
John L Fjellstad
 
Default Mencoder broken in Ubuntu

Dave M G <martin@autotelic.com> writes:

> John,
>
> Thank you for replying.
>
>> Is lame installed? (or liblame0, I guess)
>
> Yes. I have ensured that lame is installed, as well as w32codecs, and
> any and every other codec that I could find.

Actually, try installing ffmpeg. I just tried to encode a video file
here, and I noticed it uses that program instead of lame

--
John L. Fjellstad
web: http://www.fjellstad.org/ Quis custodiet ipsos custodes


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 03:10 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org