Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Ubuntu User (http://www.linux-archive.org/ubuntu-user/)
-   -   My Emacs lost the ability to highlight the syntaxes in 8.04 (http://www.linux-archive.org/ubuntu-user/89682-my-emacs-lost-ability-highlight-syntaxes-8-04-a.html)

"yueyu lin" 05-16-2008 10:21 PM

My Emacs lost the ability to highlight the syntaxes in 8.04
 
When I finish the fresh new installing of Ubuntu 8.04, my emacs including emacs 22 and emacs snapshot lost the highlighting syntaxes ability. While the xemacs's highlighting still works well.
My home directory is reserved so all of my other emacs plugins are still there.

I mainly use the XRef and have a lot of c projects. The XRef is still there but I feel very uncomfortable without the syntax highlighting.
Does anyone meet the same problem and how to solve it? Thanks in advance.

--
--
Yueyu Lin
--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

"yueyu lin" 05-16-2008 11:28 PM

My Emacs lost the ability to highlight the syntaxes in 8.04
 
It's really strange. I have to enable the syntax highlighting by "M-x font-lock-mode" every time I open my emacs. I can't enable it in .emacs. It should be a conflict with other el files.


On Fri, May 16, 2008 at 3:21 PM, yueyu lin <popeyelin@gmail.com> wrote:

When I finish the fresh new installing of Ubuntu 8.04, my emacs including emacs 22 and emacs snapshot lost the highlighting syntaxes ability. While the xemacs's highlighting still works well.
My home directory is reserved so all of my other emacs plugins are still there.


I mainly use the XRef and have a lot of c projects. The XRef is still there but I feel very uncomfortable without the syntax highlighting.
Does anyone meet the same problem and how to solve it? Thanks in advance.


--
--
Yueyu Lin


--
--
Yueyu Lin
--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Florian Diesch 05-17-2008 08:13 AM

My Emacs lost the ability to highlight the syntaxes in 8.04
 
"yueyu lin" <popeyelin@gmail.com> wrote:

> On Fri, May 16, 2008 at 3:21 PM, yueyu lin <popeyelin@gmail.com> wrote:
>
>> When I finish the fresh new installing of Ubuntu 8.04, my emacs including
>> emacs 22 and emacs snapshot lost the highlighting syntaxes ability. While
>> the xemacs's highlighting still works well.
>> My home directory is reserved so all of my other emacs plugins are still
>> there.
>> I mainly use the XRef and have a lot of c projects. The XRef is still there
>> but I feel very uncomfortable without the syntax highlighting.
>> Does anyone meet the same problem and how to solve it? Thanks in advance.

Works fine here in emacs-snapshot-gtk

> It's really strange. I have to enable the syntax highlighting by "M-x
> font-lock-mode" every time I open my emacs. I can't enable it in .emacs. It
> should be a conflict with other el files.

Maybe some of your settings don't work with the new version. Look at
the *Messages* buffer if there's some error somewhere.




Florian
--
<http://www.florian-diesch.de/>
-----------------------------------------------------------------------
** Hi! I'm a signature virus! Copy me into your signature, please! **
-----------------------------------------------------------------------

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users


All times are GMT. The time now is 09:40 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.