FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 05-16-2008, 05:51 PM
Joseph
 
Default Can't Find a Supervisor

I am trying to install avast from my desktop and this is what I get:

ragweed@ragweed-den:~$ sudo apt-get install avast4workstation_1.0.8-2.deb
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to
correct the problem.
ragweed@ragweed-den:~$ dpkg --configure -a
dpkg: requested operation requires superuser privilege
ragweed@ragweed-den:~$

Ok, I thought I was the supervisor for this machine. How do I run it as
supervisor? Why should I have to run it as supervisor? I've installed
things before and didn't have to do it as a supervisor.

Any thoughts?

Joseph







--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-16-2008, 06:04 PM
Leif Gregory
 
Default Can't Find a Supervisor

On Fri, 16 May 2008 12:51:39 -0500
Joseph <ubuntu@e-pops.org> wrote:

> dpkg: requested operation requires superuser privilege
> ragweed@ragweed-den:~$
>
> Ok, I thought I was the supervisor for this machine. How do I run it
> as supervisor? Why should I have to run it as supervisor? I've
> installed things before and didn't have to do it as a supervisor.

Uhmmmm. Superuser, not supervisor. try putting 'su' before the command.
e.g. su dpkg --configure -a


--
Leif Gregory
Power Wagon Registry: http://powerwagonregistry.org
Truck Hacks: http://trucks.PCWize.com
Geocaching: http://gps.PCWize.com
PHP Tutorials and snippets: http://www.DevTek.org

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-16-2008, 06:16 PM
Robert Spanjaard
 
Default Can't Find a Supervisor

On Fri, 16 May 2008 12:51:39 -0500, Joseph wrote:

> I am trying to install avast from my desktop and this is what I get:
>
> ragweed@ragweed-den:~$ sudo apt-get install avast4workstation_1.0.8-2.deb
> E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to
> correct the problem.
> ragweed@ragweed-den:~$ dpkg --configure -a
> dpkg: requested operation requires superuser privilege

You forgot to use "sudo" in the second command.

--
Regards, Robert http://www.arumes.com



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-16-2008, 06:22 PM
Joseph
 
Default Can't Find a Supervisor

Leif Gregory wrote:
> On Fri, 16 May 2008 12:51:39 -0500
> Joseph <ubuntu@e-pops.org> wrote:
>
>> dpkg: requested operation requires superuser privilege
>> ragweed@ragweed-den:~$
>>
>> Ok, I thought I was the supervisor for this machine. How do I run it
>> as supervisor? Why should I have to run it as supervisor? I've
>> installed things before and didn't have to do it as a supervisor.
>
> Uhmmmm. Superuser, not supervisor. try putting 'su' before the command.
> e.g. su dpkg --configure -a
>
>


OK, you're right there.... my error. However, I'm still not getting my avast to install. My command is:

sudo dpkg apt-get install avast4workstation_1.0.8-2.deb

Am I missing something, or have something I don't need?

Joseph

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-16-2008, 06:35 PM
"Steve T"
 
Default Can't Find a Supervisor

On Fri, May 16, 2008 at 1:22 PM, Joseph <ubuntu@e-pops.org> wrote
> However, I'm still not getting my avast to install. My command is:
>
> sudo dpkg apt-get install avast4workstation_1.0.8-2.deb
>
I think you should try:
sudo dpkg --configure -a
then
sudo apt-get install avast4workstation_1.0.8-2.deb


--
"In a time of universal deceit, telling the truth is a revolutionary act!"
-- George Orwell (Eric Arthur Blair)

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-16-2008, 06:43 PM
Joseph
 
Default Can't Find a Supervisor

Steve T wrote:
> On Fri, May 16, 2008 at 1:22 PM, Joseph <ubuntu@e-pops.org> wrote
>> However, I'm still not getting my avast to install. My command is:
>>
>> sudo dpkg apt-get install avast4workstation_1.0.8-2.deb
>>
> I think you should try:
> sudo dpkg --configure -a
> then
> sudo apt-get install avast4workstation_1.0.8-2.deb
>
>

Good to a point. Here's my commands:

ragweed@ragweed-den:~$ sudo dpkg --configure -a
[sudo] password for ragweed:
Setting up ssl-cert (1.0.14-0ubuntu2.1) ...

Setting up transmission-common (1.06-0ubuntu5) ...
Setting up wine (0.9.59-0ubuntu5) ...

Setting up transmission-gtk (1.06-0ubuntu5) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
ragweed@ragweed-den:~$ sudo apt-get install avast4workstation_1.0.8-2.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package avast4workstation_1.0.8-2.deb
ragweed@ragweed-den:~$ sudo apt-get install /home/ragweed/Desktop/avast4workstation_1.0.8-2.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package
ragweed@ragweed-den:~$


I tried it plain because it seems to know to look on the desktop, then I entered the path to it.... and it doesn't find it.
Any ideas?

Joseph

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-16-2008, 06:59 PM
Leif Gregory
 
Default Can't Find a Supervisor

On Fri, 16 May 2008 13:43:19 -0500
Joseph <ubuntu@e-pops.org> wrote:

> >> sudo dpkg apt-get install avast4workstation_1.0.8-2.deb
> I tried it plain because it seems to know to look on the desktop,
> then I entered the path to it.... and it doesn't find it. Any ideas?

Just double-click avast4workstation_1.0.8-2.deb. It'll install itself.

--
Leif Gregory
Power Wagon Registry: http://powerwagonregistry.org
Truck Hacks: http://trucks.PCWize.com
Geocaching: http://gps.PCWize.com
PHP Tutorials and snippets: http://www.DevTek.org

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-16-2008, 06:59 PM
James Tappin
 
Default Can't Find a Supervisor

On Fri, 16 May 2008 13:43:19 -0500
Joseph <ubuntu@e-pops.org> wrote:

J> ragweed@ragweed-den:~$ sudo apt-get install
J> avast4workstation_1.0.8-2.deb Reading package lists... Done
J> Building dependency tree
J> Reading state information... Done
J> E: Couldn't find package avast4workstation_1.0.8-2.deb
J> ragweed@ragweed-den:~$ sudo apt-get install
J> /home/ragweed/Desktop/avast4workstation_1.0.8-2.deb Reading package
J> lists... Done Building dependency tree
J> Reading state information... Done
J> E: Couldn't find package
J> ragweed@ragweed-den:~$
J>
J>
J> I tried it plain because it seems to know to look on the desktop,
J> then I entered the path to it.... and it doesn't find it.
J> Any ideas?

apt-get looks in the repositories, if you want to install a local
packages the proper command is:
sudo dpkg -i /home/ragweed/Desktop/avast4workstation_1.0.8-2.deb

--
+------------------------+-------------------------------+---------+
| James Tappin | School of Physics & Astronomy | O__ |
| sjt@star.sr.bham.ac.uk | University of Birmingham | -- /` |
| Ph: 0121-414-6462. Fax: 0121-414-3722 | |
+--------------------------------------------------------+---------+

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-16-2008, 07:31 PM
Joseph
 
Default Can't Find a Supervisor

Robert Spanjaard wrote:


> On Fri, 16 May 2008 12:51:39 -0500, Joseph wrote:
>
>> I am trying to install avast from my desktop and this is what I get:
>>
>> ragweed@ragweed-den:~$ sudo apt-get install avast4workstation_1.0.8-2.deb
>> E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to
>> correct the problem.
>> ragweed@ragweed-den:~$ dpkg --configure -a
>> dpkg: requested operation requires superuser privilege
>
> You forgot to use "sudo" in the second command.
>


Got them.... it's now installed. It was the double click. Thanks everyone for the various commands.... and correct
syntax for them. I'll have to start saving these, or find an "Ubuntu for Dummies" book.... Is there a command manual for
people like me who is not all that knowledgeable?

I used to do Dos a little, and could program batch files and I even programed a little Q&A game once.... this is somewhat
like dos... but that was in my Windows 3.5 days.... <sigh>

Anyway, I'm wanting to learn...

Thanks again everyone.

Joseph


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-16-2008, 07:51 PM
Avi Greenbury
 
Default Can't Find a Supervisor

On Fri, 16 May 2008 14:31:23 -0500
Joseph <ubuntu@e-pops.org> wrote:

> Robert Spanjaard wrote:
>

> Got them.... it's now installed. It was the double click. Thanks everyone for the various commands.... and correct
> syntax for them. I'll have to start saving these, or find an "Ubuntu for Dummies" book.... Is there a command manual for
> people like me who is not all that knowledgeable?
>

Yes. Type
man <command>
for information about that command.
<command> --help
Generally gives usage hints.
There is, i do believe, a Ubuntu for Dummies book. There's certainly something similar. I've seen quite an explosion of Linux-newbie books in book shops, both online and in real life.
This is also pretty good (IMO) at explaining some of the differences between Linux and Windows:
http://linux.oneandoneis2.org/LNW.htm


> this is somewhat like dos...

Only if you use the command shell. Most jobs can be done with an incredibly long stream of mouse clicks, too

--
Avi Greenbury

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 01:36 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org