FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 04-26-2008, 04:27 PM
"drew einhorn"
 
Default Installing freenx on Hardy

Following these instructions:

**** http://ubuntuforums.org/showthread.php?t=620057

They were written for gutsy but it says it should work for hardy, too.



I'm stuck libxcomp3 and libxcomp2 conflict

nxproxy depends on libxcomp3
drew@drew5:~$ sudo apt-get install expect openssh-server tcl8.4 libxcomp2 libxcompext2 libxcompshad nxlibs nxagent nxproxy nxclient freenx-server


Reading package lists... Done
Building dependency tree******
Reading state information... Done
expect is already the newest version.
openssh-server is already the newest version.
tcl8.4 is already the newest version.


libxcomp2 is already the newest version.
libxcompext2 is already the newest version.
libxcompshad is already the newest version.
nxlibs is already the newest version.
nxagent is already the newest version.


nxproxy is already the newest version.
nxclient is already the newest version.
freenx-server is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:


* nxproxy: Depends: libxcomp3 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Okay, we will try that, again.

drew@drew5:~$ sudo apt-get -f install


Reading package lists... Done
Building dependency tree******
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
* libxcomp3
The following NEW packages will be installed:


* libxcomp3
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
11 not fully installed or removed.
Need to get 0B/381kB of archives.
After this operation, 1081kB of additional disk space will be used.


Do you want to continue [Y/n]? y
(Reading database ... 110638 files and directories currently installed.)
Unpacking libxcomp3 (from .../libxcomp3_3.1.0-6-2_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxcomp3_3.1.0-6-2_i386.deb (--unpack):


*trying to overwrite `/usr/lib/libXcomp.so.3.1.0', which is also in package libxcomp2
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
*/var/cache/apt/archives/libxcomp3_3.1.0-6-2_i386.deb


E: Sub-process /usr/bin/dpkg returned an error code (1)

Okay, let's try removing libxcomp2

drew@drew5:~$ sudo apt-get remove libxcomp2
Reading package lists... Done
Building dependency tree******


Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
* libxcompext2: Depends: libxcomp2 but it is not going to be installed


* nxagent: Depends: libxcomp2 but it is not going to be installed
* nxlibs: Depends: libxcomp2 but it is not going to be installed
* nxproxy: Depends: libxcomp3 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


That tries to remove more stuff.


Hmm.* Installed nxclient 3.2.0-9 just to see if anything came out in the wash: nope.
*
D'oh!* Let's just:

** Sudo apt-get remove nxproxy

That probably officially broke something.* That's ok it was broken

anyway.

What is broken from the nx client's perspective?*

*** remote smb shares?
*** remote printers?
******** Any printer?
******** Or just smb printers
*** anything else?


--

Drew Einhorn
--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 04-27-2008, 12:38 AM
NoOp
 
Default Installing freenx on Hardy

On 04/26/2008 09:27 AM, drew einhorn wrote:
> Following these instructions:
>
> http://ubuntuforums.org/showthread.php?t=620057
>
> They were written for gutsy but it says it should work for hardy, too.
>
> I'm stuck libxcomp3 and libxcomp2 conflict
>

I'm not sure about freenx as I've not tried it, but standard nx works
just fine out of the box for me on hardy. The only problem that I've had
is that the .Xauthority file in the home folder gets changed to root, so
I had to go back in and change it to user permissions.

If you'd like to give standard NX a try, uninstall anything that you may
have done for freenx (including the config files) and then:

sudo apt-get install --reinstall openssh-server

http://www.nomachine.com/download-package.php?Prod_Id=5
download all three: node, client, server

Follow the install instructions on that link - be sure you do it in
order: client, node, server:

sudo dpkg -i nxclient_3.2.0-9_i386.deb
sudo dpkg -i nxnode_3.2.0-5_i386.deb
sudo dpkg -i nxserver_3.2.0-7_i386.deb



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 10:03 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org