FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 04-25-2008, 04:16 PM
John Baker
 
Default sound troubles- kubuntu hardy

Hello,

I can't get any sound in Kubuntu and have no idea how the sound system
actually works.

LSPCI sees the sound chip as such:

00:06.1 Audio device: nVidia Corporation MCP55 High Definition Audio
(rev a2)

Relevent appearing lsmod section:

nd_pcm_oss 42144 0
snd_mixer_oss 17920 1 snd_pcm_oss
snd_pcm 78596 2 snd_hda_intel,snd_pcm_oss
snd_page_alloc 11400 2 snd_hda_intel,snd_pcm
snd_hwdep 10500 1 snd_hda_intel
snd_seq_dummy 4868 0
evdev 13056 3
parport_pc 36260 1
snd_seq_oss 35584 0
parport 37832 3 ppdev,lp,parport_pc
nvidia 7825536 44
psmouse 40336 0
serio_raw 7940 0
agpgart 34760 1 nvidia
snd_seq_midi 9376 0
snd_rawmidi 25760 1 snd_seq_midi
snd_seq_midi_event 8320 2 snd_seq_oss,snd_seq_midi
pcspkr 4224 0
k8temp 6656 0
snd_seq 54224 6
snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
snd_timer 24836 2 snd_pcm,snd_seq
snd_seq_device 9612 5
snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
shpchp 34452 0
pci_hotplug 30880 1 shpchp
snd 56996 15
snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,sn d_hwdep,snd_seq_dummy,snd_seq_oss,snd_rawmidi,snd_ seq,snd_timer,snd_seq_device
soundcore 8800 1 snd
button 9232 0
i2c_nforce2 7680 0
i2c_core 24832 2 nvidia,i2c_nforce2

It appears that programs think all the right drivers are loaded and try
to play something but no sound comes out.

I still have the Gutsy partition on another drive and tested it to be
sure that nothing was wrong with my cord or speakers. It worked there fine.

I installed over the old home partition with my home setting intact so I
thought perhaps that caused a problem but a new test user with default
hardy settings was not able to get sound either. (The new root partition
is brand new and included no old settings)

Does anybody have any troubleshooting ideas for me?

Thanks
--
John Baker
Network Systems Administrator
Marlboro College
Phone: 451-7551 off campus; 551 on campus

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 04-25-2008, 04:25 PM
Mario Vukelic
 
Default sound troubles- kubuntu hardy

On Fri, 2008-04-25 at 12:16 -0400, John Baker wrote:
>
> Does anybody have any troubleshooting ideas for me?

I'm not a Kubuntu user, but in Gnome it is important to make sure that

* The PulseAudio daemon is started. In Gnome this is done through
a compatibility layer that simulates esd, and therefore the
checkbox in System > Preferences > Sound > tab Sounds > Enable
software sound mixing (ESD)
* If possible, the preferences of all apps that use sound are set
to use PulseAudio
* The user is a member of the pulseaudio* groups


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 04-25-2008, 05:41 PM
John Baker
 
Default sound troubles- kubuntu hardy

Thanks, but its something lower down in the system. Apparently something
with the hda_intel driver. I disabled the onboard sound, put and old
soun blaster in and it works.

Mario Vukelic wrote:
> On Fri, 2008-04-25 at 12:16 -0400, John Baker wrote:
>> Does anybody have any troubleshooting ideas for me?
>
> I'm not a Kubuntu user, but in Gnome it is important to make sure that
>
> * The PulseAudio daemon is started. In Gnome this is done through
> a compatibility layer that simulates esd, and therefore the
> checkbox in System > Preferences > Sound > tab Sounds > Enable
> software sound mixing (ESD)
> * If possible, the preferences of all apps that use sound are set
> to use PulseAudio
> * The user is a member of the pulseaudio* groups
>
>


--
John Baker
Network Systems Administrator
Marlboro College
Phone: 451-7551 off campus; 551 on campus

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 07:17 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org