FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 09-01-2012, 02:12 PM
william drescher
 
Default unable to enumerate USB device: APCUSBD

I have a APC 750 with the usb port connected to a 12.04 Unbutu
system.


After about a day of operation I start getting the following error:

Aug 31 23:13:57 ubuntu3 kernel: [128564.632031] hub 2-0:1.0:
unable to enumerate USB device on port 3


Checking the syslog I find the following repeated over and over,
with the device number going up by one each time:


Aug 31 23:13:25 ubuntu3 kernel: [128532.951308] hub 2-0:1.0: port
3 disabled by hub (EMI?), re-enabling...
Aug 31 23:13:25 ubuntu3 kernel: [128532.952063] usb 2-3: USB
disconnect, device number 110
Aug 31 23:13:25 ubuntu3 kernel: [128532.952267] usb 2-3: ctrl urb
status -62 received
Aug 31 23:13:25 ubuntu3 kernel: [128533.260039] usb 2-3: new
low-speed USB device number 111 using ohci_hcd

...
Aug 31 23:13:27 ubuntu3 kernel: [128534.796543] generic-usb
0003:051D:0002.006F: hiddev0,hidraw2: USB HID v1.10 Device
[American Power Conversion Smart-UPS 750 FW:651.13.D USB FW:7.3]
on usb-0000:00:02.0-3/input0
Aug 31 23:13:33 ubuntu3 apcupsd[4213]: Communications with UPS
restored.

...
Aug 31 23:13:56 ubuntu3 kernel: [128563.596881] hub 2-0:1.0: port
3 disabled by hub (EMI?), re-enabling...
Aug 31 23:13:56 ubuntu3 kernel: [128563.597605] usb 2-3: USB
disconnect, device number 111
Aug 31 23:13:56 ubuntu3 kernel: [128563.597838] usb 2-3: ctrl urb
status -62 received
Aug 31 23:13:56 ubuntu3 kernel: [128563.900049] usb 2-3: new
low-speed USB device number 112 using ohci_hcd
Aug 31 23:13:56 ubuntu3 kernel: [128564.137852] usb 2-3: can't
set config #1, error -62
Aug 31 23:13:56 ubuntu3 kernel: [128564.138747] hub 2-0:1.0: port
3 disabled by hub (EMI?), re-enabling...
Aug 31 23:13:56 ubuntu3 kernel: [128564.139398] usb 2-3: USB
disconnect, device number 112


until it reverts to this error message


Aug 31 23:13:56 ubuntu3 kernel: [128564.384041] hub 2-0:1.0:
unable to enumerate USB device on port 3
Aug 31 23:13:57 ubuntu3 kernel: [128564.632031] hub 2-0:1.0:
unable to enumerate USB device on port 3

Aug 31 2

with the last message repeated 3 times a second after that.

Does this suggest a problem with the APC unit ? (it is directly
connected to the computer port) or a ubuntu issue ?


bill


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-05-2012, 04:32 PM
Tommy Trussell
 
Default unable to enumerate USB device: APCUSBD

On Sat, Sep 1, 2012 at 9:12 AM, william drescher <william@techservsys.com> wrote:

I have a APC 750 with the usb port connected to a 12.04 Unbutu system.



After about a day of operation I start getting the following error:



Aug 31 23:13:57 ubuntu3 kernel: [128564.632031] hub 2-0:1.0: unable to enumerate USB device on port 3



Checking the syslog I find the following repeated over and over, with the device number going up by one each time:



Aug 31 23:13:25 ubuntu3 kernel: [128532.951308] hub 2-0:1.0: port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:25 ubuntu3 kernel: [128532.952063] usb 2-3: USB disconnect, device number 110

Aug 31 23:13:25 ubuntu3 kernel: [128532.952267] usb 2-3: ctrl urb status -62 received

Aug 31 23:13:25 ubuntu3 kernel: [128533.260039] usb 2-3: new low-speed USB device number 111 using ohci_hcd

...

Aug 31 23:13:27 ubuntu3 kernel: [128534.796543] generic-usb 0003:051D:0002.006F: hiddev0,hidraw2: USB HID v1.10 Device [American Power Conversion Smart-UPS 750 FW:651.13.D USB FW:7.3] on usb-0000:00:02.0-3/input0

Aug 31 23:13:33 ubuntu3 apcupsd[4213]: Communications with UPS restored.

...

Aug 31 23:13:56 ubuntu3 kernel: [128563.596881] hub 2-0:1.0: port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:56 ubuntu3 kernel: [128563.597605] usb 2-3: USB disconnect, device number 111

Aug 31 23:13:56 ubuntu3 kernel: [128563.597838] usb 2-3: ctrl urb status -62 received

Aug 31 23:13:56 ubuntu3 kernel: [128563.900049] usb 2-3: new low-speed USB device number 112 using ohci_hcd

Aug 31 23:13:56 ubuntu3 kernel: [128564.137852] usb 2-3: can't set config #1, error -62

Aug 31 23:13:56 ubuntu3 kernel: [128564.138747] hub 2-0:1.0: port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:56 ubuntu3 kernel: [128564.139398] usb 2-3: USB disconnect, device number 112



until it reverts to this error message





Aug 31 23:13:56 ubuntu3 kernel: [128564.384041] hub 2-0:1.0: unable to enumerate USB device on port 3

Aug 31 23:13:57 ubuntu3 kernel: [128564.632031] hub 2-0:1.0: unable to enumerate USB device on port 3

Aug 31 2



with the last message repeated 3 times a second after that.



Does this suggest a problem with the APC unit ? (it is directly connected to the computer port) or a ubuntu issue ?



bill



I was curious about your question so I did a couple of Google searches and found a lot of reports of similar issues. I also have an APC UPS but I don't have anything connected to its USB port.

1) Was your Ubuntu 12.04 system upgraded from a previous version or a new install? A few of the reports indicated a problem with an old unsupported driver that could be disabled to eliminate the error.*

2) For diagnostic purposes, you might try connecting the UPS via a USB hub to see if the error messages go away. You might also try connecting a USB keyboard or mouse to the system (if you aren't using them already) to see if you get a similar message. Some hardware apparently has trouble supporting old slow USB devices.

3) Since you have the UPS connected to the USB port, do you also have some *special software that is monitoring it, or does the UPS port send a generic "power down" message after a period of time? If you are running some special software you might check to make sure it is compatible with Ubuntu 12.04. Have you recently tested the UPS shutdown by pulling the plug?

I don't have answers that might fix your issues, but I hope those questions (plus some searches of your own) get you closer to the answer.

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-06-2012, 02:52 PM
Tommy Trussell
 
Default unable to enumerate USB device: APCUSBD

On Thu, Sep 6, 2012 at 7:07 AM, bill <william@techservsys.com> wrote:






On 9/5/2012 12:32 PM, Tommy Trussell
wrote:


On Sat, Sep 1, 2012 at 9:12 AM, william drescher <william@techservsys.com>
wrote:



I have a APC 750 with the usb port connected to a 12.04 Unbutu
system.



After about a day of operation I start getting the following
error:



Aug 31 23:13:57 ubuntu3 kernel: [128564.632031] hub 2-0:1.0:
unable to enumerate USB device on port 3



Checking the syslog I find the following repeated over and
over, with the device number going up by one each time:



Aug 31 23:13:25 ubuntu3 kernel: [128532.951308] hub 2-0:1.0:
port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:25 ubuntu3 kernel: [128532.952063] usb 2-3: USB
disconnect, device number 110

Aug 31 23:13:25 ubuntu3 kernel: [128532.952267] usb 2-3: ctrl
urb status -62 received

Aug 31 23:13:25 ubuntu3 kernel: [128533.260039] usb 2-3: new
low-speed USB device number 111 using ohci_hcd

...

Aug 31 23:13:27 ubuntu3 kernel: [128534.796543] generic-usb
0003:051D:0002.006F: hiddev0,hidraw2: USB HID v1.10 Device
[American Power Conversion Smart-UPS 750 FW:651.13.D USB
FW:7.3] on usb-0000:00:02.0-3/input0

Aug 31 23:13:33 ubuntu3 apcupsd[4213]: Communications with UPS
restored.

...

Aug 31 23:13:56 ubuntu3 kernel: [128563.596881] hub 2-0:1.0:
port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:56 ubuntu3 kernel: [128563.597605] usb 2-3: USB
disconnect, device number 111

Aug 31 23:13:56 ubuntu3 kernel: [128563.597838] usb 2-3: ctrl
urb status -62 received

Aug 31 23:13:56 ubuntu3 kernel: [128563.900049] usb 2-3: new
low-speed USB device number 112 using ohci_hcd

Aug 31 23:13:56 ubuntu3 kernel: [128564.137852] usb 2-3: can't
set config #1, error -62

Aug 31 23:13:56 ubuntu3 kernel: [128564.138747] hub 2-0:1.0:
port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:56 ubuntu3 kernel: [128564.139398] usb 2-3: USB
disconnect, device number 112



until it reverts to this error message





Aug 31 23:13:56 ubuntu3 kernel: [128564.384041] hub 2-0:1.0:
unable to enumerate USB device on port 3

Aug 31 23:13:57 ubuntu3 kernel: [128564.632031] hub 2-0:1.0:
unable to enumerate USB device on port 3

Aug 31 2



with the last message repeated 3 times a second after that.



Does this suggest a problem with the APC unit ? (it is
directly connected to the computer port) or a ubuntu issue ?



bill










I was curious about your question so I did a couple of
Google searches and found a lot of reports of similar issues.
I also have an APC UPS but I don't have anything connected to
its USB port.



1) Was your Ubuntu 12.04 system upgraded from a previous
version or a new install? A few of the reports indicated a
problem with an old unsupported driver that could be disabled
to eliminate the error.




it was an upgrade.






2) For diagnostic purposes, you might try connecting the
UPS via a USB hub to see if the error messages go away. You
might also try connecting a USB keyboard or mouse to the
system (if you aren't using them already) to see if you get a
similar message. Some hardware apparently has trouble
supporting old slow USB devices.


good idea






3) Since you have the UPS connected to the USB port, do you
also have some *special software that is monitoring it, or does
the UPS port send a generic "power down" message after a period
of time? If you are running some special software you might
check to make sure it is compatible with Ubuntu 12.04. Have you
recently tested the UPS shutdown by pulling the plug?

I use APCUPSD.* It works fine on the other 2 servers that I just
upgraded.

If the UPS is not communicating, I can not test the shutdown.



The thing that bothers me the most is the "port 3 disabled by hub
(EMI?)" which makes me suspect the UPS





I don't have answers that might fix your issues, but I hope
those questions (plus some searches of your own) get you closer
to the answer.




thanks





Based on your responses I would look at disabling ehci_hcd -- here are a couple of examples from my Google search:

http://www.geekdevs.com/2010/04/solved-unable-to-enumerate-usb-device-disabling-ehci_hcd/

http://uucode.com/blog/2011/01/18/solved-unable-to-enumerate-usb-device-on-port-1/
I have never tried APCUPSD on my hardware... but you might also scan through the known issues:

http://www.apcupsd.org/manual/manual.html#known-linux-usb-issues
--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-06-2012, 03:20 PM
 
Default unable to enumerate USB device: APCUSBD

all this is beyond me, didn't know what I was getting into when I signed up.** How do I stop getting all these emails?



From: "Tommy Trussell" <tommy.trussell@gmail.com>
To: "bill" <william@techservsys.com>
Cc: "Ubuntu user technical support, not for general discussions" <ubuntu-users@lists.ubuntu.com>
Sent: Thursday, September 6, 2012 9:52:57 AM
Subject: Re: unable to enumerate USB device: APCUSBD



On Thu, Sep 6, 2012 at 7:07 AM, bill <william@techservsys.com> wrote:






On 9/5/2012 12:32 PM, Tommy Trussell
wrote:


On Sat, Sep 1, 2012 at 9:12 AM, william drescher <william@techservsys.com>
wrote:



I have a APC 750 with the usb port connected to a 12.04 Unbutu
system.



After about a day of operation I start getting the following
error:



Aug 31 23:13:57 ubuntu3 kernel: [128564.632031] hub 2-0:1.0:
unable to enumerate USB device on port 3



Checking the syslog I find the following repeated over and
over, with the device number going up by one each time:



Aug 31 23:13:25 ubuntu3 kernel: [128532.951308] hub 2-0:1.0:
port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:25 ubuntu3 kernel: [128532.952063] usb 2-3: USB
disconnect, device number 110

Aug 31 23:13:25 ubuntu3 kernel: [128532.952267] usb 2-3: ctrl
urb status -62 received

Aug 31 23:13:25 ubuntu3 kernel: [128533.260039] usb 2-3: new
low-speed USB device number 111 using ohci_hcd

...

Aug 31 23:13:27 ubuntu3 kernel: [128534.796543] generic-usb
0003:051D:0002.006F: hiddev0,hidraw2: USB HID v1.10 Device
[American Power Conversion Smart-UPS 750 FW:651.13.D USB
FW:7.3] on usb-0000:00:02.0-3/input0

Aug 31 23:13:33 ubuntu3 apcupsd[4213]: Communications with UPS
restored.

...

Aug 31 23:13:56 ubuntu3 kernel: [128563.596881] hub 2-0:1.0:
port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:56 ubuntu3 kernel: [128563.597605] usb 2-3: USB
disconnect, device number 111

Aug 31 23:13:56 ubuntu3 kernel: [128563.597838] usb 2-3: ctrl
urb status -62 received

Aug 31 23:13:56 ubuntu3 kernel: [128563.900049] usb 2-3: new
low-speed USB device number 112 using ohci_hcd

Aug 31 23:13:56 ubuntu3 kernel: [128564.137852] usb 2-3: can't
set config #1, error -62

Aug 31 23:13:56 ubuntu3 kernel: [128564.138747] hub 2-0:1.0:
port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:56 ubuntu3 kernel: [128564.139398] usb 2-3: USB
disconnect, device number 112



until it reverts to this error message





Aug 31 23:13:56 ubuntu3 kernel: [128564.384041] hub 2-0:1.0:
unable to enumerate USB device on port 3

Aug 31 23:13:57 ubuntu3 kernel: [128564.632031] hub 2-0:1.0:
unable to enumerate USB device on port 3

Aug 31 2



with the last message repeated 3 times a second after that.



Does this suggest a problem with the APC unit ? (it is
directly connected to the computer port) or a ubuntu issue ?



bill










I was curious about your question so I did a couple of
Google searches and found a lot of reports of similar issues.
I also have an APC UPS but I don't have anything connected to
its USB port.



1) Was your Ubuntu 12.04 system upgraded from a previous
version or a new install? A few of the reports indicated a
problem with an old unsupported driver that could be disabled
to eliminate the error.




it was an upgrade.






2) For diagnostic purposes, you might try connecting the
UPS via a USB hub to see if the error messages go away. You
might also try connecting a USB keyboard or mouse to the
system (if you aren't using them already) to see if you get a
similar message. Some hardware apparently has trouble
supporting old slow USB devices.


good idea






3) Since you have the UPS connected to the USB port, do you
also have some *special software that is monitoring it, or does
the UPS port send a generic "power down" message after a period
of time? If you are running some special software you might
check to make sure it is compatible with Ubuntu 12.04. Have you
recently tested the UPS shutdown by pulling the plug?

I use APCUPSD.* It works fine on the other 2 servers that I just
upgraded.

If the UPS is not communicating, I can not test the shutdown.



The thing that bothers me the most is the "port 3 disabled by hub
(EMI?)" which makes me suspect the UPS





I don't have answers that might fix your issues, but I hope
those questions (plus some searches of your own) get you closer
to the answer.




thanks





Based on your responses I would look at disabling ehci_hcd -- here are a couple of examples from my Google search:

http://www.geekdevs.com/2010/04/solved-unable-to-enumerate-usb-device-disabling-ehci_hcd/

http://uucode.com/blog/2011/01/18/solved-unable-to-enumerate-usb-device-on-port-1/
I have never tried APCUPSD on my hardware... but you might also scan through the known issues:

http://www.apcupsd.org/manual/manual.html#known-linux-usb-issues

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-06-2012, 04:03 PM
Tommy Trussell
 
Default unable to enumerate USB device: APCUSBD

at the bottom of every message is a reminder:
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at:*https://lists.ubuntu.com/mailman/listinfo/ubuntu-users


Click that link and choose to unsubscribe.*
You might find the Ubuntu Forums more manageable.*

On Thu, Sep 6, 2012 at 10:20 AM, <spoonplug36@comcast.net> wrote:

all this is beyond me, didn't know what I was getting into when I signed up.** How do I stop getting all these emails?




From: "Tommy Trussell" <tommy.trussell@gmail.com>
To: "bill" <william@techservsys.com>

Cc: "Ubuntu user technical support, not for general discussions" <ubuntu-users@lists.ubuntu.com>
Sent: Thursday, September 6, 2012 9:52:57 AM

Subject: Re: unable to enumerate USB device: APCUSBD



On Thu, Sep 6, 2012 at 7:07 AM, bill <william@techservsys.com> wrote:







On 9/5/2012 12:32 PM, Tommy Trussell
wrote:


On Sat, Sep 1, 2012 at 9:12 AM, william drescher <william@techservsys.com>
wrote:



I have a APC 750 with the usb port connected to a 12.04 Unbutu
system.



After about a day of operation I start getting the following
error:



Aug 31 23:13:57 ubuntu3 kernel: [128564.632031] hub 2-0:1.0:
unable to enumerate USB device on port 3



Checking the syslog I find the following repeated over and
over, with the device number going up by one each time:



Aug 31 23:13:25 ubuntu3 kernel: [128532.951308] hub 2-0:1.0:
port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:25 ubuntu3 kernel: [128532.952063] usb 2-3: USB
disconnect, device number 110

Aug 31 23:13:25 ubuntu3 kernel: [128532.952267] usb 2-3: ctrl
urb status -62 received

Aug 31 23:13:25 ubuntu3 kernel: [128533.260039] usb 2-3: new
low-speed USB device number 111 using ohci_hcd

...

Aug 31 23:13:27 ubuntu3 kernel: [128534.796543] generic-usb
0003:051D:0002.006F: hiddev0,hidraw2: USB HID v1.10 Device
[American Power Conversion Smart-UPS 750 FW:651.13.D USB
FW:7.3] on usb-0000:00:02.0-3/input0

Aug 31 23:13:33 ubuntu3 apcupsd[4213]: Communications with UPS
restored.

...

Aug 31 23:13:56 ubuntu3 kernel: [128563.596881] hub 2-0:1.0:
port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:56 ubuntu3 kernel: [128563.597605] usb 2-3: USB
disconnect, device number 111

Aug 31 23:13:56 ubuntu3 kernel: [128563.597838] usb 2-3: ctrl
urb status -62 received

Aug 31 23:13:56 ubuntu3 kernel: [128563.900049] usb 2-3: new
low-speed USB device number 112 using ohci_hcd

Aug 31 23:13:56 ubuntu3 kernel: [128564.137852] usb 2-3: can't
set config #1, error -62

Aug 31 23:13:56 ubuntu3 kernel: [128564.138747] hub 2-0:1.0:
port 3 disabled by hub (EMI?), re-enabling...

Aug 31 23:13:56 ubuntu3 kernel: [128564.139398] usb 2-3: USB
disconnect, device number 112



until it reverts to this error message





Aug 31 23:13:56 ubuntu3 kernel: [128564.384041] hub 2-0:1.0:
unable to enumerate USB device on port 3

Aug 31 23:13:57 ubuntu3 kernel: [128564.632031] hub 2-0:1.0:
unable to enumerate USB device on port 3

Aug 31 2



with the last message repeated 3 times a second after that.



Does this suggest a problem with the APC unit ? (it is
directly connected to the computer port) or a ubuntu issue ?



bill










I was curious about your question so I did a couple of
Google searches and found a lot of reports of similar issues.
I also have an APC UPS but I don't have anything connected to
its USB port.



1) Was your Ubuntu 12.04 system upgraded from a previous
version or a new install? A few of the reports indicated a
problem with an old unsupported driver that could be disabled
to eliminate the error.




it was an upgrade.






2) For diagnostic purposes, you might try connecting the
UPS via a USB hub to see if the error messages go away. You
might also try connecting a USB keyboard or mouse to the
system (if you aren't using them already) to see if you get a
similar message. Some hardware apparently has trouble
supporting old slow USB devices.


good idea






3) Since you have the UPS connected to the USB port, do you
also have some *special software that is monitoring it, or does
the UPS port send a generic "power down" message after a period
of time? If you are running some special software you might
check to make sure it is compatible with Ubuntu 12.04. Have you
recently tested the UPS shutdown by pulling the plug?

I use APCUPSD.* It works fine on the other 2 servers that I just
upgraded.

If the UPS is not communicating, I can not test the shutdown.



The thing that bothers me the most is the "port 3 disabled by hub
(EMI?)" which makes me suspect the UPS





I don't have answers that might fix your issues, but I hope
those questions (plus some searches of your own) get you closer
to the answer.




thanks





Based on your responses I would look at disabling ehci_hcd -- here are a couple of examples from my Google search:


http://www.geekdevs.com/2010/04/solved-unable-to-enumerate-usb-device-disabling-ehci_hcd/


http://uucode.com/blog/2011/01/18/solved-unable-to-enumerate-usb-device-on-port-1/

I have never tried APCUPSD on my hardware... but you might also scan through the known issues:

http://www.apcupsd.org/manual/manual.html#known-linux-usb-issues

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users


--

ubuntu-users mailing list

ubuntu-users@lists.ubuntu.com

Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users




--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 12:46 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org