FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 08-24-2012, 02:37 PM
Nils Kassube
 
Default problems with 10.04 upgrade to 12.04

Dave Howorth wrote:
> I have a 10.04 machine that I just tried to upgrade to 12.04. I used
> update-manager-text. It ran and at the end said something like
> 'upgrade completed but there were errors'. Unhelpfully, it didn't
> give me the option to see the errors or tell me where it keeps a log
> etc.

> I rebooted and the system came up but via a partly broken boot
> process. I appear now to be back in 10.04 and the system warns me
> there are 52 broken packages. But the simple commands I've done so
> far have been OK.
>
> How do I:
> - find out what went wrong

Have a look at the log files in "/var/log/dist-upgrade/". There might be
a hint in one of the files, but I can't tell you what to look for.

> - set about fixing broken things
> - set about completing the upgrade

Did you try these commands alreadY?

sudo dpkg --configure -a
sudo apt-get install -f

If that doesn't work, what are the error messages of these commands?


Nils

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-24-2012, 03:34 PM
Dave Howorth
 
Default problems with 10.04 upgrade to 12.04

Nils Kassube wrote:
> Dave Howorth wrote:
>> I have a 10.04 machine that I just tried to upgrade to 12.04. I used
>> update-manager-text. It ran and at the end said something like
>> 'upgrade completed but there were errors'. Unhelpfully, it didn't
>> give me the option to see the errors or tell me where it keeps a log
>> etc.
>
>> I rebooted and the system came up but via a partly broken boot
>> process. I appear now to be back in 10.04 and the system warns me
>> there are 52 broken packages. But the simple commands I've done so
>> far have been OK.
>>
>> How do I:
>> - find out what went wrong
>
> Have a look at the log files in "/var/log/dist-upgrade/". There might be
> a hint in one of the files, but I can't tell you what to look for.

Well there are many large files:

# wc *
wc: 20120824-1416: Is a directory
0 0 0 20120824-1416
wc: 20120824-1418: Is a directory
0 0 0 20120824-1418
2542 14126 626870 apt-clone_system_state.tar.gz
1564 11845 108076 apt.log
996 10752 101898 apt-term.log
7 7497 129694 history.log
14 195 1583 lspci.txt
190 4526 61327 main.log
4545 186909 1941160 screenlog.0
1911 10084 457824 system_state.tar.gz
2 5 74 xorg_fixup.log
11771 245939 3428506 total


Several logs mention errors but nothing that leaps out at me. The
clearest appearing to me comes at the end of screenlog.0:

Errors were encountered while processing:
libexempi3
gdm
libgssapi-krb5-2
libclutter-gtk-1.0-0
libgssrpc4
krb5-multidev
brasero
gnome-keyring
gnome-control-center
gnome-session
nautilus-sendto-empathy
libkadm5srv-mit8
smbclient
plymouth
python-gobject
openssh-server
nautilus
gvfs
libkadm5clnt-mit8
lxdm
alsa-utils
libkdb5-6
libkrb5-dev
openssh-client
nautilus-sendto
pulseaudio
pulseaudio-module-bluetooth
pulseaudio-module-x11
plymouth-x11
pulseaudio-module-gconf
plymouth-label
pulseaudio-esound-compat

Upgrade complete

The upgrade has completed but there were errors during the upgrade
process.

>> - set about fixing broken things
>> - set about completing the upgrade
>
> Did you try these commands alreadY?
>
> sudo dpkg --configure -a

Produced masses of output that finished with:

Processing triggers for libgdk-pixbuf2.0-0 ...
Errors were encountered while processing:
python-aptdaemon
python-gnome2
python-twisted-bin
python-dbus
libwebkitgtk-1.0-0
libscalar-list-utils-perl
python-zope.interface
libxml-sax-perl
python-defer
lsb-release
computer-janitor
python-gi
python-software-properties
brasero
vim-gnome
libpurple0
gnome-keyring
gdebi-core
python-gdbm
python-aptdaemon.gtk3widgets
libcupsmime1
update-manager-core
gnome-games
python-pycurl
python-cairo
gnome-control-center
python-pyorbit
perlmagick
python-vte
python-gobject-2
nautilus-sendto-empathy
python-glade2
gnome-codec-install
python-problem-report
python-aptdaemon.gtkwidgets
python-webkit
python-gnomekeyring
python-gtksourceview2
ufw
python-rsvg
command-not-found
python-gtk2
python-gobject
nautilus
lxdm
python-chardet
python-simplejson
python-xapian
python-pam
software-properties-common
python-twisted-core
Processing was halted because there were too many errors.


> sudo apt-get install -f

# apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer
required:
libhsqldb-java-gcj libpeas-common libgettext-ruby1.8 python-opengl
xserver-xorg-input-evdev gir1.2-json-1.0 libncurses-ruby1.8
libdaemons-ruby1.8 libhpricot-ruby1.8 libhtmlentities-ruby1.8
libglade2-ruby1.8 python-mako linux-headers-2.6.32-40
linux-headers-2.6.32-41 libgconf2-ruby libamazon-ruby libkadm5clnt-mit7
gir1.2-gst-plugins-base-0.10 linux-headers-2.6.32-41-generic libdiscid0
libmmap-ruby1.8 gir1.2-gstreamer-0.10 xserver-xorg-input-wacom
gir1.2-clutter-1.0 libgraphite3 rhythmbox bsh-gcj libhtmlentities-ruby
libzoom-ruby librack-ruby1.8 xserver-xorg-input-vmmouse libindicate-gtk2
xserver-xorg-input-mouse xserver-common libatk1-ruby1.8 python-gtkglext1
libcmdparse2-ruby1.8 libapache2-mod-passenger libzoom-ruby1.8
libaccess-bridge-java-jni libvisio-0.0-0 libeggdbus-1-0 libglade2-ruby
libgnome2-ruby1.8 libcommons-httpclient-java libaccess-bridge-java
libredcloth-ruby1.8 libfcgi0ldbl libdirectfb-extra libsysfs-dev seed
libbreakpoint-ruby1.8 libruby libseed-gtk3-0 rhythmbox-data
xserver-xorg-core libruby1.8-extras libnokogiri-ruby1.8 libdirectfb-dev
libdmapsharing-3.0-2 libx264-85 libgnomecanvas2-ruby1.8 libpeas-1.0-0
libsqlite3-ruby libmp3lame0 bsh rhythmbox-plugin-cdrecorder
libcommons-codec-java librhythmbox-core5 xserver-xorg-input-all
libxcb-render-util0-dev libmocha-ruby libyaz3 libgnome2-ruby
libgconf2-ruby1.8 librevolution-ruby libgirepository1.0-0 libglib2-ruby1.8
liblzo2-2 libmocha-ruby1.8 libhpricot-ruby libcairo-ruby1.8
gnome-js-common
libimage-size-ruby1.8 librevolution-ruby1.8 libgdk-pixbuf2-ruby1.8
libmpfr1ldbl gir1.2-rb-3.0 libkadm5srv-mit7 xserver-xorg-video-geode
linux-headers-2.6.32-40-generic rubygems1.8 liblocale-ruby1.8
libart2-ruby1.8 libgtk2-ruby1.8 gir1.2-cogl-1.0 libkdb5-4 libfcgi-ruby1.8
libcommons-lang-java libgraphite2-2.0.0 liblog4r-ruby1.8 intel-gpu-tools
xserver-xorg-input-synaptics libredcloth-ruby libgtkglext1
gir1.2-coglpango-1.0 libmpcdec3 freeglut3 libpango1-ruby1.8
libwww-mechanize-ruby gir1.2-peas-1.0 libwww-mechanize-ruby1.8
libmusicbrainz3-6 libxml-simple-ruby
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
acl aisleriot alacarte apg colord cups-bsd cups-client cups-filters
cups-ppdc empathy empathy-common evolution-data-server
evolution-data-server-common folks-common gimp gimp-data
gir1.2-appindicator3-0.1 gir1.2-clutter-1.0 gir1.2-cogl-1.0
gir1.2-coglpango-1.0 gir1.2-gst-plugins-base-0.10 gir1.2-gstreamer-0.10
gir1.2-gtk-2.0 gir1.2-javascriptcoregtk-3.0 gir1.2-json-1.0
gir1.2-notify-0.7 gir1.2-peas-1.0 gir1.2-rb-3.0 gir1.2-soup-2.4
gir1.2-webkit-3.0 git git-core git-man glchess glines gnect gnibbles
gnobots2 gnome-control-center-data gnome-games-data gnome-games-extra-data
gnome-icon-theme-symbolic gnome-mag gnome-menus gnome-sudoku gnomine
gnotravex gnotski gnuchess gnuchess-book grub-gfxpayload-lists grub-pc
grub-pc-bin grub2-common gstreamer0.10-nice gstreamer0.10-plugins-base
gstreamer0.10-plugins-good gtali gtk2-engines-pixbuf gtk2.0-examples iagno
imagemagick-common indicator-sound jockey-common jockey-gtk
libapparmor-perl
libapparmor1 libappindicator1 libapt-pkg-perl libatk1.0-dev libatspi1.0-0
libbit-vector-perl libcairo-perl libcamel-1.2-29 libcap2-bin
libcarp-clan-perl libclass-isa-perl libcompress-bzip2-perl libcups2
libcupsfilters1 libcurl3-nss libdate-calc-perl libdbd-mysql-perl
libdbd-sqlite3-perl libdbi-perl libdbusmenu-gtk4 libdiscid0
libdmapsharing-3.0-2 libebackend-1.2-1 libebook-1.2-12 libecal-1.2-10
libedata-book-1.2-11 libedata-cal-1.2-13 libedataserver-1.2-15
libfarstream-0.1-0 libfolks-eds25 libfolks-telepathy25 libfolks25
libgck-1-0
libgcr-3-1 libgcr-3-common libgdata13 libgdk-pixbuf2.0-dev
libgettext-ruby1.8 libgimp2.0 libglib-perl libglib2.0-bin libglib2.0-dev
libgnome-control-center1 libgnome-menu-3-0 libgnome2-canvas-perl
libgnome2-perl libgnome2-vfs-perl libgoa-1.0-0 libgoa-1.0-common
libgssdp-1.0-3 libgstreamer-plugins-base0.10-0 libgstreamer0.10-0
libgtk2-perl libgtk2.0-dev libgupnp-1.0-4 libgupnp-igd-1.0-4
libgweather-3-0
libhtml-parser-perl libical0 libido3-0.1-0 libindicate-gtk3 libindicate5
libindicator7 libio-pty-perl libjson-xs-perl
liblaunchpad-integration-3.0-1
liblocale-gettext-perl liblouis2 liblqr-1-0 libmagickcore4
libmemcache-client-ruby libmemcache-client-ruby1.8
libmission-control-plugins0 libmng1 libmusicbrainz3-6 libmysqlclient18
libnet-dbus-perl libnewt0.52 libnice10 libnih-dbus1 libnih1 liboauth0
libpadwalker-perl libpam-cap libpango-perl libpango1.0-dev
libparams-validate-perl libpcre3-dev libpcrecpp0 libpeas-1.0-0
libpeas-common libperl5.14 libpoppler-glib8 libpoppler19 libpython2.7
librack-ruby librack-ruby1.8 librest-0.7-0 librhythmbox-core5 libruby1.8
libseed-gtk3-0 libsnmp-base libsnmp15 libsub-name-perl libsvn-perl
libswitch-perl libtelepathy-farstream2 libtelepathy-glib0
libtelepathy-logger2 libtemplate-perl libterm-readkey-perl
libtext-charwidth-perl libtext-iconv-perl libtzinfo-ruby libtzinfo-ruby1.8
libuuid-perl libvisual-0.4-0 libvisual-0.4-plugins libwebkitgtk-3.0-0
libwebkitgtk-3.0-common libwmf0.2-7-gtk libxklavier16 libxml-libxml-perl
libxml-parser-perl libxml-sax-base-perl libzeitgeist-1.0-1 lightsoff
mahjongg mysql-client-5.5 mysql-client-core-5.5 mysql-common mysql-server
mysql-server-5.5 mysql-server-core-5.5 nautilus-data
network-manager-pptp-gnome perl perl-base perl-modules python
python-appindicator python-apport python-brlapi python-cups python-fuse
python-gi-cairo python-gmenu python-gtkspell python-launchpad-integration
python-louis python-minimal python-newt python-smbc python-support
python-zeitgeist python2.7 python2.7-minimal quadrapassel rails redmine
rhythmbox rhythmbox-data rhythmbox-plugin-cdrecorder ruby
ruby-actionmailer-2.3 ruby-actionpack-2.3 ruby-activerecord-2.3
ruby-activeresource-2.3 ruby-activesupport-2.3 ruby-coderay ruby-i18n
ruby-net-ldap ruby-rack ruby-rails-2.3 ruby-rchardet ruby-text-format
ruby-tmail ruby1.8 rubygems rubygems1.8 seed swell-foop swish-e
swish-e-dev
tcl8.5 telepathy-indicator telepathy-logger telepathy-mission-control-5
update-manager-text vim vim-common vim-gui-common vim-runtime vim-tiny
zeitgeist zeitgeist-core zeitgeist-datahub
Suggested packages:
xpp empathy-call evolution evolution-data-server-dbg gimp-help-en
gimp-help
gimp-data-extras git-daemon-run git-daemon-sysvinit git-doc git-el
git-arch
git-cvs git-svn git-email git-gui gitk gitweb xboard eboard desktop-base
libfont-freetype-perl libcap-dev libglib2.0-doc libgtk2-perl-doc
libgtk2.0-doc libdata-dump-perl libmagickcore4-extra libpango1.0-doc
poppler-data snmp-mibs-downloader libtemplate-perl-doc
libtemplate-plugin-gd-perl libtemplate-plugin-xml-perl tinyca
libterm-readline-gnu-perl libterm-readline-perl-perl libpod-plainer-perl
python-doc python-tk python-launchpad-integration-dbg python2.7-doc
libsvn-ruby ruby-rmagick libopenid-ruby gstreamer0.10-plugins-bad ri
ruby-dev ruby1.8-examples ri1.8 libmp3-tag-perl hypermail wv catdoc
tclreadline ctags vim-doc vim-scripts indent
Recommended packages:
libdate-calc-xs-perl rhythmbox-mozilla rhythmbox-plugin-zeitgeist
ruby1.8-dev
The following packages will be REMOVED:
capplets-data doc-base gir1.0-clutter-1.0 gir1.0-clutter-gtk-0.10
gir1.0-gconf-2.0 gir1.0-gstreamer-0.10 gir1.0-gtk-2.0 gnome-games-common
gnome-mahjongg irb irb1.8 libbrasero-media0 libdigest-sha1-perl
libgstfarsight0.10-0 libgv-perl libopenssl-ruby1.8 libperl5.10
libreadline-ruby1.8 libseed0 libtelepathy-farsight0 mysql-client-5.1
mysql-client-core-5.1 mysql-server-5.1 mysql-server-core-5.1
python-gnomeapplet python-sexy rdoc rdoc1.8 rhythmbox-plugins
The following NEW packages will be installed:
acl apg colord cups-filters cups-ppdc evolution-data-server folks-common
gir1.2-appindicator3-0.1 gir1.2-clutter-1.0 gir1.2-cogl-1.0
gir1.2-coglpango-1.0 gir1.2-gst-plugins-base-0.10 gir1.2-gstreamer-0.10
gir1.2-gtk-2.0 gir1.2-javascriptcoregtk-3.0 gir1.2-json-1.0
gir1.2-notify-0.7 gir1.2-peas-1.0 gir1.2-rb-3.0 gir1.2-soup-2.4
gir1.2-webkit-3.0 git git-man gnome-control-center-data gnome-games-data
gnome-games-extra-data gnome-icon-theme-symbolic gnuchess gnuchess-book
grub-gfxpayload-lists grub-pc-bin grub2-common imagemagick-common
libappindicator1 libcamel-1.2-29 libcap2-bin libclass-isa-perl
libcupsfilters1 libcurl3-nss libdbusmenu-gtk4 libdiscid0
libdmapsharing-3.0-2 libebackend-1.2-1 libebook-1.2-12 libecal-1.2-10
libedata-book-1.2-11 libedata-cal-1.2-13 libedataserver-1.2-15
libfarstream-0.1-0 libfolks-eds25 libfolks-telepathy25 libfolks25
libgck-1-0
libgcr-3-1 libgcr-3-common libgdata13 libgdk-pixbuf2.0-dev libglib2.0-bin
libgnome-control-center1 libgnome-menu-3-0 libgoa-1.0-0 libgoa-1.0-common
libgssdp-1.0-3 libgupnp-1.0-4 libgupnp-igd-1.0-4 libgweather-3-0
libido3-0.1-0 libindicate-gtk3 libindicate5 libindicator7
liblaunchpad-integration-3.0-1 liblouis2 liblqr-1-0 libmagickcore4
libmemcache-client-ruby libmemcache-client-ruby1.8
libmission-control-plugins0 libmusicbrainz3-6 libmysqlclient18 libnice10
liboauth0 libpam-cap libpcre3-dev libpcrecpp0 libpeas-1.0-0 libpeas-common
libperl5.14 libpoppler-glib8 libpoppler19 libpython2.7 librest-0.7-0
librhythmbox-core5 libseed-gtk3-0 libswitch-perl libtelepathy-farstream2
libtelepathy-logger2 libtzinfo-ruby libtzinfo-ruby1.8 libwebkitgtk-3.0-0
libwebkitgtk-3.0-common libxml-sax-base-perl libzeitgeist-1.0-1 mahjongg
mysql-client-5.5 mysql-client-core-5.5 mysql-server-5.5
mysql-server-core-5.5 python-gi-cairo python-zeitgeist python2.7
python2.7-minimal rhythmbox-data ruby-actionmailer-2.3 ruby-actionpack-2.3
ruby-activerecord-2.3 ruby-activeresource-2.3 ruby-activesupport-2.3
ruby-coderay ruby-i18n ruby-net-ldap ruby-rack ruby-rails-2.3
ruby-rchardet
ruby-text-format ruby-tmail tcl8.5 telepathy-indicator telepathy-logger
zeitgeist zeitgeist-core zeitgeist-datahub
The following packages will be upgraded:
aisleriot alacarte cups-bsd cups-client empathy empathy-common
evolution-data-server-common gimp gimp-data git-core glchess glines gnect
gnibbles gnobots2 gnome-mag gnome-menus gnome-sudoku gnomine gnotravex
gnotski grub-pc gstreamer0.10-nice gstreamer0.10-plugins-base
gstreamer0.10-plugins-good gtali gtk2-engines-pixbuf gtk2.0-examples iagno
indicator-sound jockey-common jockey-gtk libapparmor-perl libapparmor1
libapt-pkg-perl libatk1.0-dev libatspi1.0-0 libbit-vector-perl
libcairo-perl
libcarp-clan-perl libcompress-bzip2-perl libcups2 libdate-calc-perl
libdbd-mysql-perl libdbd-sqlite3-perl libdbi-perl libgettext-ruby1.8
libgimp2.0 libglib-perl libglib2.0-dev libgnome2-canvas-perl
libgnome2-perl
libgnome2-vfs-perl libgstreamer-plugins-base0.10-0 libgstreamer0.10-0
libgtk2-perl libgtk2.0-dev libhtml-parser-perl libical0 libio-pty-perl
libjson-xs-perl liblocale-gettext-perl libmng1 libnet-dbus-perl
libnewt0.52
libnih-dbus1 libnih1 libpadwalker-perl libpango-perl libpango1.0-dev
libparams-validate-perl librack-ruby librack-ruby1.8 libruby1.8
libsnmp-base
libsnmp15 libsub-name-perl libsvn-perl libtelepathy-glib0 libtemplate-perl
libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl
libuuid-perl
libvisual-0.4-0 libvisual-0.4-plugins libwmf0.2-7-gtk libxklavier16
libxml-libxml-perl libxml-parser-perl lightsoff mysql-common mysql-server
nautilus-data network-manager-pptp-gnome perl perl-base perl-modules
python
python-appindicator python-apport python-brlapi python-cups python-fuse
python-gmenu python-gtkspell python-launchpad-integration python-louis
python-minimal python-newt python-smbc python-support quadrapassel rails
redmine rhythmbox rhythmbox-plugin-cdrecorder ruby ruby1.8 rubygems
rubygems1.8 seed swell-foop swish-e swish-e-dev
telepathy-mission-control-5
update-manager-text vim vim-common vim-gui-common vim-runtime vim-tiny
132 upgraded, 131 newly installed, 29 to remove and 1125 not upgraded.
191 not fully installed or removed.
Need to get 0B/131MB of archives.
After this operation, 4248kB of additional disk space will be used.
Do you want to continue [Y/n]? n


> If that doesn't work, what are the error messages of these commands?


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-24-2012, 04:18 PM
Dave Howorth
 
Default problems with 10.04 upgrade to 12.04

Dave Howorth wrote:
> After this operation, 4248kB of additional disk space will be used.
> Do you want to continue [Y/n]? n

If I say yes to that question, it says:

E: Could not perform immediate configuration on 'python-minimal'.Please
see man 5 apt.conf under APT::Immediate-Configure for details. (2)

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-24-2012, 08:09 PM
Nils Kassube
 
Default problems with 10.04 upgrade to 12.04

Dave Howorth wrote:
> Dave Howorth wrote:
> > After this operation, 4248kB of additional disk space will be used.
> > Do you want to continue [Y/n]? n
>
> If I say yes to that question, it says:
>
> E: Could not perform immediate configuration on
> 'python-minimal'.Please see man 5 apt.conf under
> APT::Immediate-Configure for details. (2)

Searching for the error message gives [1] as a result. That blog post suggests the command

apt-get -f install -o APT::Immediate-Configure=0

I hope that works for you as well.


Nils

[1] <http://blog.rimuhosting.com/2011/08/27/could-not-perform-immediate-configuration-on-already-unpacked-util-linux-
please-see-man-5-apt-conf-under-aptimmediate-configure-for-details/>

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-25-2012, 09:03 PM
NoOp
 
Default problems with 10.04 upgrade to 12.04

On 08/24/2012 01:09 PM, Nils Kassube wrote:
> Dave Howorth wrote:
>> Dave Howorth wrote:
>> > After this operation, 4248kB of additional disk space will be used.
>> > Do you want to continue [Y/n]? n
>>
>> If I say yes to that question, it says:
>>
>> E: Could not perform immediate configuration on
>> 'python-minimal'.Please see man 5 apt.conf under
>> APT::Immediate-Configure for details. (2)
>
> Searching for the error message gives [1] as a result. That blog post suggests the command
>
> apt-get -f install -o APT::Immediate-Configure=0
>
> I hope that works for you as well.
>
>
> Nils
>
> [1] <http://blog.rimuhosting.com/2011/08/27/could-not-perform-immediate-configuration-on-already-unpacked-util-linux-
> please-see-man-5-apt-conf-under-aptimmediate-configure-for-details/>
>

Nils/Dave,
Here is a bug report regarding the issue:
<https://bugs.launchpad.net/ubuntu/+source/python-defaults/+bug/990740>
[upgrading from lucid to precise fails]




--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-03-2012, 01:29 PM
Dave Howorth
 
Default problems with 10.04 upgrade to 12.04

NoOp wrote:
> On 08/24/2012 01:09 PM, Nils Kassube wrote:
>> Searching for the error message gives [1] as a result. That blog post suggests the command
>>
>> apt-get -f install -o APT::Immediate-Configure=0
>>
>> I hope that works for you as well.
>>
>> Nils

> Nils/Dave,
> Here is a bug report regarding the issue:
> <https://bugs.launchpad.net/ubuntu/+source/python-defaults/+bug/990740>
> [upgrading from lucid to precise fails]

Hi Nils, Noop,

Sorry, I've been on holiday for a week, hence no reply. I tried various
commands, which all seem to fail, so in accordance with the guidance in
that bug report I've opened a new one:

<https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1045285>

Thanks again for your help.
Dave

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-04-2012, 09:50 AM
Dave Howorth
 
Default problems with 10.04 upgrade to 12.04

I wrote:
> I've opened a new one:
>
> <https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1045285>

I'm new to the Ubuntu bug process, so I don't know what to expect. I
created the bug and received a rapid request for all the logs. So I
uploaded them and changed the status back to New. But now I've had no
acknowledgment or anything and don't know whether that's normal, or I
missed some procedural step or what. The machine that's down hosts a web
site that my boss uses, so I'm a bit fretful

Any advice?
Thanks, Dave

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-04-2012, 10:33 AM
Colin Law
 
Default problems with 10.04 upgrade to 12.04

On 4 September 2012 10:50, Dave Howorth <dhoworth@mrc-lmb.cam.ac.uk> wrote:
> I wrote:
>> I've opened a new one:
>>
>> <https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1045285>
>
> I'm new to the Ubuntu bug process, so I don't know what to expect. I
> created the bug and received a rapid request for all the logs. So I
> uploaded them and changed the status back to New. But now I've had no
> acknowledgment or anything and don't know whether that's normal, or I
> missed some procedural step or what. The machine that's down hosts a web
> site that my boss uses, so I'm a bit fretful

Nothing from the bug is likely to help fix the machine, it will
hopefully prompt changes that may help to stop the problem affecting
someone else.

If you want to get the machine working again I suggest posting the
current situation here and hoping someone can help you. If this is a
continuation of an ongoing thread then apologies as I do not seem to
have the rest of the thread.

Another alternative is to re-install Ubuntu and restore data from your backups.

Colin

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-04-2012, 11:21 AM
Dave Howorth
 
Default problems with 10.04 upgrade to 12.04

Colin Law wrote:
> On 4 September 2012 10:50, Dave Howorth <dhoworth@mrc-lmb.cam.ac.uk> wrote:
>> I wrote:
>>> I've opened a new one:
>>>
>>> <https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1045285>
>> I'm new to the Ubuntu bug process, so I don't know what to expect. I
>> created the bug and received a rapid request for all the logs. So I
>> uploaded them and changed the status back to New. But now I've had no
>> acknowledgment or anything and don't know whether that's normal, or I
>> missed some procedural step or what. The machine that's down hosts a web
>> site that my boss uses, so I'm a bit fretful
>
> Nothing from the bug is likely to help fix the machine, it will
> hopefully prompt changes that may help to stop the problem affecting
> someone else.
>
> If you want to get the machine working again I suggest posting the
> current situation here and hoping someone can help you. If this is a
> continuation of an ongoing thread then apologies as I do not seem to
> have the rest of the thread.

Basically, I tried to upgrade a machine from Lucid to Precise and it has
failed, apparently in a similar manner to several other peoples'
experiences as described in the bug reports. The machine will boot but
many programs fail. There seems to be something python-related broken
but there may be other problems.

Rather than post all the information again, is it OK to suggest reading
this thread starting at:
https://lists.ubuntu.com/archives/ubuntu-users/2012-August/263204.html

I have run various commands including:

apt-get -f install
apt-get -f install -o APT::Immediate-Configure=0
apt-get install -o APT::Immediate-Configure=false -f dpkg apt
python-minimal
apport-cli -p update-manager -u 990740

But they have all failed. I can run any other commands or supply output
from these as you or anybody else wishes.

> Another alternative is to re-install Ubuntu and restore data from your backups.

Indeed but I'm hoping I won't have to do that. I guess that what has
happened is fairly simple, if I only understood what it was, and so the
chances of a simple repair ought to be quite good.

Thanks, Dave

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-04-2012, 12:44 PM
Nils Kassube
 
Default problems with 10.04 upgrade to 12.04

Dave Howorth wrote:
> Colin Law wrote:
> > Another alternative is to re-install Ubuntu and restore data from
> > your backups.
>
> Indeed but I'm hoping I won't have to do that. I guess that what has
> happened is fairly simple, if I only understood what it was, and so
> the chances of a simple repair ought to be quite good.

Well, maybe reinstalling is the faster option as it usually only takes
something like hours and not days - after all, you mentioned some sort
of urgency. OTOH, if it isn't really THAT urgent, could you send a list
of installed packages? You can get it with the command

dpkg --get-selections >packages.txt

but don't attach the resulting file "packages.txt" to a reply because it
is probably too large to be accepted by the list server. Instead either
send it with private mail directly to me or, even better, post it e.g.
at <http://paste.ubuntu.com/> and post the URL here. Then I could try
the upgrade with the same packages used on your machine. Maybe I can
then find out what happened.


Nils

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 08:24 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org