Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Ubuntu User (http://www.linux-archive.org/ubuntu-user/)
-   -   cannot install gmsh in oneiric: anyone tried precise? (http://www.linux-archive.org/ubuntu-user/671504-cannot-install-gmsh-oneiric-anyone-tried-precise.html)

Art Edwards 05-27-2012 04:58 AM

cannot install gmsh in oneiric: anyone tried precise?
 
gmsh, a 3-d mesh generator, installs well in natty, but not in oneiric.
I did just file a bug report. I'm wondering whether this has been sorted
out in precise. Does anyone have any experience?

Art Edwards

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Rigved Rakshit 05-27-2012 06:08 AM

cannot install gmsh in oneiric: anyone tried precise?
 
gmsh, a 3-d mesh generator, installs well in natty, but not in oneiric.

I did just file a bug report. I'm wondering whether this has been sorted

out in precise. Does anyone have any experience?
gmsh can be installed in precise. It requires the removal of libhdf5-serial-1.8.4, but otherwise it can be installed.

Best Regards,
Rigved Rakshit



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Art Edwards 05-27-2012 06:21 AM

cannot install gmsh in oneiric: anyone tried precise?
 
On 05/27/2012 12:08 AM, Rigved Rakshit wrote:


gmsh, a 3-d
mesh generator, installs well in natty, but not in oneiric.

I did just file a bug report. I'm wondering whether this has
been sorted

out in precise. Does anyone have any experience?


gmsh can be installed in precise. It requires the removal of
libhdf5-serial-1.8.4, but otherwise it can be installed.



Best Regards,

Rigved Rakshit









Thanks for the response. I thought I would try the same remedy in
oneiric. However, it seems that octave, dx, scilab, and grace depend
on libhdf5-serial-1.8.4. Do you know if this is true in precise? I'm
installing gmsh to work with octave.



Art Edwards



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Rigved Rakshit 05-28-2012 06:34 AM

cannot install gmsh in oneiric: anyone tried precise?
 
However, it seems that octave, dx, scilab, and grace depend
on libhdf5-serial-1.8.4. Do you know if this is true in precise?
octave depends on libhdf5-serial-1.8.4 or libhdf5-1.8.4
dx depends on libhdf4-0-alt
scilab depends on libhdf5-serial-1.8.4 or libhdf5-1.8.4


grace does not depend on any libhdf package
*I'm
installing gmsh to work with octave.

gmsh depends on libmed1
libmed1 depends on libhdf5-openmpi-1.8.4
libhdf5-openmpi-1.8.4 conflicts with libhdf5-1.8, libhdf5-1.8.3 and libhdf5-1.8.4



It is because of this conflict that libhdf5-serial-1.8.4 is to be removed.

Looking through all the files installed by libhdf5-openmpi-1.8.4 and libhdf5-serial-1.8.4, the following files are present in both the packages.



/usr/lib/libhdf5.so.6
/usr/lib/libhdf5.so.6.0.3
/usr/lib/libhdf5_fortran.so.6
/usr/lib/libhdf5_fortran.so.6.0.3
/usr/lib/libhdf5_hl.so.6
/usr/lib/libhdf5_hl.so.6.0.3
/usr/lib/libhdf5hl_fortran.so.6


/usr/lib/libhdf5hl_fortran.so.6.0.3

These files are causing the conflict.

Also, libhdf5-serial-1.8.4 contains some extra cpp files which are not present in libhdf5-openmpi-1.8.4:

/usr/lib/libhdf5_cpp.so.6


/usr/lib/libhdf5_cpp.so.6.0.3
/usr/lib/libhdf5_hl_cpp.so.6
/usr/lib/libhdf5_hl_cpp.so.6.0.3

Assuming libhdf5-openmpi-1.8.4 is a replacement for
libhdf5-serial-1.8.4, you can go ahead and use gmsh with octave.
Otherwise, it will be a problem.

Best Regards,
Rigved Rakshit

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users


All times are GMT. The time now is 01:18 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.