FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 03-01-2012, 04:05 AM
Nolan
 
Default Memory Card Reader

Hi list,



I have not been able to get my sd card recognized in

*** nolan@retired:~$ cat /etc/issue

*** Ubuntu 10.04.4 LTS
l



*** nolan@retired:~$ uname -r

*** 2.6.32-36-generic

I have added three modules to `/etc/modules'

The last was the sdricoh_sc module which I downloaded the

source and did a make and make install as Root.



Just to be sure I as Root did a

$sudo modprobe sdricoh_sc



I have `dmesg | tail -20' after plugging the sd card

and it is not seen.

I have rebooted 3 times after making changes. No Joy.



$lspci -v

07:05.1 SD Host controller: Ricoh Co Ltd R5C822
SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)

*** Subsystem: Hewlett-Packard Company Device 30bb

*** Flags: medium devsel, IRQ 17

*** Memory at de000800 (32-bit, non-prefetchable) [size=256]

*** Capabilities: <access denied>

*** Kernel driver in use: sdhci-pci

*** Kernel modules: sdhci-pci



07:05.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller
(rev 0a)

*** Subsystem: Hewlett-Packard Company Device 30bb

*** Flags: medium devsel, IRQ 11

*** Memory at de000c00 (32-bit, non-prefetchable) [disabled]
[size=256]

************************************************** **********************************
^^^

*** Capabilities: <access denied>

*** Kernel driver in use: ricoh-mmc

*** Kernel modules: ricoh_mmc

from examples on the net* the above [disabled] was not present.



Has Ubuntu or Linux in general got the mmc reader working?



Any help will be appreacited or a link to educate me further.



Thanks

Nolan














--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 03-07-2012, 07:28 PM
Avi Greenbury
 
Default Memory Card Reader

Nolan wrote:

> I have added three modules to `/etc/modules'
> The last was the sdricoh_sc module which I downloaded the

Which three? sdrioch_sc, sdhci-pci and ricoh_mmc? Have you checked
they're all loaded properly (grep lsmod's output for their
names)? What told you to install these modules?

> I have `dmesg | tail -20' after plugging the sd card

This will give you the *top* 20 lines of dmesg's output. You probably
meant tail -n20 ; is that what you typed into the terminal?

--
Avi


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 03-08-2012, 02:28 AM
Nolan
 
Default Memory Card Reader

On 03/07/2012 12:28 PM, Avi Greenbury wrote:
> Nolan wrote:
>
>> I have added three modules to `/etc/modules'
>> The last was the sdricoh_sc module which I downloaded the
> Which three? sdrioch_sc, sdhci-pci and ricoh_mmc? Have you checked
> they're all loaded properly (grep lsmod's output for their
> names)? What told you to install these modules?
In my research I gathered that one if not more was the one I needed. So I modprobed and
lsmod and they were installed. But did not activate the reader.
>
>> I have `dmesg | tail -20' after plugging the sd card
> This will give you the *top* 20 lines of dmesg's output. You probably
> meant tail -n20 ; is that what you typed into the terminal?
>
Here's the output of `dmesg | tail -20'
> nolan@retired:~$ dmesg | tail -20
> [46213.747977] wlan0: authenticated
> [46213.748021] wlan0: associate with AP 00:1d:7e:c0:de:5a (try 1)
> [46213.750281] wlan0: RX AssocResp from 00:1d:7e:c0:de:5a (capab=0x431 status=12 aid=0)
> [46213.750289] wlan0: AP denied association (code=12)
> [46213.750319] wlan0: deauthenticating from 00:1d:7e:c0:de:5a by local choice (reason=3)
> [46213.821734] wlan0: direct probe to AP 00:1d:7e:c0:de:5a (try 1)
> [46213.823948] wlan0: direct probe responded
> [46213.823955] wlan0: authenticate with AP 00:1d:7e:c0:de:5a (try 1)
> [46213.825764] wlan0: authenticated
> [46213.825820] wlan0: associate with AP 00:1d:7e:c0:de:5a (try 1)
> [46213.828295] wlan0: RX AssocResp from 00:1d:7e:c0:de:5a (capab=0x431 status=0 aid=1)
> [46213.828302] wlan0: associated
> [46213.829972] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
> [46223.956099] wlan0: no IPv6 routers present
> [51028.932153] CE: hpet increasing min_delta_ns to 40226 nsec
> [71767.152163] usb 5-1: USB disconnect, address 3
> [405651.465189] usb 5-1: new full speed USB device using uhci_hcd and address 4
> [405651.696558] usb 5-1: configuration #1 chosen from 2 choices
> [405651.701365] cdc_acm 5-1:1.0: ttyACM0: USB ACM device
> [430929.184207] usb 5-1: USB disconnect, address 4
> nolan@retired:~$
> which are the last 20 lines of `dmesg'.

Thanks for any help
Nolan



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 09:21 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org