FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 01-27-2012, 05:30 PM
Min Wang
 
Default Ubuntu 10.04.3 LTS mapserver shp2img hang

HI
On Ubuntu 10.04.3 LTS (AMD64) , I tried to use shp2img ( because
mapserver seems not working, so try to debug it use shp2img etc), it
seems shp2img hang somewhere.


futex(0x80db90, FUTEX_WAIT_PRIVATE, 2, NULL )

see the below:

(1) On 10.0.4.3
Linux pure-ubuntu-10 2.6.32-33-server #70-Ubuntu SMP Thu Jul 7 22:28:30
UTC 2011 x86_64 GNU/Linux

strace shp2img -m postgis.map -o test.png -all_debug 5

....
close(6) = 0
munmap(0x7f07d252e000, 4096) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=3519, ...}) = 0
stat("/home/xxx/mapserver-demo/mapfiles/./../data/bluemarble.wld",
0x7fff2d285540) = -1 ENOENT (No such file or directory)
stat("/home/xx/mapserver-demo/mapfiles/./../data/bluemarble.WLD",
0x7fff2d285540) = -1 ENOENT (No such file or directory)
open("/home/xx/mapserver-demo/mapfiles/./../data/bluemarble.jpg",
O_RDONLY) = 3

close(3) = 0
futex(0x80db90, FUTEX_WAIT_PRIVATE, 2, NULL

(2) On Ubuntu 11.10
the same command/configure runs well.


Any clue? or Is the mapserver on 10.0.4.3 lucid usable?



Thanks

Min Wang


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 11:55 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org