FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 12-14-2011, 04:18 PM
Jim Byrnes
 
Default Seamonkey 2.03 to 2.5 lost plugins

Just manually installed Seamonkey 2.5 after having used the repository
version Seamonkey 2.03. Everything seemed to go well. All my previous
bookmarks showed up as well as my email and newsgroup folders and
subscriptions. A couple of extensions were listed as not compatible and
were disabled. The problem is that none of the plugins installed under
version 2.03 are shown as installed under 2.5. The plugin page is
completely empty.


How can I best get them to install in 2.5?

Thanks, Jim


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-14-2011, 05:28 PM
NoOp
 
Default Seamonkey 2.03 to 2.5 lost plugins

On 12/14/2011 09:18 AM, Jim Byrnes wrote:
> Just manually installed Seamonkey 2.5 after having used the repository
> version Seamonkey 2.03. Everything seemed to go well. All my previous
> bookmarks showed up as well as my email and newsgroup folders and
> subscriptions. A couple of extensions were listed as not compatible and
> were disabled. The problem is that none of the plugins installed under
> version 2.03 are shown as installed under 2.5. The plugin page is
> completely empty.
>
> How can I best get them to install in 2.5?
...
Close SM, go to:
/home/<user>/.mozilla/seamonkey/<profile>.default
rename 'pluginreg.dat' to 'pluginreg.dat_old'

Restart SM & the plugin file should be repopulated (it's a text file
that you can view in gedit).

You might want to join us over on:
news://news.mozilla.org/mozilla.support.seamonkey

See:
http://www.seamonkey-project.org/community



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-14-2011, 11:57 PM
Jim Byrnes
 
Default Seamonkey 2.03 to 2.5 lost plugins

On 12/14/2011 12:28 PM, NoOp wrote:

On 12/14/2011 09:18 AM, Jim Byrnes wrote:

Just manually installed Seamonkey 2.5 after having used the repository
version Seamonkey 2.03. Everything seemed to go well. All my previous
bookmarks showed up as well as my email and newsgroup folders and
subscriptions. A couple of extensions were listed as not compatible and
were disabled. The problem is that none of the plugins installed under
version 2.03 are shown as installed under 2.5. The plugin page is
completely empty.

How can I best get them to install in 2.5?

...
Close SM, go to:
/home/<user>/.mozilla/seamonkey/<profile>.default
rename 'pluginreg.dat' to 'pluginreg.dat_old'

Restart SM& the plugin file should be repopulated (it's a text file
that you can view in gedit).


For some reason that did not work. The pluginreg.dat it generated looks
strange and is exactly the same as the origianl. Its not long so I
copied it here.


Generated File. Do not edit.

[HEADER]
Version:0.15:$
Arch:x86-gcc3:$

[PLUGINS]

[INVALID]
/usr/lib/nspluginwrapper/plugins/npwrapper.nppdf.so:$
1320935978000:$
/usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so:$
1274282974000:$
/usr/lib/mozilla/plugins/libtotem-cone-plugin.so:$
1274282974000:$
/usr/lib/mozilla/plugins/libtotem-gmp-plugin.so:$
1274282974000:$
/usr/lib/mozilla/plugins/libtotem-mully-plugin.so:$
1274282974000:$
/var/lib/flashplugin-installer/npwrapper.libflashplayer.so:$
1321153129000:$
/usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so:$
1277465636000:$
/usr/lib/jvm/java-6-sun-1.6.0.26/jre/lib/amd64/libnpjp2.so:$
1304498979000:$


You might want to join us over on:
news://news.mozilla.org/mozilla.support.seamonkey


I'll check it out, thanks.


See:
http://www.seamonkey-project.org/community



Regards, Jim



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-15-2011, 01:06 AM
NoOp
 
Default Seamonkey 2.03 to 2.5 lost plugins

On 12/14/2011 04:57 PM, Jim Byrnes wrote:
> On 12/14/2011 12:28 PM, NoOp wrote:
>> On 12/14/2011 09:18 AM, Jim Byrnes wrote:
>>> Just manually installed Seamonkey 2.5 after having used the repository
>>> version Seamonkey 2.03. Everything seemed to go well. All my previous
>>> bookmarks showed up as well as my email and newsgroup folders and
>>> subscriptions. A couple of extensions were listed as not compatible and
>>> were disabled. The problem is that none of the plugins installed under
>>> version 2.03 are shown as installed under 2.5. The plugin page is
>>> completely empty.
>>>
>>> How can I best get them to install in 2.5?
>> ...
>> Close SM, go to:
>> /home/<user>/.mozilla/seamonkey/<profile>.default
>> rename 'pluginreg.dat' to 'pluginreg.dat_old'
>>
>> Restart SM& the plugin file should be repopulated (it's a text file
>> that you can view in gedit).
>
> For some reason that did not work. The pluginreg.dat it generated looks
> strange and is exactly the same as the origianl. Its not long so I
> copied it here.

That's bizare. Can you try with a different/new profile to see if it is
profile related?
...


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-15-2011, 09:17 AM
Liam Proven
 
Default Seamonkey 2.03 to 2.5 lost plugins

On 14 December 2011 17:18, Jim Byrnes <jf_byrnes@comcast.net> wrote:
> Just manually installed Seamonkey 2.5 after having used the repository
> version Seamonkey 2.03. *Everything seemed to go well. *All my previous
> bookmarks showed up as well as my email and newsgroup folders and
> subscriptions. *A couple of extensions were listed as not compatible and
> were disabled. The problem is that none of the plugins installed under
> version 2.03 are shown as installed under 2.5. The plugin page is completely
> empty.
>
> How can I best get them to install in 2.5?

Not enough info to say.

What are you running on? Version of distro, 32 or 64 bit? Were you
running 32-bit or 64-bit Seamonkey before, and which after?

32-bit plugins won't run on a 64-bit browser and /vice versa./

--
Liam Proven • Info & profile: http://www.google.com/profiles/lproven
Email: lproven@cix.co.uk • GMail/GoogleTalk/Orkut: lproven@gmail.com
Tel: +44 20-8685-0498 • Cell: +44 7939-087884 • Fax: + 44 870-9151419
AIM/Yahoo/Skype: liamproven • MSN: lproven@hotmail.com • ICQ: 73187508

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-15-2011, 04:11 PM
Jim Byrnes
 
Default Seamonkey 2.03 to 2.5 lost plugins

On 12/14/2011 08:06 PM, NoOp wrote:

On 12/14/2011 04:57 PM, Jim Byrnes wrote:

On 12/14/2011 12:28 PM, NoOp wrote:

On 12/14/2011 09:18 AM, Jim Byrnes wrote:

Just manually installed Seamonkey 2.5 after having used the repository
version Seamonkey 2.03. Everything seemed to go well. All my previous
bookmarks showed up as well as my email and newsgroup folders and
subscriptions. A couple of extensions were listed as not compatible and
were disabled. The problem is that none of the plugins installed under
version 2.03 are shown as installed under 2.5. The plugin page is
completely empty.

How can I best get them to install in 2.5?

...
Close SM, go to:
/home/<user>/.mozilla/seamonkey/<profile>.default
rename 'pluginreg.dat' to 'pluginreg.dat_old'

Restart SM& the plugin file should be repopulated (it's a text file
that you can view in gedit).


For some reason that did not work. The pluginreg.dat it generated looks
strange and is exactly the same as the origianl. Its not long so I
copied it here.


That's bizare. Can you try with a different/new profile to see if it is
profile related?
...



Sure. I had a test profile created awhile ago with 2.03 that I made no
changes to and it acted exactly the same way and profile.dat was
identical. I then created a brand new profile and profile.dat was again
the same.


Regards, Jim



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-15-2011, 04:14 PM
Jim Byrnes
 
Default Seamonkey 2.03 to 2.5 lost plugins

On 12/15/2011 04:17 AM, Liam Proven wrote:

On 14 December 2011 17:18, Jim Byrnes<jf_byrnes@comcast.net> wrote:

Just manually installed Seamonkey 2.5 after having used the repository
version Seamonkey 2.03. Everything seemed to go well. All my previous
bookmarks showed up as well as my email and newsgroup folders and
subscriptions. A couple of extensions were listed as not compatible and
were disabled. The problem is that none of the plugins installed under
version 2.03 are shown as installed under 2.5. The plugin page is completely
empty.

How can I best get them to install in 2.5?


Not enough info to say.

What are you running on? Version of distro, 32 or 64 bit? Were you
running 32-bit or 64-bit Seamonkey before, and which after?

32-bit plugins won't run on a 64-bit browser and /vice versa./



Unbuntu 10.04 and 2.0.3 & 2.5 are both 64 bit.

new:
Build identifier: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:8.0.1)
Gecko/20111121 Firefox/8.0.1 SeaMonkey/2.5


old:
Build identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.8)
Gecko/20100208 SeaMonkey/2.0.3


Regards, Jim


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-15-2011, 07:29 PM
NoOp
 
Default Seamonkey 2.03 to 2.5 lost plugins

On 12/15/2011 09:11 AM, Jim Byrnes wrote:
> On 12/14/2011 08:06 PM, NoOp wrote:
...
>>> For some reason that did not work. The pluginreg.dat it generated looks
>>> strange and is exactly the same as the origianl. Its not long so I
>>> copied it here.
>>
>> That's bizare. Can you try with a different/new profile to see if it is
>> profile related?
>> ...
>>
>
> Sure. I had a test profile created awhile ago with 2.03 that I made no
> changes to and it acted exactly the same way and profile.dat was
> identical. I then created a brand new profile and profile.dat was again
> the same.
>
> Regards, Jim

Jim how/where did you 'install' SeaMonkey? I extract to a home folder
and simply run from there:
/home/<user>/seamonkey/seamonkey
actually my command in the menu is:
/home/gg/Seamonkey2.6/seamonkey/seamonkey -mail -browser

If you still have problems, can you please install Joe Lesko's ppa
version? Note: I have been testing all of the versions as Joe builds
them & can pretty well guarantee that his 2.5 will install & work on
your system:

<https://launchpad.net/~joe-nationnet/+archive/seamonkey-dev>

$ sudo add-apt-repository ppa:joe-nationnet/seamonkey-dev
$ sudo apt-get update
$ sudo apt-get install seamonkey





--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-16-2011, 02:47 AM
Jim Byrnes
 
Default Seamonkey 2.03 to 2.5 lost plugins

On 12/15/2011 02:29 PM, NoOp wrote:

On 12/15/2011 09:11 AM, Jim Byrnes wrote:

On 12/14/2011 08:06 PM, NoOp wrote:

...

For some reason that did not work. The pluginreg.dat it generated looks
strange and is exactly the same as the origianl. Its not long so I
copied it here.


That's bizare. Can you try with a different/new profile to see if it is
profile related?
...



Sure. I had a test profile created awhile ago with 2.03 that I made no
changes to and it acted exactly the same way and profile.dat was
identical. I then created a brand new profile and profile.dat was again
the same.

Regards, Jim


Jim how/where did you 'install' SeaMonkey? I extract to a home folder
and simply run from there:
/home/<user>/seamonkey/seamonkey


That's what I did also.


actually my command in the menu is:
/home/gg/Seamonkey2.6/seamonkey/seamonkey -mail -browser


/home/jfb/seamonkey/seamonkey is mine. Just to be complete I just
tried the -mail -browser switches but it did no good.


When this all started I saved a copy of the original /.mozilla/seamonkey
directory. So I removed everything I did and re-installed it thinking
maybe I did something wrong the first time but still acted the same.
After multiple attempts I found that simply extracting the tar.bz file
would turn a good puginreg.dat file into that mess I posted. On one try
I even made a good puginreg.dat read only. Seamonkey installed, no
pluginreg.dat was generated but I sill had no plugins installed.
Strange it worked for you and of course the same procedure worked for
me when I did it with Firefox.



If you still have problems, can you please install Joe Lesko's ppa
version? Note: I have been testing all of the versions as Joe builds
them& can pretty well guarantee that his 2.5 will install& work on
your system:

<https://launchpad.net/~joe-nationnet/+archive/seamonkey-dev>

$ sudo add-apt-repository ppa:joe-nationnet/seamonkey-dev
$ sudo apt-get update
$ sudo apt-get install seamonkey



Ok, I'll give that a shot. I haven't used ppa's much so I wonder will
future updates come from mozilla or the ppa?


Thanks, Jim



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-16-2011, 07:56 PM
NoOp
 
Default Seamonkey 2.03 to 2.5 lost plugins

On 12/15/2011 07:47 PM, Jim Byrnes wrote:
> On 12/15/2011 02:29 PM, NoOp wrote:
...
>> Jim how/where did you 'install' SeaMonkey? I extract to a home folder
>> and simply run from there:
>> /home/<user>/seamonkey/seamonkey
>
> That's what I did also.
>
>> actually my command in the menu is:
>> /home/gg/Seamonkey2.6/seamonkey/seamonkey -mail -browser
>
> /home/jfb/seamonkey/seamonkey is mine. Just to be complete I just
> tried the -mail -browser switches but it did no good.
>
> When this all started I saved a copy of the original /.mozilla/seamonkey
> directory. So I removed everything I did and re-installed it thinking
> maybe I did something wrong the first time but still acted the same.
> After multiple attempts I found that simply extracting the tar.bz file
> would turn a good puginreg.dat file into that mess I posted. On one try
> I even made a good puginreg.dat read only. Seamonkey installed, no
> pluginreg.dat was generated but I sill had no plugins installed.
> Strange it worked for you and of course the same procedure worked for
> me when I did it with Firefox.
>
>> If you still have problems, can you please install Joe Lesko's ppa
>> version? Note: I have been testing all of the versions as Joe builds
>> them& can pretty well guarantee that his 2.5 will install& work on
>> your system:
>>
>> <https://launchpad.net/~joe-nationnet/+archive/seamonkey-dev>
>>
>> $ sudo add-apt-repository ppa:joe-nationnet/seamonkey-dev
>> $ sudo apt-get update
>> $ sudo apt-get install seamonkey
>>
>
> Ok, I'll give that a shot. I haven't used ppa's much so I wonder will
> future updates come from mozilla or the ppa?

The ppa. Also note that you do not have to uninstall/remopve your
/home/jfb/seamonkey/seamonkey version, you can have both installed &
they will use the same '~/.mozilla/seamonkey/<defaultprofile>'.
...
Probably better if we take this off list, that way we can exchange
screenshots & 'ls -al' etc. Can you send me (directly) the output of:

$ ls -al ~/.mozilla/seamonkey/<defaultprofile>
$ ls -al ~/.mozilla/seamonkey/<defaultprofile>/plugins
$ ls -al /usr/lib/mozilla/plugins

Thanks.



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 02:45 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org