FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 11-23-2011, 08:29 PM
"Robert P. J. Day"
 
Default any pointers on how to qemu-system-ppc a powerpc kernel on 11.10?

(while this question has a lot of powerpc and qemu content, i'm
trying to do this on my ubuntu 11.10 system, so i figured i'd check if
someone here has already been down this road.)

i have a lite5200b system board, so i built myself a kernel from the
latest kernel source using the "lite5200b_defconfig" configuration.
what i got out of that was the standard "vmlinux" kernel file, as well
as "zImage" and "uImage" files that are U-Boot ready.

i just want to fire up "qemu-system-ppc" from the qemu-system
package and test the kernel; i have no root filesystem yet so i know
starting the kernel will eventually result in dying due to lack of
root filesystem. no problem, i'm good with that.

but trying something simple like:

$ qemu-system-ppc vmlinux

produces:

qemu: hardware error: qemu: could not load PowerPC bios 'openbios-ppc'

so i'm in the process of googling to see what else i need. has anyone
else gone through this on their ubuntu system? i just want to get
to the point of starting the kernel, at which point i think i'll be
able to take it from there. thanks.

rday

--

================================================== ======================
Robert P. J. Day Ottawa, Ontario, CANADA
http://crashcourse.ca

Twitter: http://twitter.com/rpjday
LinkedIn: http://ca.linkedin.com/in/rpjday
================================================== ======================


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 11-24-2011, 07:25 AM
Colin Watson
 
Default any pointers on how to qemu-system-ppc a powerpc kernel on 11.10?

On Wed, Nov 23, 2011 at 04:29:49PM -0500, Robert P. J. Day wrote:
> qemu: hardware error: qemu: could not load PowerPC bios 'openbios-ppc'

Unfortunately the openbios-ppc package can only be built on a powerpc
system, and a long-standing Launchpad bug means that we can't arrange
for architecture-independent Ubuntu packages to be built on
architectures other than i386. Maybe some day we'll get this fixed. In
the meantime, I'd suggest just grabbing the package directly from Debian
and installing it using 'dpkg -i', as it's small and has no
dependencies:

http://ftp.debian.org/debian/pool/main/o/openbios-ppc/

Using this, I've been able to debug problems with Ubuntu powerpc images
like this (obviously -cpu and -M details will be board-specific):

qemu-system-ppc -cpu G4 -M mac99 -bios /usr/share/openbios/openbios-ppc -cdrom .iso -hda foo.img -boot order=d

Good luck,

--
Colin Watson [cjwatson@ubuntu.com]

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 11-25-2011, 10:53 AM
Colin Watson
 
Default any pointers on how to qemu-system-ppc a powerpc kernel on 11.10?

On Thu, Nov 24, 2011 at 08:25:18AM +0000, Colin Watson wrote:
> Using this, I've been able to debug problems with Ubuntu powerpc images
> like this (obviously -cpu and -M details will be board-specific):
>
> qemu-system-ppc -cpu G4 -M mac99 -bios /usr/share/openbios/openbios-ppc -cdrom .iso -hda foo.img -boot order=d

Incidentally, I had cause to do this again myself recently, and while it
works fine on 11.10, something is broken in 12.04 and I just get a blank
screen in the emulator. I'm running it in an 11.10 chroot for now.

--
Colin Watson [cjwatson@ubuntu.com]

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 11-25-2011, 11:13 AM
"Robert P. J. Day"
 
Default any pointers on how to qemu-system-ppc a powerpc kernel on 11.10?

Quoting Colin Watson <cjwatson@ubuntu.com>:


On Thu, Nov 24, 2011 at 08:25:18AM +0000, Colin Watson wrote:

Using this, I've been able to debug problems with Ubuntu powerpc images
like this (obviously -cpu and -M details will be board-specific):

qemu-system-ppc -cpu G4 -M mac99 -bios
/usr/share/openbios/openbios-ppc -cdrom .iso -hda foo.img -boot
order=d


Incidentally, I had cause to do this again myself recently, and while it
works fine on 11.10, something is broken in 12.04 and I just get a blank
screen in the emulator. I'm running it in an 11.10 chroot for now.


argh. that is all.

rday


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 01:09 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org