FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 11-15-2011, 04:14 PM
Bill Walton
 
Default possible to update bash to version 4.1 on 8.04 LTS ?

Hi,

I've been having a bunch of issues with Lucid and have dropped back to
Hardy to see if they persist. But I need to have bash >= 4.1 and have
not found a way to update the version (3.2) on Hardy. Is there one?

TIA,
Bill

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 11-16-2011, 05:47 AM
Rigved Rakshit
 
Default possible to update bash to version 4.1 on 8.04 LTS ?

I've been having a bunch of issues with Lucid and have dropped back to

Hardy to see if they persist.
Have you tried a later version, like 11.10, to see if these problems have been fixed. I am asking this because Ubuntu 8.04's support ended on 12 May 2011 for desktops. But, if you are on a server, then there is no problem.


*But I need to have bash >= 4.1 and have

not found a way to update the version (3.2) on Hardy. *Is there one?

Bash 4.1 will also need some updated dependencies. So, to use bash 4.1 on Hardy, you will need to use the updated versions of all the dependencies of bash. In case you want to do this anyway, just download all the .deb files (of bash and its dependencies) from http://packages.ubuntu.com/lucid/shells/bash. This page also has links to the download pages of it's dependencies. Just go ahead and download/install all of these dependencies (and in turn, the dependencies of the dependencies).



Best Regards,
Rigved Rakshit

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 11-16-2011, 11:00 PM
Avi Greenbury
 
Default possible to update bash to version 4.1 on 8.04 LTS ?

Rigved Rakshit wrote:

> Bash 4.1 will also need some updated dependencies. So, to use bash
> 4.1 on Hardy, you will need to use the updated versions of all the
> dependencies of bash. In case you want to do this anyway, just
> download all the .deb files (of bash and its dependencies) from
> http://packages.ubuntu.com/lucid/shells/bash. This page also has
> links to the download pages of it's dependencies. Just go ahead and
> download/install all of these dependencies (and in turn, the
> dependencies of the dependencies).

Much as this might work, it also might break things. There's no 'good'
way to upgrade only a single component of a distribution - one of the
side-effects of the Unixy tradition of relying on external libraries
and the like is that everything generally wants to be kept in sync.

What is it you need from bash 4.1, and why did you go backwards to see
if the issues weren't present? What were the issues?

--
Avi

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 03:44 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org