FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 10-24-2011, 05:19 AM
Dixon Xavier
 
Default Atheros AR9285 on Ubuntu 11.10 Sony Vaio VPCEH - wifi does't works

I am unable to use wireless network and Bluetooth on my laptop..

Before in Ubuntu 11.04 is worked fine, but after a fresh install of Ubuntu 11.10 it doesn't works..


I posted same in ubuntuforums, yet resolved..
http://ubuntuforums.org/showthread.php?t=1867214



1) Machine Brand and Model (PC/Laptop):


Code:
SONY VAIO VPCEH15EN
2 ) Wireless Brand, Model and Wireless Chipset:


Code:
dixon@dixon-vaio:~$ lspci -nn|grep "Atheros"
07:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
3 ) Checking interface:


Code:
dixon@dixon-vaio:~$ ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 90:00:4e:d2:24:5d
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

dixon@dixon-vaio:~$ iwconfig wlan0
wlan0 IEEE 802.11bgn ESSIDff/any
Mode:Managed Access Point: Not-Associated Tx-Power=15 dBm
Retry long limit:7 RTS thrff Fragment thrff
Power Managementff
4 ) Checking for modules:


Code:
dixon@dixon-vaio:~$ lsmod | grep "ath9k"
ath9k 127538 0
mac80211 310872 1 ath9k
ath9k_common 13839 1 ath9k
ath9k_hw 312866 2 ath9k,ath9k_common
ath 24067 2 ath9k,ath9k_hw
cfg80211 199587 3 ath9k,mac80211,ath
5 ) Kernel boot messages


Code:
dixon@dixon-vaio:~$ dmesg|grep "ath9k"
[ 9.541422] ath9k 0000:07:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 9.541439] ath9k 0000:07:00.0: setting latency timer to 64
[ 9.619352] ieee80211 phy0: Selected rate control algorithm 'ath9k_rate_control'
[ 9.619965] Registered led device: ath9k-phy0
6 ) Network configuration


Code:
dixon@dixon-vaio:~$ sudo lshw -C network
*-network
description: Wireless interface
product: AR9285 Wireless Network Adapter (PCI-Express)
vendor: Atheros Communications Inc.
physical id: 0
bus info: pci@0000:07:00.0
logical name: wlan0
version: 01
serial: 90:00:4e:d2:24:5d
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath9k driverversion=3.0.0-12-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
resources: irq:16 memory:92500000-9250ffff
*-network
description: Ethernet interface
product: RTL8111/8168B PCI Express Gigabit Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:13:00.0
logical name: eth0
version: 06
serial: 78:84:3c:e5:2c:e8
size: 10Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:40 ioport:2000(size=256) memory:91404000-91404fff memory:91400000-91403fff
7 ) Scan for networks:


Code:
dixon@dixon-vaio:~$ iwlist wlan0 scan
wlan0 No scan results
8 ) Ubuntu Version:


Code:
dixon@dixon-vaio:~$ lsb_release -d
Description: Ubuntu 11.10
9 ) Kernel/architecture:


Code:
dixon@dixon-vaio:~$ uname -mr
3.0.0-12-generic x86_64
10 ) Restarting the network:


Code:
dixon@dixon-vaio:~$ sudo /etc/init.d/networking restart
* Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
* Reconfiguring network interfaces... [ OK ]
11) rfkill list:


Code:
dixon@dixon-vaio:~$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
2: sony-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
3: sony-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
4: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
Any additional informations needed ?

Thanks in advance...
--
. : D i X O N : .

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-24-2011, 05:45 AM
Ioannis Vranos
 
Default Atheros AR9285 on Ubuntu 11.10 Sony Vaio VPCEH - wifi does't works

On Mon, Oct 24, 2011 at 8:19 AM, Dixon Xavier <dixoncx@gmail.com> wrote:
> I am unable to use wireless network and Bluetooth on my laptop..
> Before in Ubuntu 11.04 is worked fine, but after a fresh install of Ubuntu 11.10 it doesn't works..

Try installing linux-firmware-nonfree package, and then reboot.


--
Ioannis Vranos

http://www.cpp-software.net

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-24-2011, 10:30 AM
Dixon Xavier
 
Default Atheros AR9285 on Ubuntu 11.10 Sony Vaio VPCEH - wifi does't works

Installed linux- firmware-nonfree package..
After reboot, no change

Currently am unable to check wi-fi connectivity (no wifi connection in my home),
am checking bluetooth connectivity instead...
thinking both are interconnected, ie., functionality by same hardware...

I can't turn my bluetooth on..

How can i fix it ..?

--
. : D i X O N : .

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-24-2011, 07:15 PM
Ioannis Vranos
 
Default Atheros AR9285 on Ubuntu 11.10 Sony Vaio VPCEH - wifi does't works

On Mon, Oct 24, 2011 at 1:30 PM, Dixon Xavier <dixoncx@gmail.com> wrote:
> Installed linux- firmware-nonfree package..
> After reboot, no change
>
> Currently am unable to check wi-fi connectivity (no wifi connection in my home),
> am checking bluetooth connectivity instead...
> thinking both are interconnected, ie., functionality by same hardware...
>
> I can't turn my bluetooth on..

Click on the icon on the top right, and select System Settings. In the
hardware tab, select Bluetooth. Is it on?

Also did you do a clean install or an upgrade to Ubuntu 11.10?



--
Ioannis Vranos

http://www.cpp-software.net

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 01:03 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org