FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 10-03-2011, 04:17 PM
Mike Barnard
 
Default Ubuntu 11.04: Huawei E173s-2

Hi,

I am new to Ubuntu (but not Linux/UNIX) and trying to get the Huawei E173s-2 modem to work on Ubuntu 11.04. Is there an update or patch to get this modem to work on Ubuntu?

The modem Vendor and Product ID's are present in /lib/udev/rules.d/40-usb_modeswitch


# Huawei E173s
ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1c0b", RUN+="usb_modeswitch '%b/%k'"

I have to run usb_modeswitch on each plugin, but the modem will not work without


echo "12d1 1c05" > /sys/bus/usb-serial/drivers/option1/new_id

I have gone through the list archives and did not find much, but a few hits come up on the Ubuntuforums. Any one know how I can get this to work like all other modems.



--
Mike

Of course, you might discount this possibility, but remember that one in*a million chances happen 99% of the time.
------------------------------------------------------------


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-03-2011, 04:20 PM
Jason Arkell
 
Default Ubuntu 11.04: Huawei E173s-2

Use synaptic package manager to install usb-modeswitch. Should work after that. Left click the network icon and look for new mobile connection and left click on it. That will begin the setup process.




Mike Barnard <mike.barnardq@gmail.com> wrote:





Hi,



I am new to Ubuntu (but not Linux/UNIX) and trying to get the Huawei E173s-2 modem to work on Ubuntu 11.04. Is there an update or patch to get this modem to work on Ubuntu?



The modem Vendor and Product ID's are present in /lib/udev/rules.d/40-usb_modeswitch



# Huawei E173s

ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1c0b", RUN+="usb_modeswitch '%b/%k'"



I have to run usb_modeswitch on each plugin, but the modem will not work without



echo "12d1 1c05" > /sys/bus/usb-serial/drivers/option1/new_id



I have gone through the list archives and did not find much, but a few hits come up on the Ubuntuforums. Any one know how I can get this to work like all other modems.






--

Mike



Of course, you might discount this possibility, but remember that one in*a million chances happen 99% of the time.

------------------------------------------------------------




--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 09:13 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org