Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Ubuntu User (http://www.linux-archive.org/ubuntu-user/)
-   -   calibre (ebook reader) dependencies problem in natty (Ubuntu 11.04 ) (http://www.linux-archive.org/ubuntu-user/581408-calibre-ebook-reader-dependencies-problem-natty-ubuntu-11-04-a.html)

Tapas Mishra 09-29-2011 02:28 AM

calibre (ebook reader) dependencies problem in natty (Ubuntu 11.04 )
 
I tried installing calibre (via apt-get and synaptics both) got following errors


The following packages have unmet dependencies:

calibre: Depends: python (>= 2.6) but 2.7.1-0ubuntu5 is to be installed
Depends: python-pypdf (>= 1.10) but 1.12-3 is to be installed
Depends: python-cssutils (>= 0.9.7~) but 0.9.7~b2-2 is to be installed
Depends: python-encutils (>= 0.9.5) but 0.9.7~b2-2 is to be installed
Depends: python-cherrypy3 (>= 3.1.1) but 3.1.2-1 is to be installed
Depends: python-qt4 (>= 4.7.3) but 4.8.3-2 is to be installed
Depends: calibre-bin (>= 0.7.44+dfsg-1build1) but
0.7.44+dfsg-1build1 is to be installed


My OS Ubuntu 11.04 64 bit.

I could not understand what is python (>= 2.6) but 2.7.1-0ubuntu5 so left it.

Via synaptics installed
python-pypdf
python-cssutils
python-encutils
python-cherrypy3
upto here it worked well.

But when I proceeded to install pyhton-qt4 got following errors
The following packages have unmet dependencies:

python-qt4: Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to
be installed
Depends: libqt4-declarative (>= 4:4.7.0~rc1) but
4:4.7.2-0ubuntu6 is to be installed
Depends: libqt4-designer (>= 4:4.7.0) but 4:4.7.2-0ubuntu6
is to be installed
Depends: libqt4-help (>= 4:4.7.0) but 4:4.7.2-0ubuntu6 is
to be installed
Depends: libqt4-network (>= 4:4.7.0) but 4:4.7.2-0ubuntu6
is to be installed
Depends: libqt4-script (>= 4:4.7.0) but 4:4.7.2-0ubuntu6
is to be installed
Depends: libqt4-scripttools (>= 4:4.7.0) but
4:4.7.2-0ubuntu6 is to be installed
Depends: libqt4-svg (>= 4:4.7.0) but 4:4.7.2-0ubuntu6 is
to be installed
Depends: libqt4-test (>= 4:4.7.0) but 4:4.7.2-0ubuntu6 is
to be installed
Depends: libqt4-xml (>= 4:4.7.0) but 4:4.7.2-0ubuntu6.2 is
to be installed
Depends: libqt4-xmlpatterns (>= 4:4.7.0) but
4:4.7.2-0ubuntu6 is to be installed
Depends: libqtcore4 (>= 4:4.7.0) but 4:4.7.2-0ubuntu6.2 is
to be installed
Depends: libqtgui4 (>= 4:4.7.2) but 4:4.7.2-0ubuntu6.2 is
to be installed
Depends: python (< 2.8) but 2.7.1-0ubuntu5 is to be installed
Depends: sip-api-8.1 but it is a virtual package




So I am yet debugging this how ever I wanted to report this problem
here (for any possible suggestions)
and want to know what is meant by error message

"python (< 2.8) but 2.7.1-0ubuntu5 is to be installed"

I want to also clear I got these errors while using the GUI (Software Centre).


------------------------------
Tags: calibre, ebook reader,ebook library,Ubuntu 11.04,2.7.1-0ubuntu5
Tapas

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users


All times are GMT. The time now is 12:51 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.