Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Ubuntu User (http://www.linux-archive.org/ubuntu-user/)
-   -   troubleshooting sound problems (http://www.linux-archive.org/ubuntu-user/57222-troubleshooting-sound-problems.html)

"Tomoki Taniguchi" 02-16-2008 04:15 PM

troubleshooting sound problems
 
I need help getting my sound card working on my laptop.
the sound card was working under windows prior to installing gutsy,
so i know the hardware works.

"aplay -l" gives me
**** List of PLAYBACK Hardware Devices ****
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel
82801DB-ICH4]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 4: Intel ICH -
IEC958 [Intel 82801DB-ICH4 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Modem [Intel 82801DB-ICH4 Modem], device 0: Intel ICH - Modem
[Intel 82801DB-ICH4 Modem - Modem]
Subdevices: 1/1
Subdevice #0: subdevice #0
so it seems the sound card is recognized.

i've checked alsamixer to make sure all the settings are unmuted.

but i still get no sound when i play an mp3 or a video file.

is there anything else i can try?

TIA,
Tomoki

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

sktsee 02-16-2008 11:25 PM

troubleshooting sound problems
 
On Sun, 2008-02-17 at 02:15 +0900, Tomoki Taniguchi wrote:
> I need help getting my sound card working on my laptop.
> the sound card was working under windows prior to installing gutsy,
> so i know the hardware works.
>
> "aplay -l" gives me
> **** List of PLAYBACK Hardware Devices ****
> card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel
> 82801DB-ICH4]
> Subdevices: 0/1
> Subdevice #0: subdevice #0
> card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 4: Intel ICH -
> IEC958 [Intel 82801DB-ICH4 - IEC958]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> card 1: Modem [Intel 82801DB-ICH4 Modem], device 0: Intel ICH - Modem
> [Intel 82801DB-ICH4 Modem - Modem]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> so it seems the sound card is recognized.
>
> i've checked alsamixer to make sure all the settings are unmuted.
>
> but i still get no sound when i play an mp3 or a video file.
>
> is there anything else i can try?
>
> TIA,
> Tomoki
>

Is it only mp3's or vid files where you get no sound, or do you not get
any sound period?

If you have no sound at all, can you post the complete output from the
following commands run in a terminal?

$ sudo hwinfo --sound
$ lsmod |grep snd

If you get a message that hwinfo isn't installed, issue the command
"sudo apt-get install hwinfo" and then run it.

If it's only with mp3's and vid files that you don't have sound, then it
may be that you don't have the necessary decoders installed. There's a
package in the multiverse repository that grabs a lot of packages that
provide mp3 playback and other stuff. If you have the multiverse
repository enabled, you can install it with Synaptic or with "sudo
apt-get install ubuntu-restricted-extras" (if you are on a slow
connection like dial-up, this will take a long time).

--
sktsee


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

"Tomoki Taniguchi" 02-17-2008 02:35 AM

troubleshooting sound problems
 
sound isn't working at all

results from hwinfo --sound
<snip>
20: PCI 1f.5: 0401 Multimedia audio controller
[Created at pci.281]
UDI: /org/freedesktop/Hal/devices/pci_8086_24c5
Unique ID: W60f.3l4z2BlRD+7
SysFS ID: /devices/pci0000:00/0000:00:1f.5
SysFS BusID: 0000:00:1f.5
Hardware Class: sound
Model: "Matsushita Electric Industrial 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x24c5 "82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio
Controller"
SubVendor: pci 0x10f7 "Matsushita Electric Industrial Co., Ltd."
SubDevice: pci 0x8346
Revision: 0x03
Driver: "Intel ICH"
Driver Modules: "snd_intel8x0"
I/O Ports: 0x1c00-0x1cff (rw)
I/O Ports: 0x1880-0x18bf (rw)
Memory Range: 0xe0100c00-0xe0100dff (rw,non-prefetchable)
Memory Range: 0xe0100800-0xe01008ff (rw,non-prefetchable)
IRQ: 9 (16664 events)
Module Alias: "pci:v00008086d000024C5sv000010F7sd00008346bc04sc0 1i00"
Driver Info #0:
Driver Status: i810_audio is not active
Driver Activation Cmd: "modprobe i810_audio"
Driver Info #1:
Driver Status: snd_intel8x0 is active
Driver Activation Cmd: "modprobe snd_intel8x0"
Config Status: cfg=new, avail=yes, need=no, active=unknown
<snip>

i noticed that i810_audio is not active.
so i ran "modprobe i810_audio" but still didn't get any sound

results from "lsmod | grep snd" prior to loading i810_audio
<snip>
snd_intel8x0 30332 1
snd_pcm_oss 38368 0
snd_mixer_oss 15200 1 snd_pcm_oss
snd_intel8x0m 15980 0
snd_ac97_codec 83104 2 snd_intel8x0,snd_intel8x0m
snd_ac97_bus 2400 1 snd_ac97_codec
snd_pcm 68676 4
snd_intel8x0,snd_pcm_oss,snd_intel8x0m,snd_ac97_co dec
snd_timer 20996 1 snd_pcm
snd 47012 9
snd_intel8x0,snd_pcm_oss,snd_mixer_oss,snd_intel8x 0m,snd_ac97_codec,snd_pcm,snd_timer
soundcore 9248 1 snd
snd_page_alloc 10184 3 snd_intel8x0,snd_intel8x0m,snd_pcm
<snip>

post loading i810_audio
<snip>
snd_intel8x0 30332 1
snd_pcm_oss 38368 0
snd_mixer_oss 15200 1 snd_pcm_oss
snd_intel8x0m 15980 0
snd_ac97_codec 83104 2 snd_intel8x0,snd_intel8x0m
snd_ac97_bus 2400 1 snd_ac97_codec
snd_pcm 68676 4
snd_intel8x0,snd_pcm_oss,snd_intel8x0m,snd_ac97_co dec
snd_timer 20996 1 snd_pcm
snd 47012 9
snd_intel8x0,snd_pcm_oss,snd_mixer_oss,snd_intel8x 0m,snd_ac97_codec,snd_pcm,snd_timer
soundcore 9248 2 i810_audio,snd
snd_page_alloc 10184 3 snd_intel8x0,snd_intel8x0m,snd_pcm
<snip>

results from amixer
<snip>
Simple mixer control 'Master',0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 17 [55%] [on]
Front Right: Playback 17 [55%] [on]
Simple mixer control 'Master Mono',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 31
Mono: Playback 24 [77%] [on]
Simple mixer control 'Headphone',0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 24 [77%] [on]
Front Right: Playback 24 [77%] [on]
Simple mixer control '3D Control - Center',0
Capabilities: volume volume-joined
Playback channels: Mono
Capture channels: Mono
Limits: 0 - 15
Mono: 0 [0%]
Simple mixer control '3D Control - Depth',0
Capabilities: volume volume-joined
Playback channels: Mono
Capture channels: Mono
Limits: 0 - 15
Mono: 0 [0%]
Simple mixer control '3D Control - Switch',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control 'PCM',0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 28 [90%] [on]
Front Right: Playback 28 [90%] [on]
Simple mixer control 'PCM Out Path & Mute',0
Capabilities: enum
Items: 'pre 3D' 'post 3D'
Item0: 'pre 3D'
Simple mixer control 'Line',0
Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 17 [55%] [on] Capture [off]
Front Right: Playback 17 [55%] [on] Capture [off]
Simple mixer control 'CD',0
Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 25 [81%] [on] Capture [off]
Front Right: Playback 25 [81%] [on] Capture [off]
Simple mixer control 'Mic',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-exclusive
Capture exclusive group: 0
Playback channels: Mono
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono: Playback 0 [0%] [off]
Front Left: Capture [on]
Front Right: Capture [on]
Simple mixer control 'Mic Boost (+20dB)',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control 'Mic Select',0
Capabilities: enum
Items: 'Mic1' 'Mic2'
Item0: 'Mic1'
Simple mixer control 'Video',0
Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 21 [68%] [off] Capture [off]
Front Right: Playback 21 [68%] [off] Capture [off]
Simple mixer control 'Phone',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-exclusive
Capture exclusive group: 0
Playback channels: Mono
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono: Playback 11 [35%] [off]
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control 'PC Speaker',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 15
Mono: Playback 8 [53%] [on]
Simple mixer control 'Aux',0
Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 11 [35%] [off] Capture [off]
Front Right: Playback 11 [35%] [off] Capture [off]
Simple mixer control 'Mono Output Select',0
Capabilities: enum
Items: 'Mix' 'Mic'
Item0: 'Mix'
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 15
Front Left: Capture 0 [0%] [on]
Front Right: Capture 0 [0%] [on]
Simple mixer control 'Mix',0
Capabilities: cswitch cswitch-exclusive
Capture exclusive group: 0
Capture channels: Front Left - Front Right
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control 'Mix Mono',0
Capabilities: cswitch cswitch-exclusive
Capture exclusive group: 0
Capture channels: Front Left - Front Right
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control 'External Amplifier',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
<snip>

i still don't get any sound.
is there something i can do?

TIA,
Tomoki

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users


All times are GMT. The time now is 06:01 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.