FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 08-21-2011, 11:37 AM
Graham Todd
 
Default Is Dillo Missing From Natty's repos?

I can't find the Dillo web-browser in Natty's repos and I need it to be
able to use one of the html plugins with the Claws-Mail email package
(my MUA of choice).

The Dillo web page gives only the source code, not the .deb binary, and
there are problems with the fltk dependency. When compiling the source
code, a message is flagged that the FLTK dependency can't be found.

I suppose I could go back to Lucid but that's like putting the clock
back.

I haven't been keeping up with the forum lately as I've been in
hospital, but can anyone inform me why a dependency of one of the
listed items in Natty's repos is not included in the same repos?

Dillo is a nice lightweight browser for most of my purposes (I have to
use Firefox sometimes, though) and I guess it would be the browser best
used by those with limited resources, so why can't I find it in the
repos for Natty?


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-21-2011, 11:43 AM
Alan Pope
 
Default Is Dillo Missing From Natty's repos?

On 21 August 2011 12:37, Graham Todd <grahamtodd2@gmail.com> wrote:
> I can't find the Dillo web-browser in Natty's repos and I need it to be
> able to use one of the html plugins with the Claws-Mail email package
> (my MUA of choice).
>

http://packages.ubuntu.com/search?keywords=dillo

Looks like it.

> I haven't been keeping up with the forum lately as I've been in
> hospital, but can anyone inform me why a dependency of one of the
> listed items in Natty's repos is not included in the same repos?
>

Looks like it disappeared from Debian which is probably why it's
missing in Ubuntu too.

http://packages.debian.org/search?keywords=dillo

Al.

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-21-2011, 11:50 AM
Dejan Ribič
 
Default Is Dillo Missing From Natty's repos?

Dne 21.8.2011 13:37, piše Graham Todd:

I can't find the Dillo web-browser in Natty's repos and I need it to be
able to use one of the html plugins with the Claws-Mail email package
(my MUA of choice).

The Dillo web page gives only the source code, not the .deb binary, and
there are problems with the fltk dependency. When compiling the source
code, a message is flagged that the FLTK dependency can't be found.

I suppose I could go back to Lucid but that's like putting the clock
back.

I haven't been keeping up with the forum lately as I've been in
hospital, but can anyone inform me why a dependency of one of the
listed items in Natty's repos is not included in the same repos?

Dillo is a nice lightweight browser for most of my purposes (I have to
use Firefox sometimes, though) and I guess it would be the browser best
used by those with limited resources, so why can't I find it in the
repos for Natty?



Hi,

well it says in README that you can get FLTK2 from:
http://www.dillo.org/dillo-2.x/fltk-2.0.x-r7513.tar.bz2 so I would
suggest that you do that, because it looks like that Dillo is curently
under develepmont at launchpad: https://launchpad.net/dillo you can
always join the team and help them make .deb packages.


Cheers,

Dejan


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-21-2011, 03:14 PM
Jordon Bedwell
 
Default Is Dillo Missing From Natty's repos?

On 08/21/2011 06:50 AM, Dejan Ribič wrote:
> Dne 21.8.2011 13:37, piše Graham Todd:
>> I can't find the Dillo web-browser in Natty's repos and I need it to be
>> able to use one of the html plugins with the Claws-Mail email package
>> (my MUA of choice).
>>
>> The Dillo web page gives only the source code, not the .deb binary, and
>> there are problems with the fltk dependency. When compiling the source
>> code, a message is flagged that the FLTK dependency can't be found.
>>
>> I suppose I could go back to Lucid but that's like putting the clock
>> back.
>>
>> I haven't been keeping up with the forum lately as I've been in
>> hospital, but can anyone inform me why a dependency of one of the
>> listed items in Natty's repos is not included in the same repos?
>>
>> Dillo is a nice lightweight browser for most of my purposes (I have to
>> use Firefox sometimes, though) and I guess it would be the browser best
>> used by those with limited resources, so why can't I find it in the
>> repos for Natty?
>>
>>
> Hi,
>
> well it says in README that you can get FLTK2 from:
> http://www.dillo.org/dillo-2.x/fltk-2.0.x-r7513.tar.bz2 so I would
> suggest that you do that, because it looks like that Dillo is curently
> under develepmont at launchpad: https://launchpad.net/dillo you can
> always join the team and help them make .deb packages.

Read: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=577019


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-21-2011, 08:44 PM
Ric Moore
 
Default Is Dillo Missing From Natty's repos?

On Sun, 2011-08-21 at 12:37 +0100, Graham Todd wrote:

> I suppose I could go back to Lucid but that's like putting the clock
> back.

It's a matter of perspective, you see. I think it's you running the
clock fast. I love me some Lucid. I hung onto 8.04 for the longest time.
<grins> Ric


--
My father, Victor Moore (Vic) used to say:
"There are two Great Sins in the world...
..the Sin of Ignorance, and the Sin of Stupidity.
Only the former may be overcome." R.I.P. Dad.
Linux user# 44256


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-22-2011, 09:02 AM
Graham Todd
 
Default Is Dillo Missing From Natty's repos?

On Sun, 21 Aug 2011 10:14:49 -0500
Jordon Bedwell <jordon@envygeeks.com> wrote:

> On 08/21/2011 06:50 AM, Dejan Ribič wrote:
> > Dne 21.8.2011 13:37, piše Graham Todd:
> >> I can't find the Dillo web-browser in Natty's repos and I need it
> >> to be able to use one of the html plugins with the Claws-Mail
> >> email package (my MUA of choice).
> >>
> >> The Dillo web page gives only the source code, not the .deb
> >> binary, and there are problems with the fltk dependency. When
> >> compiling the source code, a message is flagged that the FLTK
> >> dependency can't be found.
> >>
> >> I suppose I could go back to Lucid but that's like putting the
> >> clock back.
> >>
> >> I haven't been keeping up with the forum lately as I've been in
> >> hospital, but can anyone inform me why a dependency of one of the
> >> listed items in Natty's repos is not included in the same repos?
> >>
> >> Dillo is a nice lightweight browser for most of my purposes (I
> >> have to use Firefox sometimes, though) and I guess it would be the
> >> browser best used by those with limited resources, so why can't I
> >> find it in the repos for Natty?
> >>
> >>
> > Hi,
> >
> > well it says in README that you can get FLTK2 from:
> > http://www.dillo.org/dillo-2.x/fltk-2.0.x-r7513.tar.bz2 so I would
> > suggest that you do that, because it looks like that Dillo is
> > curently under develepmont at launchpad:
> > https://launchpad.net/dillo you can always join the team and help
> > them make .deb packages.
>
> Read: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=577019
>
>

AAAH...that explains it:

Please remove dillo:
- Depends on long-obsolete GTK 1.2 libs (#515271)
- Broken HTTPS support (#510348)
- Security bugs unfixed for more than nine months (#535788), #560874
- Newer upstream releases depend on fltk2 which has license problems
- Unmaintained (#575240)

I guess I'll have to inform the Claws-Mail list.....

Graham

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-22-2011, 01:44 PM
sktsee
 
Default Is Dillo Missing From Natty's repos?

On 08/22/2011 04:02 AM, Graham Todd wrote:

[snip]


AAAH...that explains it:

Please remove dillo:
- Depends on long-obsolete GTK 1.2 libs (#515271)
- Broken HTTPS support (#510348)
- Security bugs unfixed for more than nine months (#535788), #560874
- Newer upstream releases depend on fltk2 which has license problems
- Unmaintained (#575240)

I guess I'll have to inform the Claws-Mail list.....

Graham



The situation will probably change in at least the next couple of weeks
if not sooner. FLTK1.3 is in Debian unstable now, and a development
snapshot of Dillo 3.0 is in experimental. Final release of 3.0 is
supposed to be out sometime by the end this month. Soon after it'll
probably make its way into Debian unstable, though it'll be too late to
be included in Ubuntu Oneric. I would expect that it'll be available in
a ppa not long after its final release.


--
sktsee


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-22-2011, 02:27 PM
Jordon Bedwell
 
Default Is Dillo Missing From Natty's repos?

On 08/22/2011 08:44 AM, sktsee wrote:
> On 08/22/2011 04:02 AM, Graham Todd wrote:
>
> [snip]
>>
>> AAAH...that explains it:
>>
>> Please remove dillo:
>> - Depends on long-obsolete GTK 1.2 libs (#515271)
>> - Broken HTTPS support (#510348)
>> - Security bugs unfixed for more than nine months (#535788), #560874
>> - Newer upstream releases depend on fltk2 which has license problems
>> - Unmaintained (#575240)
>>
>> I guess I'll have to inform the Claws-Mail list.....
>>
>> Graham
>>
>
> The situation will probably change in at least the next couple of weeks
> if not sooner. FLTK1.3 is in Debian unstable now, and a development
> snapshot of Dillo 3.0 is in experimental. Final release of 3.0 is
> supposed to be out sometime by the end this month. Soon after it'll
> probably make its way into Debian unstable, though it'll be too late to
> be included in Ubuntu Oneric. I would expect that it'll be available in
> a ppa not long after its final release.

It was too late when it was reintroduced into experimental. Just sayin'

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 04:08 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org