FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 03-09-2011, 03:35 AM
Abhishek Dixit
 
Default wubi does not install grub and neither correctly copies the modules of grub

Here is a situation 1 week back I had asked in this list about a clean
way to install Ubuntu on a friends laptop and how to uninstall.
I have installed and things worked by now perfectly without any problem.
We are trying to set up a Xen (virtualization)environment in this
laptop as this is the only piece of good hardware with VT support in
built available to us.
After setting up every thing cleanly.
When I needed to boot with following grub entries

menuentry "Xen Linux 2.6.32.27" {
insmod ntfs
set root='(hd0,2)'
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
multiboot /boot/xen.gz
module /boot/vmlinuz-2.6.32.27 dummy=dummy root=/dev/sda2
loop=/ubuntu/disks/root.disk ro console=tty0
module /boot/initrd.img-2.6.32.27
}

I got
error:file not found.
when booting and command multiboot ,kernel,module are not present.

Now to dig this issue further I reboot the machine and go to grub command prompt

and manually pass on each of the above parameters which you see in the
grub entry
when I reached
grub> insmod multiboot
then I got following message on screen
error:file not found.

It looks like my grub setup has just enough modules to use loopback
file on ntfs, but the ACTUAL /boot directory is on the loopback NOT
ntfs (hd0,2). Therefore any attempt to read any files from (hd0,2)
simply wont work, cause there's no file there.It's a somewhat
advanced setup, I am trying to troubleshoot ntfs-loop-xen
combination.This is not Xen-specific, but rather wubi - grub -
multiboot
issue.I want to know how can I install the missing modules of grub in Wubi?
I need to use insmod multiboot and commands kernel,module available in
grub in this Ubuntu setup which was done using Wubi.


I searched on internet and
http://ubuntuforums.org/showthread.php?t=1546788
it seems Wubi simply does not installs grub based on above link,
http://ubuntuforums.org/showthread.php?t=1546603
So my question is what is happening is Wubi booting or grub booting in
this installation from Wubi and why are the files in /boot/grub
directory empty?
While a normal Kernel is still booting?
How can I get module multiboot in this Wubi based install.
Since the laptop is given to me on trust so I can not format drives
and use a usual partition without Wubi type setup so any clues what
should I do in this situation?

--

Regards
Abhi

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 09:53 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org