Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Ubuntu User (http://www.linux-archive.org/ubuntu-user/)
-   -   Problem during upgrade from 08.04 LTS to 10.04.1 LTS (http://www.linux-archive.org/ubuntu-user/476824-problem-during-upgrade-08-04-lts-10-04-1-lts.html)

Fredrik Jonson 01-15-2011 07:00 AM

Problem during upgrade from 08.04 LTS to 10.04.1 LTS
 
Jay Ridgley wrote:

> I am attempting to upgrade one of my systems from 08.04 LTS [and] the
> following message appears:
>
> E:Couldn't configure pre-depend jre for openoffice.org-writer2latex,
> probably a dependence cycle.'

In cases like this one you can probably uninstall the offending package and then
attempt the upgrade again.

Though, as mentioned, I'm not sure a upgrade over two versions is a great idea,
see the upgrade documentation:

https://help.ubuntu.com/community/UpgradeNotes

I recommend doing a backup and starting over with a fresh install instead of
upgrading a such old release. It's a great opportunity to relieve the computer
of old cruft too.

--
Fredrik Jonson


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Ric Moore 01-16-2011 06:10 PM

Problem during upgrade from 08.04 LTS to 10.04.1 LTS
 
On Sat, 2011-01-15 at 08:00 +0000, Fredrik Jonson wrote:
> Jay Ridgley wrote:
>
> > I am attempting to upgrade one of my systems from 08.04 LTS [and] the
> > following message appears:
> >
> > E:Couldn't configure pre-depend jre for openoffice.org-writer2latex,
> > probably a dependence cycle.'
>
> In cases like this one you can probably uninstall the offending package and then
> attempt the upgrade again.
>
> Though, as mentioned, I'm not sure a upgrade over two versions is a great idea,
> see the upgrade documentation:
>
> https://help.ubuntu.com/community/UpgradeNotes
>
> I recommend doing a backup and starting over with a fresh install instead of
> upgrading a such old release. It's a great opportunity to relieve the computer
> of old cruft too.
+1 I concur. I get copies of the Devel list and I have yet to see any
discussion checking if 8.04 updated correctly to 10.4 ...nary once. It's
a noble goal to be able to update from one LTS to the next, but I am
leery of that big a jump and to have all of your .dot and /etc files go
along with the plan successfully. I see nothing but a potential trail of
tears. :) Ric


--
My father, Victor Moore (Vic) used to say:
"There are two Great Sins in the world...
..the Sin of Ignorance, and the Sin of Stupidity.
Only the former may be overcome." R.I.P. Dad.
Linux user# 44256


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Robert Holtzman 01-16-2011 07:29 PM

Problem during upgrade from 08.04 LTS to 10.04.1 LTS
 
On Sun, Jan 16, 2011 at 02:10:54PM -0500, Ric Moore wrote:

.........snip........

> +1 I concur. I get copies of the Devel list and I have yet to see any
> discussion checking if 8.04 updated correctly to 10.4 ...nary once. It's
> a noble goal to be able to update from one LTS to the next, but I am
> leery of that big a jump and to have all of your .dot and /etc files go
> along with the plan successfully. I see nothing but a potential trail of
> tears. :) Ric

Gee. I guess my two upgrades of LTS releases were anomalies.

--
Bob Holtzman
Key ID: 8D549279
"If you think you're getting free lunch,
check the price of the beer"
--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Tom H 01-16-2011 09:20 PM

Problem during upgrade from 08.04 LTS to 10.04.1 LTS
 
On Sun, Jan 16, 2011 at 2:10 PM, Ric Moore <wayward4now@gmail.com> wrote:
> On Sat, 2011-01-15 at 08:00 +0000, Fredrik Jonson wrote:
>> Jay Ridgley wrote:
>>
>> > *I am attempting to upgrade one of my systems from 08.04 LTS [and] the
>> > *following message appears:
>> >
>> > *E:Couldn't configure pre-depend jre for openoffice.org-writer2latex,
>> > *probably a dependence cycle.'
>>
>> In cases like this one you can probably uninstall the offending package and then
>> attempt the upgrade again.
>>
>> Though, as mentioned, I'm not sure a upgrade over two versions is a great idea,
>> see the upgrade documentation:
>>
>> https://help.ubuntu.com/community/UpgradeNotes
>>
>> I recommend doing a backup and starting over with a fresh install instead of
>> upgrading a such old release. It's a great opportunity to relieve the computer
>> of old cruft too.
>
> +1 I concur. I get copies of the Devel list and I have yet to see any
> discussion checking if 8.04 updated correctly to 10.4 ...nary once. It's
> a noble goal to be able to update from one LTS to the next, but I am
> leery of that big a jump and to have all of your .dot and /etc files go
> along with the plan successfully. I see nothing but a potential trail of
> tears.

I'd be interested to know what's special about an LTS to LTS upgrade.
There's no reason why an 8.04 to 10.04 upgrade'd be successful but an
8.10 to 10.10 upgrade wouldn't be - other than marketing. If done
carefully, both these upgrades should be possible given that it's
possible (and possibly encouraged) to upgrade from one Debian version
to another when they're published 2-3 years apart.

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Colin Law 01-16-2011 09:30 PM

Problem during upgrade from 08.04 LTS to 10.04.1 LTS
 
On 16 January 2011 22:20, Tom H <tomh0665@gmail.com> wrote:
>
> I'd be interested to know what's special about an LTS to LTS upgrade.
> There's no reason why an 8.04 to 10.04 upgrade'd be successful but an
> 8.10 to 10.10 upgrade wouldn't be - other than marketing. If done
> carefully, both these upgrades should be possible given that it's
> possible (and possibly encouraged) to upgrade from one Debian version
> to another when they're published 2-3 years apart.

The difference is that the upgrade software is designed to cope with
LTS to LTS but otherwise only one release at a time. This is so that
a user can specifically choose to use only LTS versions.

Colin

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Ric Moore 01-17-2011 02:44 AM

Problem during upgrade from 08.04 LTS to 10.04.1 LTS
 
On Sun, 2011-01-16 at 13:29 -0700, Robert Holtzman wrote:
> On Sun, Jan 16, 2011 at 02:10:54PM -0500, Ric Moore wrote:
>
> .........snip........
>
> > +1 I concur. I get copies of the Devel list and I have yet to see any
> > discussion checking if 8.04 updated correctly to 10.4 ...nary once. It's
> > a noble goal to be able to update from one LTS to the next, but I am
> > leery of that big a jump and to have all of your .dot and /etc files go
> > along with the plan successfully. I see nothing but a potential trail of
> > tears. :) Ric
>
> Gee. I guess my two upgrades of LTS releases were anomalies.

As I wrote I would expect it to be fulla holes. If not, then great! Me,
I wouldn't do it. :) Ric


--
My father, Victor Moore (Vic) used to say:
"There are two Great Sins in the world...
..the Sin of Ignorance, and the Sin of Stupidity.
Only the former may be overcome." R.I.P. Dad.
Linux user# 44256


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Tom H 01-17-2011 08:42 AM

Problem during upgrade from 08.04 LTS to 10.04.1 LTS
 
On Sun, Jan 16, 2011 at 5:30 PM, Colin Law <clanlaw@googlemail.com> wrote:
> On 16 January 2011 22:20, Tom H <tomh0665@gmail.com> wrote:
>>
>> I'd be interested to know what's special about an LTS to LTS upgrade.
>> There's no reason why an 8.04 to 10.04 upgrade'd be successful but an
>> 8.10 to 10.10 upgrade wouldn't be - other than marketing. If done
>> carefully, both these upgrades should be possible given that it's
>> possible (and possibly encouraged) to upgrade from one Debian version
>> to another when they're published 2-3 years apart.
>
> The difference is that the upgrade software is designed to cope with
> LTS to LTS but otherwise only one release at a time. *This is so that
> a user can specifically choose to use only LTS versions.

The upgrade tool's set up to allow you to go from 8.04 to 10.04 and
not from 8.10 to 10.10 but there's no technical reason why an upgrade
from 8.10 to 10.10 wouldn't be successful when an upgrade from 8.04 to
10.04 would be.

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Colin Law 01-17-2011 09:10 AM

Problem during upgrade from 08.04 LTS to 10.04.1 LTS
 
On 17 January 2011 09:42, Tom H <tomh0665@gmail.com> wrote:
> On Sun, Jan 16, 2011 at 5:30 PM, Colin Law <clanlaw@googlemail.com> wrote:
>> On 16 January 2011 22:20, Tom H <tomh0665@gmail.com> wrote:
>>>
>>> I'd be interested to know what's special about an LTS to LTS upgrade.
>>> There's no reason why an 8.04 to 10.04 upgrade'd be successful but an
>>> 8.10 to 10.10 upgrade wouldn't be - other than marketing. If done
>>> carefully, both these upgrades should be possible given that it's
>>> possible (and possibly encouraged) to upgrade from one Debian version
>>> to another when they're published 2-3 years apart.
>>
>> The difference is that the upgrade software is designed to cope with
>> LTS to LTS but otherwise only one release at a time. *This is so that
>> a user can specifically choose to use only LTS versions.
>
> The upgrade tool's set up to allow you to go from 8.04 to 10.04 and
> not from 8.10 to 10.10 but there's no technical reason why an upgrade
> from 8.10 to 10.10 wouldn't be successful when an upgrade from 8.04 to
> 10.04 would be.

There is a technical reason, which is that the tool has not been setup
to cope with 8.10 to 10.10. The work has not been done to allow that.
If you meant that there is no technical reason why the tool *could*
have been setup to cope with it then you are likely correct, but
presumably it was judged that the effort in doing this was not
worthwhile.

Colin
Do you mean 'there is no techn

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Tom H 01-17-2011 03:48 PM

Problem during upgrade from 08.04 LTS to 10.04.1 LTS
 
On Mon, Jan 17, 2011 at 5:10 AM, Colin Law <clanlaw@googlemail.com> wrote:
> On 17 January 2011 09:42, Tom H <tomh0665@gmail.com> wrote:
>> On Sun, Jan 16, 2011 at 5:30 PM, Colin Law <clanlaw@googlemail.com> wrote:
>>> On 16 January 2011 22:20, Tom H <tomh0665@gmail.com> wrote:
>>>>
>>>> I'd be interested to know what's special about an LTS to LTS upgrade.
>>>> There's no reason why an 8.04 to 10.04 upgrade'd be successful but an
>>>> 8.10 to 10.10 upgrade wouldn't be - other than marketing. If done
>>>> carefully, both these upgrades should be possible given that it's
>>>> possible (and possibly encouraged) to upgrade from one Debian version
>>>> to another when they're published 2-3 years apart.
>>>
>>> The difference is that the upgrade software is designed to cope with
>>> LTS to LTS but otherwise only one release at a time. *This is so that
>>> a user can specifically choose to use only LTS versions.
>>
>> The upgrade tool's set up to allow you to go from 8.04 to 10.04 and
>> not from 8.10 to 10.10 but there's no technical reason why an upgrade
>> from 8.10 to 10.10 wouldn't be successful when an upgrade from 8.04 to
>> 10.04 would be.
>
> There is a technical reason, which is that the tool has not been setup
> to cope with 8.10 to 10.10. *The work has not been done to allow that.
> *If you meant that there is no technical reason why the tool *could*
> have been setup to cope with it then you are likely correct, but
> presumably it was judged that the effort in doing this was not
> worthwhile.

I agree with the latter part of your last email. For the tool not to
have been set up to allow a non-LTS version to be upgraded to a
non-consecutive version is a fake technical reason. It's a more or
less understandable decision given that any upgrade can go south
easily but...

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Pastor JW 01-18-2011 03:25 AM

Problem during upgrade from 08.04 LTS to 10.04.1 LTS
 
On Sunday, January 16, 2011 11:10:54 am Ric Moore wrote:
> On Sat, 2011-01-15 at 08:00 +0000, Fredrik Jonson wrote:
> > Jay Ridgley wrote:
> > > I am attempting to upgrade one of my systems from 08.04 LTS [and] the
> > > following message appears:
> > >
> > > E:Couldn't configure pre-depend jre for openoffice.org-writer2latex,
> > > probably a dependence cycle.'
> >
> > In cases like this one you can probably uninstall the offending package
> > and then attempt the upgrade again.

Was Open Office the normal Hardy or one of the PPAs? In any case, the un-
installing cure should work. It can be reinstalled from your working upgraded
system. I have never had to do it though.

> > Though, as mentioned, I'm not sure a upgrade over two versions is a great
> > idea, see the upgrade documentation:
> >
> > https://help.ubuntu.com/community/UpgradeNotes
> >
> > I recommend doing a backup and starting over with a fresh install instead
> > of upgrading a such old release. It's a great opportunity to relieve the
> > computer of old cruft too.
>
> +1 I concur. I get copies of the Devel list and I have yet to see any
> discussion checking if 8.04 updated correctly to 10.4 ...nary once. It's
> a noble goal to be able to update from one LTS to the next, but I am
> leery of that big a jump and to have all of your .dot and /etc files go
> along with the plan successfully. I see nothing but a potential trail of
> tears. :) Ric

Well 39 machines so far have been directly upgraded from 8.04 to 10.04,
however, since it was in the instructions, everyone of them was done from
gnome rather then from the normal KDE each of them always use. None had a
problem. Of course, none of them had nvidia anything on them.


--
73 de N7PSV aka Pastor JW <n>< PDGA# 35276
http://the-inner-circle.org _Registered Kubuntu User: #27403
http://groups.yahoo.com/group/the_original_inner_circle
http://h.webring.com/hub?ring=universalministr

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users


All times are GMT. The time now is 05:23 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.