FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.

» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

LinkBack Thread Tools
Old 01-12-2011, 02:05 PM
Default Latest karmic update failed.

After seeing the update gui fail with a cryptic message and no
report/listing/diagnostics, I ran
sudo apt-get update && sudo apt-get upgrade
and got this:

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6: Depends: libc-bin (= 2.10.1-0ubuntu18)
but 2.10.1-0ubuntu19 is installed
E: Unmet dependencies. Try using -f.

As I read that, libc-bin is ahead of the 'depends' that libc6 is
complaining about.

Is using "-f" the proper thing to do in this case (an upgrade)?
apt-get's man page's description of "-f" seems to cover "install/remove"
-- not so much an "upgrade". I'm a little new with ubuntu and this is
my first snafu with apt-get.

(Is there not a 'depends ... or better' specification that could be used
in upgrade check lists? I've seen this sort of catch-22 back in my
Mandrake/PRM days.)

Marvin L Jones | jonz | W3DHJ | linux
38.24N 104.55W | @ config.com | Jonesy | OS/2
* Killfiling google & XXXXbanter.com: jonz.net/ng.htm

ubuntu-users mailing list
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Thread Tools

All times are GMT. The time now is 02:48 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org