FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 09-23-2010, 05:12 AM
Tapas Mishra
 
Default openacs installation problem

I tried installing openacs on lucid
apt-get install openacs every thing went fine upto some time until
some where it stopped.
Can not say what is the error what do or how do I check where it
stopped and what changes had it made to the system.


--
Tapas

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-23-2010, 05:17 AM
Tapas Mishra
 
Default openacs installation problem

Ok these are the error messages I could catch.


error when trying to connect to the pgsql database. This error can
occur if you have no database to connect to, or if the password was
incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
Error when trying to connect to the pgsql database. This error can
occur if you have no database to connect to, or if the password was
incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
Error when trying to connect to the pgsql database. This error can
occur if you have no database to connect to, or if the password was
incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
* Stopping web server aolserver4
start-stop-daemon: warning: failed to kill 30391: No such
process
[ OK ]
* Stopping web server openacs [ OK ]
* Starting web server aolserver4
[23/Sep/2010:10:33:34][30656.475354880][-main-] Error:
prebind: invalid entry: 127.0.0.1:80: Address already in use




I am already running apache on the target machine so might be that is
conflicting.
It is not possible to stop as a website is running on that and on the
same time I have to install openacs which uses aolserver at port 80 in
a way that it works correctly and at a different port.
Apache 80
AOLServer some 3001 like that.

--
Tapas

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-23-2010, 10:17 AM
Tim Frost
 
Default openacs installation problem

Tapas,


On Thu, 2010-09-23 at 10:47 +0530, Tapas Mishra wrote:
> Ok these are the error messages I could catch.
>
>
> error when trying to connect to the pgsql database. This error can
> occur if you have no database to connect to, or if the password was
> incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
> Error when trying to connect to the pgsql database. This error can
> occur if you have no database to connect to, or if the password was
> incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
> Error when trying to connect to the pgsql database. This error can
> occur if you have no database to connect to, or if the password was
> incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.

Openacs needs to be able to access a postgres database, and the
configuration process for openacs asks for:
- what host is the database on
- credentials to access that database

These errors indicate that the postgres credentials that openacs is
configured to use may be incorrect, or that communication with the
database is not fully set up. (This might also indicate that the
database isn't configured for remote access, or that openacs is using
the wrong name or IP address for the database server).

> * Stopping web server aolserver4
> start-stop-daemon: warning: failed to kill 30391: No such
> process
> [ OK ]
> * Stopping web server openacs [ OK ]
> * Starting web server aolserver4
> [23/Sep/2010:10:33:34][30656.475354880][-main-] Error:
> prebind: invalid entry: 127.0.0.1:80: Address already in use
>
>
>
>
> I am already running apache on the target machine so might be that is
> conflicting.

That is almost certainly the issue here. The Apache server will be
listening on port 80 for all IP addresses, including localhost (IP
address 127.0.0.1), unless it is explicitly configured not to.

The error messages indicate that the aolserver package is installing a
program that is also using (or at least attempting to use) port 80,
which causes the conflict.

> It is not possible to stop as a website is running on that and on the
> same time I have to install openacs which uses aolserver at port 80 in
> a way that it works correctly and at a different port.
> Apache 80
> AOLServer some 3001 like that.

For AOLserver, there may be at least the following options:
1: run the AOL server on its own port
2: configure Apache to recognise AOL traffic, based on the URL, and pass
it to the AOL server process


I don't use AOLserver or openacs, so don't know how to configure them to
use an alternative port (or hostname/IP address) to communicate



>
> --
> Tapas
>

Tim

--
Tim Frost <timfrost@xtra.co.nz>
--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-23-2010, 12:00 PM
Tapas Mishra
 
Default openacs installation problem

On Thu, Sep 23, 2010 at 3:47 PM, Tim Frost <timfrost@xtra.co.nz> wrote:
>>
>>
>> error when trying to connect to the pgsql database. This error can
>> occur if you have no database to connect to, or if the password was
>> incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
>> Error when trying to connect to the pgsql database. This error can
>> occur if you have no database to connect to, or if the password was
>> incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
Did what you suggested
dpkg-reconfigure -plow postgresql

also checked
dpkg -s postgresql

Package: postgresql
Status: install ok installed
Priority: optional
Section: database
Installed-Size: 48
Maintainer: Martin Pitt <martin.pitt@ubuntu.com>
Architecture: all
Source: postgresql-8.4
Version: 8.4.4-0ubuntu10.04
Depends: postgresql-8.4


>> Error when trying to connect to the pgsql database. This error can
>> occur if you have no database to connect to, or if the password was
>> incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
when as root I type

psql
psql: FATAL: Ident authentication failed for user "root"

how will I get the psql prompt any idea?
I have checked this page
http://www.postgresql.org/docs/9.0/interactive/index.html
they talk about creating database and things like that but I am not
able to find
if I have to do some thing to be able to run it as root
(just to make eliminate that openacs is not able to connect to postgresql)


> The error messages indicate that the aolserver package is installing a
> program that is also using (or at least attempting to use) port 80,
> which causes the conflict.

Right

>
> For AOLserver, there may be at least the following options:
> 1: run the AOL server on its own port
Ok
> 2: configure Apache to recognise AOL traffic, based on the URL, and pass
> it to the AOL server process
This will happen only when I will finish installation of openacs or
some thing different is possible.

> I don't use AOLserver or openacs, so don't know how to configure them to
> use an alternative port (or hostname/IP address) to communicate
ok if some one else wishes to reply the problem is during installation itself
apt-get install openacs
it tries to install aolserver and start that aolserver at 80 which is
not successful since Apache is listening at 80.
Is there a way that during installation I can control aolserver from
starting so that conflict does not happen
and when I install it I configure where ever I choose a different port.

--
Tapas

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 02-22-2011, 09:40 AM
Tapas Mishra
 
Default openacs installation problem

root@ubuntu:~# aptitude install openacs
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following NEW packages will be installed:
aolserver4-core{a} aolserver4-daemon{a} aolserver4-doc{a}
aolserver4-nspostgres{a} aolserver4-nssha1{a} aolserver4-xotcl{a}
libpq5{a} openacs postgresql-client{a} postgresql-client-8.4{a}
postgresql-client-common{a} tcl{a} tcllib{a} tclthread{a} tdom{a}
wwwconfig-common{a} xotcl{a}
0 packages upgraded, 17 newly installed, 0 to remove and 240 not upgraded.
Need to get 19.4MB of archives. After unpacking 92.7MB will be used.
Do you want to continue? [Y/n/?] Y
Writing extended state information... Done
Get:1 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
aolserver4-core 4.5.1-12 [309kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
aolserver4-daemon 4.5.1-12 [172kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
aolserver4-doc 4.5.1-12 [3,318kB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main libpq5
8.4.7-0ubuntu0.10.04 [86.2kB]
Get:5 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
aolserver4-nspostgres 4.5-3 [24.7kB]
Get:6 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
aolserver4-nssha1 0.1-3 [8,716B]
Get:7 http://us.archive.ubuntu.com/ubuntu/ lucid/main tcl 8.4.16-2 [4,154B]
Get:8 http://us.archive.ubuntu.com/ubuntu/ lucid/universe xotcl
1.6.5-1.2 [309kB]
Get:9 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
aolserver4-xotcl 1.6.5-1.2 [50.9kB]
Get:10 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main
postgresql-client-common 106ubuntu1 [52.4kB]
Get:11 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main
postgresql-client-8.4 8.4.7-0ubuntu0.10.04 [786kB]
Get:12 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main
postgresql-client 8.4.7-0ubuntu0.10.04 [20.1kB]
Get:13 http://us.archive.ubuntu.com/ubuntu/ lucid/universe tclthread
1:2.6.5-3 [123kB]
Get:14 http://us.archive.ubuntu.com/ubuntu/ lucid/universe tcllib
1.12-dfsg-2 [3,863kB]
Get:15 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
wwwconfig-common 0.2.1 [22.8kB]
Get:16 http://us.archive.ubuntu.com/ubuntu/ lucid/universe tdom
0.8.3~20080525-3 [266kB]
Get:17 http://us.archive.ubuntu.com/ubuntu/ lucid/universe openacs
5.5.1-2 [9,962kB]
Fetched 19.4MB in 5min 1s (64.2kB/s)
Preconfiguring packages ...
Selecting previously deselected package aolserver4-core.
(Reading database ... 124160 files and directories currently installed.)
Unpacking aolserver4-core (from .../aolserver4-core_4.5.1-12_i386.deb) ...
Selecting previously deselected package aolserver4-daemon.
Unpacking aolserver4-daemon (from .../aolserver4-daemon_4.5.1-12_i386.deb) ...
Selecting previously deselected package aolserver4-doc.
Unpacking aolserver4-doc (from .../aolserver4-doc_4.5.1-12_all.deb) ...
Selecting previously deselected package libpq5.
Unpacking libpq5 (from .../libpq5_8.4.7-0ubuntu0.10.04_i386.deb) ...
Selecting previously deselected package aolserver4-nspostgres.
Unpacking aolserver4-nspostgres (from
.../aolserver4-nspostgres_4.5-3_i386.deb) ...
Selecting previously deselected package aolserver4-nssha1.
Unpacking aolserver4-nssha1 (from .../aolserver4-nssha1_0.1-3_i386.deb) ...
Selecting previously deselected package tcl.
Unpacking tcl (from .../archives/tcl_8.4.16-2_all.deb) ...
Selecting previously deselected package xotcl.
Unpacking xotcl (from .../xotcl_1.6.5-1.2_i386.deb) ...
Selecting previously deselected package aolserver4-xotcl.
Unpacking aolserver4-xotcl (from .../aolserver4-xotcl_1.6.5-1.2_all.deb) ...
Selecting previously deselected package postgresql-client-common.
Unpacking postgresql-client-common (from
.../postgresql-client-common_106ubuntu1_all.deb) ...
Selecting previously deselected package postgresql-client-8.4.
Unpacking postgresql-client-8.4 (from
.../postgresql-client-8.4_8.4.7-0ubuntu0.10.04_i386.deb) ...
Selecting previously deselected package postgresql-client.
Unpacking postgresql-client (from
.../postgresql-client_8.4.7-0ubuntu0.10.04_all.deb) ...
Selecting previously deselected package tclthread.
Unpacking tclthread (from .../tclthread_1%3a2.6.5-3_i386.deb) ...
Selecting previously deselected package tcllib.
Unpacking tcllib (from .../tcllib_1.12-dfsg-2_all.deb) ...
Selecting previously deselected package wwwconfig-common.
Unpacking wwwconfig-common (from .../wwwconfig-common_0.2.1_all.deb) ...
Selecting previously deselected package tdom.
Unpacking tdom (from .../tdom_0.8.3~20080525-3_i386.deb) ...
Selecting previously deselected package openacs.
Unpacking openacs (from .../openacs_5.5.1-2_all.deb) ...
Processing triggers for man-db ...
Processing triggers for doc-base ...
Processing 26 changed 6 added doc-base file(s)...
Registering documents with scrollkeeper...
Setting up aolserver4-core (4.5.1-12) ...
Setting up aolserver4-daemon (4.5.1-12) ...
* Starting web server aolserver4
[22/Feb/2011:02:25:39][18495.3078551232][-main-] Notice: prebind:
bound: 127.0.0.1:80
[ OK ]
chmod: cannot access `/var/www/index.adp': No such file or directory

Setting up aolserver4-doc (4.5.1-12) ...
Setting up libpq5 (8.4.7-0ubuntu0.10.04) ...

Setting up aolserver4-nspostgres (4.5-3) ...
Setting up aolserver4-nssha1 (0.1-3) ...
Setting up tcl (8.4.16-2) ...
update-alternatives: using /usr/bin/tclsh-default to provide
/usr/bin/tclsh (tclsh) in auto mode.

Setting up xotcl (1.6.5-1.2) ...
Setting up aolserver4-xotcl (1.6.5-1.2) ...
Setting up postgresql-client-common (106ubuntu1) ...
Setting up postgresql-client-8.4 (8.4.7-0ubuntu0.10.04) ...
update-alternatives: using
/usr/share/postgresql/8.4/man/man1/psql.1.gz to provide
/usr/share/man/man1/psql.1.gz (psql.1.gz) in auto mode.

Setting up postgresql-client (8.4.7-0ubuntu0.10.04) ...
Setting up tclthread (1:2.6.5-3) ...
Setting up tcllib (1.12-dfsg-2) ...
Setting up wwwconfig-common (0.2.1) ...
Setting up tdom (0.8.3~20080525-3) ...
Setting up openacs (5.5.1-2) ...
Error when trying to connect to the pgsql database. This error can
occur if you have no database to connect to, or if the password was
incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
Error when trying to connect to the pgsql database. This error can
occur if you have no database to connect to, or if the password was
incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
Error when trying to connect to the pgsql database. This error can
occur if you have no database to connect to, or if the password was
incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
* Stopping web server aolserver4 [ OK ]
* Starting web server aolserver4
[22/Feb/2011:02:25:44][19260.3078665920][-main-] Notice: prebind:
bound: 127.0.0.1:80
[ OK ]
* Starting AOL instance openacs
[22/Feb/2011:02:25:45][19274.3078444736][-main-] Notice: prebind:
bound: 127.0.0.1:8000
[ OK ]
Error when trying to connect to the pgsql database. This error can
occur if you have no database to connect to, or if the password was
incorrect. use: dpkg-reconfigure -plow packagename to reconfigure.
-------------------------------------------------------------
I've tried my best to create the OpenACS user and database
but an error has occurred
-------------------------------------------------------------
You will have to set up the OpenACS user and database yourself
-------------------------------------------------------------
[22/Feb/2011:02:25:45][19275.3078444736][-main-] Notice: nsd.tcl:
starting to read config file...
[22/Feb/2011:02:25:45][19275.3078444736][-main-] Notice: nsd.tcl:
using threadsafe tcl: 1
[22/Feb/2011:02:25:45][19275.3078444736][-main-] Notice: nsd.tcl:
finished reading config file.

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

after this I expcected some thing on http://localhost:8000
but there was nothing.I tried on lucid.
--

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 03:14 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org