FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 09-22-2010, 12:06 AM
Christopher Chan
 
Default ping Goh Lip - grub2 specialist

Hey Goh Lip,

Know anything about the lousy grub-pc package in Hardy?

Got two disks, sda and sdb. Two primary partitions on each (1,2) with
the 1 partitions going to md0 for raid1, ext2 and the 2 partitions going
to md1 for raid1, pv.

grub-install will complain about "unknown device" if I feed it /dev/sda
or dev/sdb or '(hd0)' but will complain about "Can't embed core.img blah
blah" if I feed it /dev/md0. Rather, grub-setup will complain after
grub-install passes the flags onto grub-setup.

cheers,

Christopher

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-22-2010, 01:33 AM
Fajar Priyanto
 
Default ping Goh Lip - grub2 specialist

On Wed, Sep 22, 2010 at 8:06 AM, Christopher Chan
<christopher.chan@bradbury.edu.hk> wrote:
> Got two disks, sda and sdb. Two primary partitions on each (1,2) with
> the 1 partitions going to md0 for raid1, ext2 and the 2 partitions going
> to md1 for raid1, pv.
>
> grub-install will complain about "unknown device" if I feed it /dev/sda
> or dev/sdb or '(hd0)' but will complain about "Can't embed core.img blah
> blah" if I feed it /dev/md0. Rather, grub-setup will complain after
> grub-install passes the flags onto grub-setup.

I believe you want it to be:
grub-install /dev/sda1 (and) grub-install /dev/sdb1

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 09-22-2010, 01:52 AM
Christopher Chan
 
Default ping Goh Lip - grub2 specialist

On Wednesday, September 22, 2010 09:33 AM, Fajar Priyanto wrote:
> On Wed, Sep 22, 2010 at 8:06 AM, Christopher Chan
> <christopher.chan@bradbury.edu.hk> wrote:
>> Got two disks, sda and sdb. Two primary partitions on each (1,2) with
>> the 1 partitions going to md0 for raid1, ext2 and the 2 partitions going
>> to md1 for raid1, pv.
>>
>> grub-install will complain about "unknown device" if I feed it /dev/sda
>> or dev/sdb or '(hd0)' but will complain about "Can't embed core.img blah
>> blah" if I feed it /dev/md0. Rather, grub-setup will complain after
>> grub-install passes the flags onto grub-setup.
>
> I believe you want it to be:
> grub-install /dev/sda1 (and) grub-install /dev/sdb1
>

Why would I want to stick grub on the boot partition and not the MBR?

Anyway, in your interest, I went ahead and tried anyway. Lo and behold!
unknown device. Please leave this one to Goh Lip. I am sure he has some
work around or knows what I missed such that grub2 on Hardy is misbehaving.

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 08:58 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org