FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 06-23-2010, 01:05 PM
Nathan Bahn
 
Default Trying to Update Firefox 3.6.3 on 09.10

Hello everyone--

So I get a message saying that FF cannot update -- or words to that effect -- because it does not have the permissions required to access the root directory.* After doing some looking around, I conclude that I need to set up an administrative account.* I do so; however, I still get a message stating that FF doesn't have the necessary permissions even though I AM IN the new just-created administrative account.* So what's going on?* Why won't FF3.6.3 update from an administrative account in 09.10?

--N.B.
--
Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html & http://www.openoffice.org (Nathan Bahn)


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 06-23-2010, 01:49 PM
Markus Schönhaber
 
Default Trying to Update Firefox 3.6.3 on 09.10

23.06.2010 15:05, Nathan Bahn:

> So I get a message saying that FF cannot update -- or words to that effect
> -- because it does not have the permissions required to access the root
> directory.

What did you do to install FF in the first place?
Look at this
https://help.ubuntu.com/community/FirefoxNewVersion
for a (probably) better way to get a current FF.

> After doing some looking around, I conclude that I need to set
> up an administrative account.

There already is what one could call an "administrative account": the
user with ID 0, aka "root".
On Ubuntu, by default, you cannot log in as root using password-based
authentication, though. But that doesn't mean that there is no root
account or that it's somehow inactive.
https://help.ubuntu.com/community/RootSudo

What exactly did you do to set up this "administrative account"?

> I do so; however, I still get a message
> stating that FF doesn't have the necessary permissions *even though I
> AM IN*the new just-created administrative account. So what's going
> on? Why won't
> FF3.6.3 update from an administrative account in 09.10?

I see the following alternatives:
- Check out the document I pointed you to in the first part of my answer.
- Get Firefox 3.5.4 from where you got 3.5.3 and do the same you did to
install the latter (removing 3.5.3 first).
- Start FF by using gksudo (or equivalent) and try if the integrated
update mechanism works.

--
Regards
mks

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 06-23-2010, 03:39 PM
Detlef Lechner
 
Default Trying to Update Firefox 3.6.3 on 09.10

On Wed, 2010-06-23 at 09:05 -0400, Nathan Bahn wrote:

> Why won't FF3.6.3 update from an administrative account in 09.10?

Firefox 3.6.3 is the current version provided by Ubuntu repositories.

Detlef
--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 06-23-2010, 10:18 PM
NoOp
 
Default Trying to Update Firefox 3.6.3 on 09.10

On 06/23/2010 06:05 AM, Nathan Bahn wrote:
> Hello everyone--
>
> So I get a message saying that FF cannot update -- or words to that effect
> -- because it does not have the permissions required to access the root
> directory. After doing some looking around, I conclude that I need to set
> up an administrative account. I do so; however, I still get a message
> stating that FF doesn't have the necessary permissions *even though I
> AM IN*the new just-created administrative account. So what's going
> on? Why won't
> FF3.6.3 update from an administrative account in 09.10?
>
> --N.B.

What version of FF do you have installed now?

Please provide the output of:

$ locate firefox-bin



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 06-24-2010, 04:54 PM
Markus Schönhaber
 
Default Trying to Update Firefox 3.6.3 on 09.10

23.06.2010 17:39, Detlef Lechner:

> On Wed, 2010-06-23 at 09:05 -0400, Nathan Bahn wrote:
>
>> Why won't FF3.6.3 update from an administrative account in 09.10?
>
> Firefox 3.6.3 is the current version provided by Ubuntu repositories.

The OP says he uses Karmic. The latest version in the Karmic
repositories is 3.5.9.
My WAG is: the OP has downloaded FF binaries from a third party source
(maybe Mozilla).

--
Regards
mks

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 05:46 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org