FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 06-20-2010, 10:19 AM
baldyeti
 
Default Windows have no controls or title bar after upgrade from 9.10 to 10.04

This sounds like the problem I had under the same upgrade path.
Someone on the ubuntu support forum correctly suggested I was
missing the "gnome-compiz" package; I hope it'll work for you,
too...

On 20/06/2010 06:34, R. A. Bilonick wrote:
> I tested 10.04 using the livecd before upgrading to 10.04 from 9.10. The
> windows looked fine in the live cd. You had borders around the windows
> with controls in the upper left for closing and resizing the windows.
> You had a title bar that you could grab to move the window, etc.
>
> After upgrading to 10.04, the default windows are defective. No controls
> and no title bar. Plus, the cpu usage now runs at 62% all the time even
> when not running any applications.
>
> If I change the appearance (system|preferences|appearance) and change
> "Visual Effects" from "none" to "normal", I get window controls and
> title bar, but they are not "embellished" as they should be for 10.04.
>
> Clearly, the gnome window manager or some such software did not upgrade
> correctly. How can I fix this? I installed LXDE and the system runs
> normally using LXDE (no 62% cpu usage and the window controls etc. are
> what you would expect). I've tried re-installing various gnome
> components without any improvement.
>
>
>


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 06-21-2010, 12:59 AM
"R. A. Bilonick"
 
Default Windows have no controls or title bar after upgrade from 9.10 to 10.04

On Sun, 2010-06-20 at 20:56 +0100, Tony Pursell wrote:
> On Sun, 2010-06-20 at 13:42 -0400, R. A. Bilonick wrote:
> > On Sun, 2010-06-20 at 12:18 -0500, Cybe R. Wizard wrote:
> > > On Sun, 20 Jun 2010 11:50:45 -0400
> > > "R. A. Bilonick" <rab@consolidated.net> wrote:
> > >
> > > > Re-installing compiz-gnome had no effect - the bit mapped buttons do
> > > > not display.
> > >
> > > Do you have a window decorator installed? I use Emerald, although I
> > > understand it is on its way out. The GTK decorator is good enough.
> > > Control it through the Compiz Fusion icon (install it, too)>right
> > > click.
> > >
> > > Cybe R. Wizard
> > > --
> > > When Windows are opened the bugs come in.
> > > Winduhs
> > >
> >
> > I think it is trying to use the gtk decorator. I installed emerald and
> > the fusion thing, but do not understand how to access it - I don't see
> > it any where.
> >
> > I tried running 10.04 from the livecd before upgrading. Everything
> > worked fine, the window decorations showed up. So I'm not sure what the
> > problem is.
> >
>
> This is all related to this bug
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/467668
>
> and the bugs shown as duplicates of it.
>
> However the effect seems to be different for different people. I cured
> the lack of window 'decoration' by simply re-naming ~/.compiz to
> ~/.compiz.old and ~/.config/gnome.session to ~/.config/gnome.session.old
> and restarting. But I don't use compiz at all and I know this is not a
> fix for everyone with this problem.
>
> Like you I did not have any problems with a live USB. After upgrade, I
> couldn't boot at all, so I did a re-install of Lucid keeping my home
> folder.
>
> Tony
>
>
Thanks for the info. First, I created a new user account and then logged
into it. The window controls in the new account have the decorations. So
I logged back into my main account and renamed as you suggested. I
logged out and then back in but still no decoration. The files (or
directories) were not re-created. I'm going to try re-booting.





--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 06-21-2010, 09:59 AM
"Cybe R. Wizard"
 
Default Windows have no controls or title bar after upgrade from 9.10 to 10.04

On Sun, 20 Jun 2010 13:42:04 -0400
"R. A. Bilonick" <rab@consolidated.net> wrote:

> I think it is trying to use the gtk decorator. I installed emerald and
> the fusion thing, but do not understand how to access it - I don't see
> it any where.

Menu>System Tools>Compiz Fusion Icon. It will show up in the menu bar
as a blue box with an arrow up and right.
Right click on the icon for a menu. Try out the options there.

Cybe R. Wizard
--
When Windows are opened the bugs come in.
Winduhs

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 06-21-2010, 01:49 PM
"R. A. Bilonick"
 
Default Windows have no controls or title bar after upgrade from 9.10 to 10.04

On Mon, 2010-06-21 at 04:59 -0500, Cybe R. Wizard wrote:
> On Sun, 20 Jun 2010 13:42:04 -0400
> "R. A. Bilonick" <rab@consolidated.net> wrote:
>
> > I think it is trying to use the gtk decorator. I installed emerald and
> > the fusion thing, but do not understand how to access it - I don't see
> > it any where.
>
> Menu>System Tools>Compiz Fusion Icon. It will show up in the menu bar
> as a blue box with an arrow up and right.
> Right click on the icon for a menu. Try out the options there.
>
> Cybe R. Wizard
> --
> When Windows are opened the bugs come in.
> Winduhs
>
Thanks. I did find the icon. It shows it's using the gtk decorator. I
switched it to emerald and it changed the look (but I don't know what
it's supposed to look like, the title bar is reddish and the buttons are
on the right - but they look plain - a dash, a box, and an x).

Is there any way to re-install? I've tried re-installing related
packages but it made no difference. I mentioned previously that I
created a new account and when I login to that account the window
decorations look as they should for default 10.04. So it's not a
graphics chip issue (plus live cd works normally also).


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 06-21-2010, 02:07 PM
"R. A. Bilonick"
 
Default Windows have no controls or title bar after upgrade from 9.10 to 10.04

On Mon, 2010-06-21 at 09:49 -0400, R. A. Bilonick wrote:
> On Mon, 2010-06-21 at 04:59 -0500, Cybe R. Wizard wrote:
> > On Sun, 20 Jun 2010 13:42:04 -0400
> > "R. A. Bilonick" <rab@consolidated.net> wrote:
> >
> > > I think it is trying to use the gtk decorator. I installed emerald and
> > > the fusion thing, but do not understand how to access it - I don't see
> > > it any where.
> >
> > Menu>System Tools>Compiz Fusion Icon. It will show up in the menu bar
> > as a blue box with an arrow up and right.
> > Right click on the icon for a menu. Try out the options there.
> >
> > Cybe R. Wizard
> > --
> > When Windows are opened the bugs come in.
> > Winduhs
> >
> Thanks. I did find the icon. It shows it's using the gtk decorator. I
> switched it to emerald and it changed the look (but I don't know what
> it's supposed to look like, the title bar is reddish and the buttons are
> on the right - but they look plain - a dash, a box, and an x).
>
> Is there any way to re-install? I've tried re-installing related
> packages but it made no difference. I mentioned previously that I
> created a new account and when I login to that account the window
> decorations look as they should for default 10.04. So it's not a
> graphics chip issue (plus live cd works normally also).
>
>
I should also mention that the title bar and window buttons disappear if
I change compiz (Visual Effects) from "normal" to "none" - even using
emerald.


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 06-21-2010, 02:24 PM
Tony Arnold
 
Default Windows have no controls or title bar after upgrade from 9.10 to 10.04

On 21/06/10 14:49, R. A. Bilonick wrote:
> On Mon, 2010-06-21 at 04:59 -0500, Cybe R. Wizard wrote:
>> On Sun, 20 Jun 2010 13:42:04 -0400
>> "R. A. Bilonick" <rab@consolidated.net> wrote:
>>
>>> I think it is trying to use the gtk decorator. I installed emerald and
>>> the fusion thing, but do not understand how to access it - I don't see
>>> it any where.
>>
>> Menu>System Tools>Compiz Fusion Icon. It will show up in the menu bar
>> as a blue box with an arrow up and right.
>> Right click on the icon for a menu. Try out the options there.
>>
>> Cybe R. Wizard
>> --
>> When Windows are opened the bugs come in.
>> Winduhs
>>
> Thanks. I did find the icon. It shows it's using the gtk decorator. I
> switched it to emerald and it changed the look (but I don't know what
> it's supposed to look like, the title bar is reddish and the buttons are
> on the right - but they look plain - a dash, a box, and an x).
>
> Is there any way to re-install? I've tried re-installing related
> packages but it made no difference. I mentioned previously that I
> created a new account and when I login to that account the window
> decorations look as they should for default 10.04. So it's not a
> graphics chip issue (plus live cd works normally also).

I had a similar problem. I concluded there was an issues with one of the
many config files in my home directory. I spent some time removing
various config files that were related to compiz and metacity, but
without success.

I ended up creating a new user name and migrating my files and selected
config files to the new user's home directory. It was a painful process.

Regards,
Tony.
--
Tony Arnold, Tel: +44 (0) 161 275 6093
Head of IT Security, Fax: +44 (0) 705 344 3082
University of Manchester, Mob: +44 (0) 773 330 0039
Manchester M13 9PL. Email: tony.arnold@manchester.ac.uk

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 06-21-2010, 02:41 PM
"R. A. Bilonick"
 
Default Windows have no controls or title bar after upgrade from 9.10 to 10.04

On Mon, 2010-06-21 at 15:24 +0100, Tony Arnold wrote:
>
> On 21/06/10 14:49, R. A. Bilonick wrote:
> > On Mon, 2010-06-21 at 04:59 -0500, Cybe R. Wizard wrote:
> >> On Sun, 20 Jun 2010 13:42:04 -0400
> >> "R. A. Bilonick" <rab@consolidated.net> wrote:
> >>
> >>> I think it is trying to use the gtk decorator. I installed emerald and
> >>> the fusion thing, but do not understand how to access it - I don't see
> >>> it any where.
> >>
> >> Menu>System Tools>Compiz Fusion Icon. It will show up in the menu bar
> >> as a blue box with an arrow up and right.
> >> Right click on the icon for a menu. Try out the options there.
> >>
> >> Cybe R. Wizard
> >> --
> >> When Windows are opened the bugs come in.
> >> Winduhs
> >>
> > Thanks. I did find the icon. It shows it's using the gtk decorator. I
> > switched it to emerald and it changed the look (but I don't know what
> > it's supposed to look like, the title bar is reddish and the buttons are
> > on the right - but they look plain - a dash, a box, and an x).
> >
> > Is there any way to re-install? I've tried re-installing related
> > packages but it made no difference. I mentioned previously that I
> > created a new account and when I login to that account the window
> > decorations look as they should for default 10.04. So it's not a
> > graphics chip issue (plus live cd works normally also).
>
> I had a similar problem. I concluded there was an issues with one of the
> many config files in my home directory. I spent some time removing
> various config files that were related to compiz and metacity, but
> without success.
>
> I ended up creating a new user name and migrating my files and selected
> config files to the new user's home directory. It was a painful process.
>
> Regards,
> Tony.
> --
> Tony Arnold, Tel: +44 (0) 161 275 6093
> Head of IT Security, Fax: +44 (0) 705 344 3082
> University of Manchester, Mob: +44 (0) 773 330 0039
> Manchester M13 9PL. Email: tony.arnold@manchester.ac.uk
>
Thanks. I was beginning to suspect I would have to move everything to a
new account.


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 06-21-2010, 09:52 PM
Tony Pursell
 
Default Windows have no controls or title bar after upgrade from 9.10 to 10.04

On Sun, 2010-06-20 at 20:59 -0400, R. A. Bilonick wrote:
> On Sun, 2010-06-20 at 20:56 +0100, Tony Pursell wrote:
> > On Sun, 2010-06-20 at 13:42 -0400, R. A. Bilonick wrote:
> > > On Sun, 2010-06-20 at 12:18 -0500, Cybe R. Wizard wrote:
> > > > On Sun, 20 Jun 2010 11:50:45 -0400
> > > > "R. A. Bilonick" <rab@consolidated.net> wrote:
> > > >
> > > > > Re-installing compiz-gnome had no effect - the bit mapped buttons do
> > > > > not display.
> > > >
> > > > Do you have a window decorator installed? I use Emerald, although I
> > > > understand it is on its way out. The GTK decorator is good enough.
> > > > Control it through the Compiz Fusion icon (install it, too)>right
> > > > click.
> > > >
> > > > Cybe R. Wizard
> > > > --
> > > > When Windows are opened the bugs come in.
> > > > Winduhs
> > > >
> > >
> > > I think it is trying to use the gtk decorator. I installed emerald and
> > > the fusion thing, but do not understand how to access it - I don't see
> > > it any where.
> > >
> > > I tried running 10.04 from the livecd before upgrading. Everything
> > > worked fine, the window decorations showed up. So I'm not sure what the
> > > problem is.
> > >
> >
> > This is all related to this bug
> >
> > https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/467668
> >
> > and the bugs shown as duplicates of it.
> >
> > However the effect seems to be different for different people. I cured
> > the lack of window 'decoration' by simply re-naming ~/.compiz to
> > ~/.compiz.old and ~/.config/gnome.session to ~/.config/gnome.session.old
> > and restarting. But I don't use compiz at all and I know this is not a
> > fix for everyone with this problem.
> >
> > Like you I did not have any problems with a live USB. After upgrade, I
> > couldn't boot at all, so I did a re-install of Lucid keeping my home
> > folder.
> >
> > Tony
> >
> >
> Thanks for the info. First, I created a new user account and then logged
> into it. The window controls in the new account have the decorations. So
> I logged back into my main account and renamed as you suggested. I
> logged out and then back in but still no decoration. The files (or
> directories) were not re-created. I'm going to try re-booting.
>

I'm not surprised that it did nothing to help you. Re-booting may do
the trick. But as I said, its not a fix for everyone. What I might
suggest is you set System > Preferences > Appearance > Visual Effects
to None (ie disable compiz) and reboot. See if that keeps reverting to
Normal. This was a symptom I had that was also fixed for me by doing
those renames. If you are successful in curing to problem, do report
back on the bug. They need all the help they can get to track down what
the problem is.

Tony



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 11:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org