FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 05-09-2010, 05:31 AM
Dotan Cohen
 
Default Missing serial port

A neighbour's computer has five serial ports, one on the motherboard
and four on a PCI card. However, only four cards are showing:

# dmesg | grep tty
[ 0.000000] console [tty0] enabled
[ 0.394565] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[ 0.394877] 00:08: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[ 0.395080] 0000:03:06.0: ttyS1 at I/O 0xcf00 (irq = 20) is a 16550A
[ 0.395201] 0000:03:06.0: ttyS2 at I/O 0xce00 (irq = 20) is a 16550A
[ 0.395320] 0000:03:06.0: ttyS3 at I/O 0xcd00 (irq = 20) is a 16550A
[ 8.751992] setserial sets custom speed on ttyS1. This is deprecated.
[ 8.754670] setserial sets custom speed on ttyS3. This is deprecated.
[ 70.056749] redhot sets custom speed on ttyS3. This is deprecated.
[ 80.734705] radoga sets custom speed on ttyS1. This is deprecated.
[ 5437.884113] redhot sets custom speed on ttyS3. This is deprecated.
[ 5510.465311] redhot sets custom speed on ttyS3. This is deprecated.
[ 5662.096348] redhot sets custom speed on ttyS3. This is deprecated.
[ 5692.931148] redhot sets custom speed on ttyS3. This is deprecated.
#

The motherboard card is ttys0. All five ports work in Windows, and
replacing the PCI card with another identical, known good card showed
the same results. This is Ubuntu 10.04. Any ideas what could be wrong?

Thanks.


--
Dotan Cohen

http://bido.com
http://what-is-what.com

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-09-2010, 11:56 AM
Karl Larsen
 
Default Missing serial port

On 05/08/2010 11:31 PM, Dotan Cohen wrote:
> A neighbour's computer has five serial ports, one on the motherboard
> and four on a PCI card. However, only four cards are showing:
>
> # dmesg | grep tty
> [ 0.000000] console [tty0] enabled
> [ 0.394565] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
> [ 0.394877] 00:08: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
> [ 0.395080] 0000:03:06.0: ttyS1 at I/O 0xcf00 (irq = 20) is a 16550A
> [ 0.395201] 0000:03:06.0: ttyS2 at I/O 0xce00 (irq = 20) is a 16550A
> [ 0.395320] 0000:03:06.0: ttyS3 at I/O 0xcd00 (irq = 20) is a 16550A
> [ 8.751992] setserial sets custom speed on ttyS1. This is deprecated.
> [ 8.754670] setserial sets custom speed on ttyS3. This is deprecated.
> [ 70.056749] redhot sets custom speed on ttyS3. This is deprecated.
> [ 80.734705] radoga sets custom speed on ttyS1. This is deprecated.
> [ 5437.884113] redhot sets custom speed on ttyS3. This is deprecated.
> [ 5510.465311] redhot sets custom speed on ttyS3. This is deprecated.
> [ 5662.096348] redhot sets custom speed on ttyS3. This is deprecated.
> [ 5692.931148] redhot sets custom speed on ttyS3. This is deprecated.
> #
>
> The motherboard card is ttys0. All five ports work in Windows, and
> replacing the PCI card with another identical, known good card showed
> the same results. This is Ubuntu 10.04. Any ideas what could be wrong?
>
> Thanks.
>
>
>
10.04 is still buggy. It should get better in 2 months of upgrades.

73 Karl


--

Karl F. Larsen, AKA K5DI
Linux User
#450462 http://counter.li.org.
Key ID = 3951B48D



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-09-2010, 12:56 PM
Dotan Cohen
 
Default Missing serial port

> * * * * 10.04 is still buggy.

In regards to serial ports? Can you provide a link?


> It should get better in 2 months of upgrades.
>

What happens in two month? Can you provide more information?

--
Dotan Cohen

http://bido.com
http://what-is-what.com

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-09-2010, 04:31 PM
Karl Larsen
 
Default Missing serial port

On 05/09/2010 06:56 AM, Dotan Cohen wrote:
>> 10.04 is still buggy.
>>
> In regards to serial ports? Can you provide a link?
>
>
>
>> It should get better in 2 months of upgrades.
>>
>>
> What happens in two month? Can you provide more information?
>
>
Chris says when they get the many bugs fixed in 10.4 like in 2-3
months it will work as well as 8.04 does right now.

73 Karl


--

Karl F. Larsen, AKA K5DI
Linux User
#450462 http://counter.li.org.
Key ID = 3951B48D



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-09-2010, 04:35 PM
Frans Ketelaars
 
Default Missing serial port

On Sun, 09 May 2010 08:31:22 +0300, Dotan Cohen wrote:

> A neighbour's computer has five serial ports, one on the motherboard and
> four on a PCI card. However, only four cards are showing:
>
> # dmesg | grep tty
> [ 0.000000] console [tty0] enabled [ 0.394565] serial8250: ttyS0
> at I/O 0x3f8 (irq = 4) is a 16550A [ 0.394877] 00:08: ttyS0 at I/O
> 0x3f8 (irq = 4) is a 16550A [ 0.395080] 0000:03:06.0: ttyS1 at I/O
> 0xcf00 (irq = 20) is a 16550A [ 0.395201] 0000:03:06.0: ttyS2 at I/O
> 0xce00 (irq = 20) is a 16550A [ 0.395320] 0000:03:06.0: ttyS3 at I/O
> 0xcd00 (irq = 20) is a 16550A [ 8.751992] setserial sets custom speed
> on ttyS1. This is deprecated. [ 8.754670] setserial sets custom speed
> on ttyS3. This is deprecated. [ 70.056749] redhot sets custom speed on
> ttyS3. This is deprecated. [ 80.734705] radoga sets custom speed on
> ttyS1. This is deprecated. [ 5437.884113] redhot sets custom speed on
> ttyS3. This is deprecated. [ 5510.465311] redhot sets custom speed on
> ttyS3. This is deprecated. [ 5662.096348] redhot sets custom speed on
> ttyS3. This is deprecated. [ 5692.931148] redhot sets custom speed on
> ttyS3. This is deprecated. #
>
> The motherboard card is ttys0. All five ports work in Windows, and
> replacing the PCI card with another identical, known good card showed
> the same results. This is Ubuntu 10.04. Any ideas what could be wrong?
>
> Thanks.

Does http://www.linux.org/docs/ldp/howto/Serial-HOWTO-16.html#ss16.3 help?

-Frans


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-09-2010, 04:37 PM
Dotan Cohen
 
Default Missing serial port

> * * Chris says when they get the many bugs fixed in 10.4 like in 2-3
> months it will work as well as 8.04 does right now.
>

Karl, are you talking specifically about the serial ports, or are you
just polluting this thread with general Lucid-bashing? Do you know of
specific problems with serial ports in Lucid?


--
Dotan Cohen

http://bido.com
http://what-is-what.com

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-09-2010, 04:42 PM
Karl Larsen
 
Default Missing serial port

On 05/09/2010 10:37 AM, Dotan Cohen wrote:
>> Chris says when they get the many bugs fixed in 10.4 like in 2-3
>> months it will work as well as 8.04 does right now.
>>
>>
> Karl, are you talking specifically about the serial ports, or are you
> just polluting this thread with general Lucid-bashing? Do you know of
> specific problems with serial ports in Lucid?
>
>
>
Dotan, serial ports are not common anymore. Chris said things like
this will be a problem on 10.04. I have 8.04. Many of my things do not
work on 10.04 today. They ALL work right on 8.04 so is this good?

73 Karl


--

Karl F. Larsen, AKA K5DI
Linux User
#450462 http://counter.li.org.
Key ID = 3951B48D



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-09-2010, 07:41 PM
Dotan Cohen
 
Default Missing serial port

On 9 May 2010 19:35, Frans Ketelaars <ketelaars@wanadoo.nl> wrote:
> Does http://www.linux.org/docs/ldp/howto/Serial-HOWTO-16.html#ss16.3 help?
>

Thanks, Frans! That was _exactly_ what I needed. The kernel module in
Ubuntu is artificially limited to only 4 serial ports.


--
Dotan Cohen

http://bido.com
http://what-is-what.com

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 05-09-2010, 07:46 PM
Dotan Cohen
 
Default Missing serial port

> * * Dotan, serial ports are not common anymore.

Not common?!? Parallel port, maybe. But serial?


> Chris said things like
> this will be a problem on 10.04. I have 8.04. Many of my things do not
> work on 10.04 today. They ALL work right on 8.04 so is this good?
>

Karl, thank you but please don't try to help when you don't know what
you are talking about. Your advice and assistance is appreciated in
the threads that you have experience with, but when you pipe up
phrasing general statements as if they are relevant to a specific
problem you only do harm. Take no offense, but please just stay out of
threads on subjects in which you have no specific experience. I don't
need you complicating things or making me run around in circles.

--
Dotan Cohen

http://bido.com
http://what-is-what.com

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 09:19 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org