FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 12-16-2009, 08:04 PM
Christopher Lemire
 
Default The following packages have unmet dependencies:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I can't figure out how to solve this issue. I tried disabling PPA
repos by commenting them out.

chris@ubuntu:~/Desktop/imageshack-uploader$ cat /etc/apt/sources.list

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.


## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
deb http://archive.canonical.com/ubuntu jaunty partner
deb-src http://archive.canonical.com/ubuntu jaunty partner

# winehq repository

#deb http://ppa.launchpad.net/awn-testing/ubuntu jaunty main
#deb-src http://ppa.launchpad.net/awn-testing/ubuntu jaunty main

# chromium daily

#deb http://ppa.launchpad.net/timothy-redaelli/ppa/ubuntu jaunty main
#deb-src http://ppa.launchpad.net/timothy-redaelli/ppa/ubuntu jaunty main
deb http://us.archive.ubuntu.com/ubuntu/ jaunty main universe
restricted multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty main universe
restricted multiverse #Added by software-properties
deb http://us.archive.ubuntu.com/ubuntu/ jaunty-updates universe main
multiverse restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty-updates universe
main multiverse restricted
deb http://security.ubuntu.com/ubuntu/ jaunty-security universe main
multiverse restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty-security universe
main multiverse restricted
deb http://us.archive.ubuntu.com/ubuntu/ jaunty-backports universe
main multiverse restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty-backports universe
main multiverse restricted

#miro

# deb repo.offensive-security.com/dist/bt4 binary/
chris@ubuntu:~/Desktop/imageshack-uploader$ sudo apt-get update
Hit http://security.ubuntu.com jaunty-security Release.gpg
Ign http://security.ubuntu.com jaunty-security/universe Translation-en_US
Ign http://security.ubuntu.com jaunty-security/main Translation-en_US
Hit http://us.archive.ubuntu.com jaunty Release.gpg
Ign http://us.archive.ubuntu.com jaunty/main Translation-en_US
Ign http://us.archive.ubuntu.com jaunty/universe Translation-en_US
Hit http://ppa.launchpad.net jaunty Release.gpg
Ign http://ppa.launchpad.net jaunty/main Translation-en_US
Hit http://archive.canonical.com jaunty Release.gpg
Ign http://archive.canonical.com jaunty/partner Translation-en_US
Hit http://packages.medibuntu.org jaunty Release.gpg
Ign http://packages.medibuntu.org jaunty/free Translation-en_US
Ign http://packages.medibuntu.org jaunty/non-free Translation-en_US
Ign http://security.ubuntu.com jaunty-security/multiverse Translation-en_US
Ign http://security.ubuntu.com jaunty-security/restricted Translation-en_US
Ign http://us.archive.ubuntu.com jaunty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com jaunty/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com jaunty-updates Release.gpg
Ign http://us.archive.ubuntu.com jaunty-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com jaunty-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com jaunty-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com jaunty-updates/restricted Translation-en_US
Hit http://us.archive.ubuntu.com jaunty-security Release.gpg
Hit http://archive.canonical.com jaunty Release
Hit http://security.ubuntu.com jaunty-security Release
Hit http://ppa.launchpad.net jaunty Release
Hit http://us.archive.ubuntu.com jaunty-backports Release.gpg
Hit http://packages.medibuntu.org jaunty Release
Ign http://us.archive.ubuntu.com jaunty-backports/universe Translation-en_US
Ign http://us.archive.ubuntu.com jaunty-backports/main Translation-en_US
Ign http://us.archive.ubuntu.com jaunty-backports/multiverse Translation-en_US
Hit http://archive.canonical.com jaunty/partner Packages
Ign http://us.archive.ubuntu.com jaunty-backports/restricted Translation-en_US
Hit http://security.ubuntu.com jaunty-security/universe Packages
Hit http://ppa.launchpad.net jaunty/main Packages
Hit http://us.archive.ubuntu.com jaunty Release
Hit http://us.archive.ubuntu.com jaunty-updates Release
Hit http://packages.medibuntu.org jaunty/free Packages
Hit http://us.archive.ubuntu.com jaunty-security Release
Hit http://us.archive.ubuntu.com jaunty-backports Release
Hit http://archive.canonical.com jaunty/partner Sources
Hit http://security.ubuntu.com jaunty-security/main Packages
Hit http://security.ubuntu.com jaunty-security/multiverse Packages
Hit http://security.ubuntu.com jaunty-security/restricted Packages
Hit http://packages.medibuntu.org jaunty/non-free Packages
Hit http://packages.medibuntu.org jaunty/free Sources
Hit http://packages.medibuntu.org jaunty/non-free Sources
Hit http://us.archive.ubuntu.com jaunty/main Packages
Hit http://us.archive.ubuntu.com jaunty/universe Packages
Hit http://us.archive.ubuntu.com jaunty/restricted Packages
Hit http://us.archive.ubuntu.com jaunty/multiverse Packages
Hit http://us.archive.ubuntu.com jaunty/main Sources
Hit http://us.archive.ubuntu.com jaunty/universe Sources
Hit http://us.archive.ubuntu.com jaunty/restricted Sources
Hit http://us.archive.ubuntu.com jaunty/multiverse Sources
Hit http://us.archive.ubuntu.com jaunty-updates/universe Packages
Hit http://us.archive.ubuntu.com jaunty-updates/main Packages
Hit http://us.archive.ubuntu.com jaunty-updates/multiverse Packages
Hit http://us.archive.ubuntu.com jaunty-updates/restricted Packages
Hit http://us.archive.ubuntu.com jaunty-updates/universe Sources
Hit http://us.archive.ubuntu.com jaunty-updates/main Sources
Hit http://us.archive.ubuntu.com jaunty-updates/multiverse Sources
Hit http://us.archive.ubuntu.com jaunty-updates/restricted Sources
Hit http://us.archive.ubuntu.com jaunty-security/universe Sources
Hit http://us.archive.ubuntu.com jaunty-security/main Sources
Hit http://us.archive.ubuntu.com jaunty-security/multiverse Sources
Hit http://us.archive.ubuntu.com jaunty-security/restricted Sources
Hit http://us.archive.ubuntu.com jaunty-backports/universe Packages
Hit http://us.archive.ubuntu.com jaunty-backports/main Packages
Hit http://us.archive.ubuntu.com jaunty-backports/multiverse Packages
Hit http://us.archive.ubuntu.com jaunty-backports/restricted Packages
Hit http://us.archive.ubuntu.com jaunty-backports/universe Sources
Hit http://us.archive.ubuntu.com jaunty-backports/main Sources
Hit http://us.archive.ubuntu.com jaunty-backports/multiverse Sources
Hit http://us.archive.ubuntu.com jaunty-backports/restricted Sources
Reading package lists... Done
chris@ubuntu:~/Desktop/imageshack-uploader$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
chris@ubuntu:~/Desktop/imageshack-uploader$ sudo apt-get install
libqt4-gui libqt4-core libqt4-xml
Reading package lists... Done
Building dependency tree
Reading state information... Done
libqt4-core is already the newest version.
libqt4-core set to manually installed.
libqt4-xml is already the newest version.
libqt4-xml set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libqt4-gui: Depends: libqtgui4 (= 4.5.0-0ubuntu4.3) but
4.5.2-0ubuntu2~jaunty1~ppa2 is to be installed
Depends: libqt4-svg (= 4.5.0-0ubuntu4.3) but
4.5.2-0ubuntu2~jaunty1~ppa2 is to be installed
Depends: libqt4-opengl (= 4.5.0-0ubuntu4.3) but
4.5.2-0ubuntu2~jaunty1~ppa2 is to be installed
Depends: libqt4-designer (= 4.5.0-0ubuntu4.3) but
4.5.2-0ubuntu2~jaunty1~ppa2 is to be installed
Depends: libqt4-assistant (= 4.5.0-0ubuntu4.3) but
4.5.2-0ubuntu2~jaunty1~ppa2 is to be installed
E: Broken packages
chris@ubuntu:~/Desktop/imageshack-uploader$


- --
Christopher Lemire
Ubuntu 64 bit Linux Raid Level 0

GnuPG Security Key fingerprint = 3E1A 9103 EF3D 4885 6866 E9DE C69F
18B3 E13B 0909

Need Tech Support and Stay on Top of Linux Technology? Visit my Blog.

http://linuxinnovations.blogspot.com/


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Use GnuPG with Firefox : http://getfiregpg.org (Version: 0.7.10)

iEYEARECAAYFAkspS4sACgkQxp8Ys+E7CQm+3gCfTT8pOvHgiC P8nw6t93JhVOPR
P70An3mlmP6TtfiHZl+KWgqyO1/620jB
=77s1
-----END PGP SIGNATURE-----

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-16-2009, 09:42 PM
Tom H
 
Default The following packages have unmet dependencies:

> I can't figure out how to solve this issue. I tried disabling PPA
> repos by commenting them out.

> chris@ubuntu:~/Desktop/imageshack-uploader$ cat /etc/apt/sources.list
> deb http://archive.canonical.com/ubuntu jaunty partner
> deb-src http://archive.canonical.com/ubuntu jaunty partner
> # winehq repository
> #deb http://ppa.launchpad.net/awn-testing/ubuntu jaunty main
> #deb-src http://ppa.launchpad.net/awn-testing/ubuntu jaunty main
> # chromium daily
> #deb http://ppa.launchpad.net/timothy-redaelli/ppa/ubuntu jaunty main
> #deb-src http://ppa.launchpad.net/timothy-redaelli/ppa/ubuntu jaunty main
> deb http://us.archive.ubuntu.com/ubuntu/ jaunty main universe
> restricted multiverse
> deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty main universe
> restricted multiverse #Added by software-properties
> deb http://us.archive.ubuntu.com/ubuntu/ jaunty-updates universe main
> multiverse restricted
> deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty-updates universe
> main multiverse restricted
> deb http://security.ubuntu.com/ubuntu/ jaunty-security universe main
> multiverse restricted
> deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty-security universe
> main multiverse restricted
> deb http://us.archive.ubuntu.com/ubuntu/ jaunty-backports universe
> main multiverse restricted
> deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty-backports universe
> main multiverse restricted
> #miro
> # deb repo.offensive-security.com/dist/bt4 binary/

> chris@ubuntu:~/Desktop/imageshack-uploader$ sudo apt-get update

> chris@ubuntu:~/Desktop/imageshack-uploader$ sudo apt-get install -f

> chris@ubuntu:~/Desktop/imageshack-uploader$ sudo apt-get install
> libqt4-gui libqt4-core libqt4-xml

> libqt4-core is already the newest version.
> libqt4-core set to manually installed.
> libqt4-xml is already the newest version.
> libqt4-xml set to manually installed.
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
> *libqt4-gui: Depends: libqtgui4 (= 4.5.0-0ubuntu4.3) but
> 4.5.2-0ubuntu2~jaunty1~ppa2 is to be installed
> * * * * * * *Depends: libqt4-svg (= 4.5.0-0ubuntu4.3) but
> 4.5.2-0ubuntu2~jaunty1~ppa2 is to be installed
> * * * * * * *Depends: libqt4-opengl (= 4.5.0-0ubuntu4.3) but
> 4.5.2-0ubuntu2~jaunty1~ppa2 is to be installed
> * * * * * * *Depends: libqt4-designer (= 4.5.0-0ubuntu4.3) but
> 4.5.2-0ubuntu2~jaunty1~ppa2 is to be installed
> * * * * * * *Depends: libqt4-assistant (= 4.5.0-0ubuntu4.3) but
> 4.5.2-0ubuntu2~jaunty1~ppa2 is to be installed
> E: Broken packages

(1) Your "sources.list" consists of the following:
deb http://archive.canonical.com/ubuntu jaunty partner
deb http://us.archive.ubuntu.com/ubuntu/ jaunty main universe
restricted multiverse
deb http://us.archive.ubuntu.com/ubuntu/ jaunty-updates main universe
restricted multiverse
deb http://security.ubuntu.com/ubuntu/ jaunty-security main universe
restricted multiverse
deb http://us.archive.ubuntu.com/ubuntu/ jaunty-backports main
universe restricted multiverse

And yet you have the following repositories being queried when you
"apt-get update":
Hit http://ppa.launchpad.net jaunty Release.gpg
Ign http://ppa.launchpad.net jaunty/main Translation-en_US
Hit http://packages.medibuntu.org jaunty Release.gpg
Ign http://packages.medibuntu.org jaunty/free Translation-en_US
Ign http://packages.medibuntu.org jaunty/non-free Translation-en_US
Hit http://ppa.launchpad.net jaunty Release
Hit http://packages.medibuntu.org jaunty Release
Hit http://ppa.launchpad.net jaunty/main Packages
Hit http://packages.medibuntu.org jaunty/free Packages
Hit http://packages.medibuntu.org jaunty/non-free Packages
Hit http://packages.medibuntu.org jaunty/free Sources
Hit http://packages.medibuntu.org jaunty/non-free Sources

Do you have any files in "/etc/apt/sources.list.d"? I have never used
this directory but it would explain (to me anyway) why "medibuntu.org"
and "launchpad.net" are appearing in the "apt-get update" output given
your "sources.list".

(2) If you "apt-get install libqt4-core libqt4-xml" and "libqt4-core"
and "libqt4-xml" have already been automatically installed, they will
be set to having been manually installed.

(3) "libqt4-gui" is a dummy package and it may not exist in the ppa
from which you installed "libqtgui4", etc, so apt-get is complaining
about your more recent libqt... versions.

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 06:28 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org