FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 11-13-2009, 11:43 AM
Robert Spanjaard
 
Default Newspost fails to build on 9.10 - Solution

I suppose Ubuntu has quite a lot of newspost-users, because the
repositories don't have any alternatives (AFAIK). This is the bugreport
that I sent to the author of this great little program, Jim Faulkner:

---8<------8<------8<------8<------8<------8<------8<------8<---
Newspost fails to install on new distros, like my Ubuntu 9.10.
The error message I get after typing "make" is "error: conflicting types
for 'getline'". After a bit of Googling (I'm not a programmer myself) I
found this explanation in a newsgroup:

http://groups.google.com/group/linux.debian.bugs.dist/msg/4b23088fe713bc63

This means that you need to rename "getline" to "get_line" at the
following locations:

base/newspost.c, line 345
base/utils.c, line 46
base/utils.h, line 29
ui/options.c, line 335 and 432

Just tried it myself, and newspost compiles again like it should.
---8<------8<------8<------8<------8<------8<------8<------8<---

It's a small fix, so if you're afraid to change sourcefiles, I expect the
author to release a fixed version soon.

--
Regards, Robert http://www.arumes.com


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 10:09 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org