FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 10-29-2009, 12:08 PM
Richard Ibbotson
 
Default X-server Bug - Severe

Hello there

For the past week or so I've been testing the 9.10 beta and upgrading
from 9.04 as the new updates came along. Throughout all of this I
have the same bug which is not going away. The Nvidia driver will not
start up. I am booting into a black screen on my desktop and not KDE
or Gnome. If I hack /etc/X11/xorg.conf and remove the "nvidia" part
of it and replace it with "nv" my desktop will start up without any
problems.

How do I fix this so that I can do a normal boot into my desktop login
screen ? Xorg log startup file is below....



X.Org X Server 1.6.4
Release Date: 2009-9-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server x86_64 Ubuntu
Current Operating System: Linux 2.6.31-14-generic #48-Ubuntu SMP Fri
Oct 16 14:05:01 UTC 2009 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic
root=UUID=096cec78-4c9d-4c35-802f-f0cf3616815f ro quiet splash
Build Date: 26 October 2009 05:19:56PM
xorg-server 2:1.6.4-2ubuntu4 (buildd@)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Oct 29 12:26:44 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) No Layout section. Using the first Screen section.
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Configured Monitor"
(**) | |-->Device "Configured Video Device"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable
AllowEmptyInput.
(II) Loader magic: 0xb40
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0:1:0:0) 10de:016a:10b0:0401 nVidia Corporation NV44
[GeForce 7100 GS] rev 161, Mem @ 0xfa000000/16777216,
0xc0000000/536870912, 0xfb000000/16777216, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[16] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[17] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[18] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[19] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[24] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[25] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[26] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[27] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[28] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[29] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded. This was enabled by default and also
specified in the config file.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 185.18.36 Fri Aug 14 18:27:24 PDT 2009
(II) Loading extension GLX
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver 185.18.36 Fri Aug 14 17:51:02 PDT 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[16] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[17] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[18] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[19] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[24] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[25] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[26] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[27] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[28] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[29] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
(II) NVIDIA(0): Creating default Display subsection in Screen section
"Default Screen" for depth/fbbpp 24/32
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X
extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 7100 GS (NV44) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 05.44.02.33.00
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 7100 GS at
PCI:1:0:0:
(--) NVIDIA(0): Samsung SyncMaster (CRT-0)
(--) NVIDIA(0): Samsung SyncMaster (CRT-0): 400.0 MHz maximum pixel
clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(==) NVIDIA(0):
(==) NVIDIA(0): No modes were requested; the default mode "nvidia-
auto-select"
(==) NVIDIA(0): will be used as the requested mode.
(==) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
(--) NVIDIA(0): DPI set to (96, 88); computed from "UseEdidDpi" X
config
(--) NVIDIA(0): option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[16] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[17] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[18] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[19] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[24] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[25] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[26] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[27] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[28] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[29] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
ddxSigGiveUp: Closing log


--
Richard
www.sheflug.org.uk

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-29-2009, 12:56 PM
Chan Chung Hang Christopher
 
Default X-server Bug - Severe

Maybe the gdm.log for gdm can give us a bit more information.

Richard Ibbotson wrote:
> Hello there
>
> For the past week or so I've been testing the 9.10 beta and upgrading
> from 9.04 as the new updates came along. Throughout all of this I
> have the same bug which is not going away. The Nvidia driver will not
> start up. I am booting into a black screen on my desktop and not KDE
> or Gnome. If I hack /etc/X11/xorg.conf and remove the "nvidia" part
> of it and replace it with "nv" my desktop will start up without any
> problems.
>
> How do I fix this so that I can do a normal boot into my desktop login
> screen ? Xorg log startup file is below....
>
>
>
> X.Org X Server 1.6.4
> Release Date: 2009-9-27
> X Protocol Version 11, Revision 0
> Build Operating System: Linux 2.6.24-23-server x86_64 Ubuntu
> Current Operating System: Linux 2.6.31-14-generic #48-Ubuntu SMP Fri
> Oct 16 14:05:01 UTC 2009 x86_64
> Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic
> root=UUID=096cec78-4c9d-4c35-802f-f0cf3616815f ro quiet splash
> Build Date: 26 October 2009 05:19:56PM
> xorg-server 2:1.6.4-2ubuntu4 (buildd@)
> Before reporting problems, check http://wiki.x.org
> to make sure that you have the latest version.
> Markers: (--) probed, (**) from config file, (==) default setting,
> (++) from command line, (!!) notice, (II) informational,
> (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> (==) Log file: "/var/log/Xorg.0.log", Time: Thu Oct 29 12:26:44 2009
> (==) Using config file: "/etc/X11/xorg.conf"
> (==) No Layout section. Using the first Screen section.
> (**) |-->Screen "Default Screen" (0)
> (**) | |-->Monitor "Configured Monitor"
> (**) | |-->Device "Configured Video Device"
> (==) Automatically adding devices
> (==) Automatically enabling devices
> (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
> Entry deleted from font path.
> (==) FontPath set to:
> /usr/share/fonts/X11/misc,
> /usr/share/fonts/X11/100dpi/:unscaled,
> /usr/share/fonts/X11/75dpi/:unscaled,
> /usr/share/fonts/X11/Type1,
> /usr/share/fonts/X11/100dpi,
> /usr/share/fonts/X11/75dpi,
> /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
> built-ins
> (==) ModulePath set to "/usr/lib/xorg/modules"
> (II) Cannot locate a core pointer device.
> (II) Cannot locate a core keyboard device.
> (II) The server relies on HAL to provide the list of input devices.
> If no devices become available, reconfigure HAL or disable
> AllowEmptyInput.
> (II) Loader magic: 0xb40
> (II) Module ABI versions:
> X.Org ANSI C Emulation: 0.4
> X.Org Video Driver: 5.0
> X.Org XInput driver : 4.0
> X.Org Server Extension : 2.0
> (II) Loader running on linux
> (++) using VT number 7
>
> (--) PCI:*(0:1:0:0) 10de:016a:10b0:0401 nVidia Corporation NV44
> [GeForce 7100 GS] rev 161, Mem @ 0xfa000000/16777216,
> 0xc0000000/536870912, 0xfb000000/16777216, BIOS @ 0x????????/131072
> (II) Open ACPI successful (/var/run/acpid.socket)
> (II) System resource ranges:
> [0] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [4] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [8] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [12] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [16] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [17] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [18] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [19] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [21] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [23] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [24] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [25] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [26] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [27] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [28] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [29] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> (II) "extmod" will be loaded by default.
> (II) "dbe" will be loaded by default.
> (II) "glx" will be loaded. This was enabled by default and also
> specified in the config file.
> (II) "record" will be loaded by default.
> (II) "dri" will be loaded by default.
> (II) "dri2" will be loaded by default.
> (II) LoadModule: "glx"
> (II) Loading /usr/lib/xorg/modules/extensions//libglx.so
> (II) Module glx: vendor="NVIDIA Corporation"
> compiled for 4.0.2, module version = 1.0.0
> Module class: X.Org Server Extension
> (II) NVIDIA GLX Module 185.18.36 Fri Aug 14 18:27:24 PDT 2009
> (II) Loading extension GLX
> (II) LoadModule: "extmod"
> (II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
> (II) Module extmod: vendor="X.Org Foundation"
> compiled for 1.6.4, module version = 1.0.0
> Module class: X.Org Server Extension
> ABI class: X.Org Server Extension, version 2.0
> (II) Loading extension MIT-SCREEN-SAVER
> (II) Loading extension XFree86-VidModeExtension
> (II) Loading extension XFree86-DGA
> (II) Loading extension DPMS
> (II) Loading extension XVideo
> (II) Loading extension XVideo-MotionCompensation
> (II) Loading extension X-Resource
> (II) LoadModule: "dbe"
> (II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
> (II) Module dbe: vendor="X.Org Foundation"
> compiled for 1.6.4, module version = 1.0.0
> Module class: X.Org Server Extension
> ABI class: X.Org Server Extension, version 2.0
> (II) Loading extension DOUBLE-BUFFER
> (II) LoadModule: "record"
> (II) Loading /usr/lib/xorg/modules/extensions//librecord.so
> (II) Module record: vendor="X.Org Foundation"
> compiled for 1.6.4, module version = 1.13.0
> Module class: X.Org Server Extension
> ABI class: X.Org Server Extension, version 2.0
> (II) Loading extension RECORD
> (II) LoadModule: "dri"
> (II) Loading /usr/lib/xorg/modules/extensions//libdri.so
> (II) Module dri: vendor="X.Org Foundation"
> compiled for 1.6.4, module version = 1.0.0
> ABI class: X.Org Server Extension, version 2.0
> (II) Loading extension XFree86-DRI
> (II) LoadModule: "dri2"
> (II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
> (II) Module dri2: vendor="X.Org Foundation"
> compiled for 1.6.4, module version = 1.1.0
> ABI class: X.Org Server Extension, version 2.0
> (II) Loading extension DRI2
> (II) LoadModule: "nvidia"
> (II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
> (II) Module nvidia: vendor="NVIDIA Corporation"
> compiled for 4.0.2, module version = 1.0.0
> Module class: X.Org Video Driver
> (II) NVIDIA dlloader X Driver 185.18.36 Fri Aug 14 17:51:02 PDT 2009
> (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
> (II) Primary Device is: PCI 01@00:00:0
> (II) Loading sub module "fb"
> (II) LoadModule: "fb"
> (II) Loading /usr/lib/xorg/modules//libfb.so
> (II) Module fb: vendor="X.Org Foundation"
> compiled for 1.6.4, module version = 1.0.0
> ABI class: X.Org ANSI C Emulation, version 0.4
> (II) Loading sub module "wfb"
> (II) LoadModule: "wfb"
> (II) Loading /usr/lib/xorg/modules//libwfb.so
> (II) Module wfb: vendor="X.Org Foundation"
> compiled for 1.6.4, module version = 1.0.0
> ABI class: X.Org ANSI C Emulation, version 0.4
> (II) Loading sub module "ramdac"
> (II) LoadModule: "ramdac"
> (II) Module "ramdac" already built-in
> (II) resource ranges after probing:
> [0] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [4] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [8] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [12] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [16] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [17] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [18] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [19] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [21] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [23] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [24] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [25] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [26] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [27] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [28] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [29] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> (II) NVIDIA(0): Creating default Display subsection in Screen section
> "Default Screen" for depth/fbbpp 24/32
> (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
> (==) NVIDIA(0): RGB weight 888
> (==) NVIDIA(0): Default visual is TrueColor
> (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
> (**) NVIDIA(0): Option "NoLogo" "True"
> (**) NVIDIA(0): Enabling RENDER acceleration
> (II) NVIDIA(0): Support for GLX with the Damage and Composite X
> extensions is
> (II) NVIDIA(0): enabled.
> (II) NVIDIA(0): NVIDIA GPU GeForce 7100 GS (NV44) at PCI:1:0:0 (GPU-0)
> (--) NVIDIA(0): Memory: 524288 kBytes
> (--) NVIDIA(0): VideoBIOS: 05.44.02.33.00
> (II) NVIDIA(0): Detected PCI Express Link width: 16X
> (--) NVIDIA(0): Interlaced video modes are supported on this GPU
> (--) NVIDIA(0): Connected display device(s) on GeForce 7100 GS at
> PCI:1:0:0:
> (--) NVIDIA(0): Samsung SyncMaster (CRT-0)
> (--) NVIDIA(0): Samsung SyncMaster (CRT-0): 400.0 MHz maximum pixel
> clock
> (II) NVIDIA(0): Assigned Display Device: CRT-0
> (==) NVIDIA(0):
> (==) NVIDIA(0): No modes were requested; the default mode "nvidia-
> auto-select"
> (==) NVIDIA(0): will be used as the requested mode.
> (==) NVIDIA(0):
> (II) NVIDIA(0): Validated modes:
> (II) NVIDIA(0): "nvidia-auto-select"
> (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
> (--) NVIDIA(0): DPI set to (96, 88); computed from "UseEdidDpi" X
> config
> (--) NVIDIA(0): option
> (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
> (--) Depth 24 pixmap format is 32 bpp
> (II) do I need RAC? No, I don't.
> (II) resource ranges after preInit:
> [0] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [4] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [8] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [12] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [16] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
> [17] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
> [18] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
> [19] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
> [20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [21] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [23] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [24] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [25] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [26] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [27] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> [28] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
> [29] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
> (II) NVIDIA(0): Initialized GPU GART.
> (II) NVIDIA(0): Setting mode "nvidia-auto-select"
> (II) Loading extension NV-GLX
> (II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
> (==) NVIDIA(0): Disabling shared memory pixmaps
> (II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
> (==) NVIDIA(0): Backing store disabled
> (==) NVIDIA(0): Silken mouse enabled
> (II) NVIDIA(0): DPMS enabled
> (II) Loading extension NV-CONTROL
> (II) Loading extension XINERAMA
> (==) RandR enabled
> (II) Initializing built-in extension Generic Event Extension
> (II) Initializing built-in extension SHAPE
> (II) Initializing built-in extension MIT-SHM
> (II) Initializing built-in extension XInputExtension
> (II) Initializing built-in extension XTEST
> (II) Initializing built-in extension BIG-REQUESTS
> (II) Initializing built-in extension SYNC
> (II) Initializing built-in extension XKEYBOARD
> (II) Initializing built-in extension XC-MISC
> (II) Initializing built-in extension SECURITY
> (II) Initializing built-in extension XINERAMA
> (II) Initializing built-in extension XFIXES
> (II) Initializing built-in extension RENDER
> (II) Initializing built-in extension RANDR
> (II) Initializing built-in extension COMPOSITE
> (II) Initializing built-in extension DAMAGE
> (II) Initializing extension GLX
> ddxSigGiveUp: Closing log
>
>
>


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-29-2009, 01:03 PM
Richard Ibbotson
 
Default X-server Bug - Severe

Hi

On Thursday 29 Oct 2009 13:56:22 Chan Chung Hang Christopher wrote:
> Maybe the gdm.log for gdm can give us a bit more information.

/var/log/kdm.log

X.Org X Server 1.6.4
Release Date: 2009-9-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server x86_64 Ubuntu
Current Operating System: Linux 2.6.31-14-generic #48-Ubuntu SMP Fri
Oct 16 14:05:01 UTC 2009 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic
root=UUID=096cec78-4c9d-4c35-802f-f0cf3616815f ro quiet splash
Build Date: 26 October 2009 05:19:56PM
xorg-server 2:1.6.4-2ubuntu4 (buildd@)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/var/log/Xorg.failsafe.log", Time: Thu Oct 29 12:27:18
2009
(++) Using config file: "/etc/X11/xorg.conf.failsafe"
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver
not found)
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


/var/log/gdm/:0.log

X.Org X Server 1.6.0
Release Date: 2009-2-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-15-server x86_64 Ubuntu
Current Operating System: Linux 2.6.28-12-generic #43-Ubuntu SMP Fri
May 1 19:31:32 UTC 2009 x86_64
Build Date: 09 April 2009 02:11:54AM
xorg-server 2:1.6.0-0ubuntu14 (buildd@crested.buildd)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri May 8 15:01:47 2009
(==) Using config file: "/etc/X11/xorg.conf"
ddxSigGiveUp: Closing log


--
Richard
www.sheflug.org.uk

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-29-2009, 01:06 PM
Leonard Chatagnier
 
Default X-server Bug - Severe

--- On Thu, 10/29/09, Richard Ibbotson <richard.ibbotson@gmail.com> wrote:

> From: Richard Ibbotson <richard.ibbotson@gmail.com>
> Subject: X-server Bug - Severe
> To: ubuntu-users@lists.ubuntu.com
> Date: Thursday, October 29, 2009, 8:08 AM
> Hello there
>
> For the past week or so I've been testing the 9.10 beta and
> upgrading
> from 9.04 as the new updates came along.* Throughout
> all of this I
> have the same bug which is not going away.* The Nvidia
> driver will not
> start up.* I am booting into a black screen on my
> desktop and not KDE
> or Gnome.* If I hack /etc/X11/xorg.conf and remove the
> "nvidia" part
> of it and replace it with "nv" my desktop will start up
> without any
> problems.
>
> How do I fix this so that I can do a normal boot into my
> desktop login
> screen ?* Xorg log startup file is below....
>
>
>
Well, the first thing I would have done with your X problem and before rming the nvidia-185-* driver would be to reboot in recovery mode and run "xfix" without the quotes. You may not be able to do that with Karmic as it seems that some, including me, find recovery mode broken in Karmic Beta 64 bit. It may work for you if you have 32 bit but I don't know for sure. Another thing to try if you can access the recovery mode kernel is to run the fix broken menu item with the nvidia driver installed, of course.
You may want to consider googling for "your video card model or chip+karmic+video driver" or similar and see what comes up of interest.
I'm running 64 bit Karmic beta recent nightly build with the nvidia-185 driver and X works out of the box with no issues.
Hope this gets you started on a solution, if not post back with details on what you've done.
Leonard Chatagnier
lenc5570@sbcglobal.net



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-29-2009, 01:21 PM
Chan Chung Hang Christopher
 
Default X-server Bug - Severe

Richard Ibbotson wrote:
> Hi
>
> On Thursday 29 Oct 2009 13:56:22 Chan Chung Hang Christopher wrote:
>
>> Maybe the gdm.log for gdm can give us a bit more information.
>>
>
> /var/log/kdm.log
>
>
<snip>
> (++) Log file: "/var/log/Xorg.failsafe.log", Time: Thu Oct 29 12:27:18
> 2009
> (++) Using config file: "/etc/X11/xorg.conf.failsafe"
> (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver
> not found)
> Fatal server error:
> Server is already active for display 0
> If this server is no longer running, remove /tmp/.X0-lock
> and start again.
>
>

Not sure what to make of this...

> /var/log/gdm/:0.log
>
>

I do not notice anything out of the ordinary...

Does your monitor support 1680 x 1050? Is it a CRT or a LCD monitor?



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-29-2009, 02:08 PM
Richard Ibbotson
 
Default X-server Bug - Severe

Christopher

> <snip>
>
> > (++) Log file: "/var/log/Xorg.failsafe.log", Time: Thu Oct 29
> > 12:27:18 2009
> > (++) Using config file: "/etc/X11/xorg.conf.failsafe"
> Not sure what to make of this...

Yes <scratches head>

> I do not notice anything out of the ordinary...
> Does your monitor support 1680 x 1050? Is it a CRT or a LCD
> monitor?

Yes. It's a Samsung Syncmaster 2243BW flat screen. Works fine with any
version of Linux. What's confusing me is that I can start the Gnome
desktop by logging in as a user and then by typing in "startx". This
gets me stright into a GNome 2.28 desktop without a login screen. KDM
is running. I've checked it. /etc/X11/xorg.conf below. So, I can
remove "nvidia" and put in "nv" and everything starts up fine but no 3D
drivers and no Compiz effects.

/var/log/kdm.log (EE) Failed to initialize GLX extension (Compatible
NVIDIA X driver not found)

/etc/X11/xorg.conf
Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7100 GS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1680x1050 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


--
Richard

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-29-2009, 02:26 PM
Chan Chung Hang Christopher
 
Default X-server Bug - Severe

Why do you have twinview enabled when you only have one monitor?

Can you get into GNOME with the nvidia driver using startx?

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-29-2009, 02:38 PM
Richard Ibbotson
 
Default X-server Bug - Severe

Christopher

> Why do you have twinview enabled when you only have one monitor?

Uhhmmm ?? Didn't know about that How do I turn it off ? It was
turned off. I think an upgrade must have switched it on.

> Can you get into GNOME with the nvidia driver using startx?

Yes. That works. I have now removed the 185 Nvidia driver and
installed the 173 driver and run - dpkg-reconfigure -phigh xserver-
xorg. What happens now is that the rectangular graphical error
message comes up on the screen when the Xserver starts saying that
there is an error and the desktop will not start. Offering me a low
graphics mode. If I click on cancel I am taken to a normal graphical
login screen and I am now logged into my KDE 4 desktop.

--
Richard

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 10-30-2009, 12:20 AM
Rashkae
 
Default X-server Bug - Severe

Richard Ibbotson wrote:

> /etc/X11/xorg.conf
> Section "ServerLayout"
> Identifier "Default Layout"
> Screen 0 "Screen0" 0 0
> InputDevice "Keyboard0" "CoreKeyboard"
> InputDevice "Mouse0" "CorePointer"
> EndSection
>
> Section "Module"
> Load "glx"
> EndSection
>
> Section "ServerFlags"
> Option "Xinerama" "0"
> EndSection
>
> Section "InputDevice"
> # generated from default
> Identifier "Keyboard0"
> Driver "kbd"
> EndSection
>
> Section "InputDevice"
> # generated from default
> Identifier "Mouse0"
> Driver "mouse"
> Option "Protocol" "auto"
> Option "Device" "/dev/psaux"
> Option "Emulate3Buttons" "no"
> Option "ZAxisMapping" "4 5"
> EndSection
>
> Section "Monitor"
> Identifier "Configured Monitor"
> EndSection
>
> Section "Monitor"
> Identifier "Monitor0"
> VendorName "Unknown"
> ModelName "Samsung SyncMaster"
> HorizSync 30.0 - 81.0
> VertRefresh 56.0 - 75.0
> EndSection
>
> Section "Device"
> Identifier "Configured Video Device"
> Driver "nvidia"
> Option "NoLogo" "True"
> EndSection
>
> Section "Device"
> Identifier "Device0"
> Driver "nvidia"
> VendorName "NVIDIA Corporation"
> BoardName "GeForce 7100 GS"
> EndSection
>
> Section "Screen"
> Identifier "Default Screen"
> Device "Configured Video Device"
> Monitor "Configured Monitor"
> DefaultDepth 24
> EndSection
>
> Section "Screen"
> Identifier "Screen0"
> Device "Device0"
> Monitor "Monitor0"
> DefaultDepth 24
> Option "TwinView" "0"
> Option "TwinViewXineramaInfoOrder" "CRT-0"
> Option "metamodes" "1680x1050 +0+0"
> SubSection "Display"
> Depth 24
> EndSubSection
> EndSection
>
>



I see lots of stuff in there that probably no longer belongs in modern X
config file.

Try making a backup of the xorg.conf file, then simply empty it. Or use
the grub menu to start recovery mode, and from the menu, choose the
option to fix X. Then when the system restarts, you can use the Ubuntu
hardware manager to enable the Nvidia driver. Hopefully htat will fix
your woes.


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 04:35 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org