FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 03-06-2009, 05:42 PM
NoOp
 
Default Installing Emacs gets error!

On 03/06/2009 05:34 AM, Ziffer wrote:
> Hi,
> My hardy works fine until I trying remove emacs. After doing ' sudo apt-get autoremove emacs' , I try install it again, then I get this:
>
> Byte-compiling add-on packages, please wait... failed.
>
> !! Byte-compilation for emacs22 failed!
> !! This indicates a bug in one of the add-on packages
> !! installed on your system, or a bug in Emacs itself.
> !! Please file a bug report against emacs22
> !! and attach the file /tmp/emacs22.Dc6404
>

Try purging emacs first & then reinstalling:

$ sudo apt-get purge emacs
$ sudo apt-get install emacs


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 03-07-2009, 04:01 AM
Ziffer
 
Default Installing Emacs gets error!

On* Fri, 06 Mar 2009 10:42:24, NoOp wrote:

>On 03/06/2009 05:34 AM, Ziffer wrote:
>> Hi,
>>* My hardy works fine until I trying remove emacs. After doing ' sudo apt-get autoremove emacs' , I try install it again, then I get this:
>>
> > * * * Byte-compiling add-on packages, please wait... failed.
>>
> > * * !! Byte-compilation for emacs22 failed!
> > * * !! This indicates a bug in one of the add-on packages
> > * * !! installed on your system, or a bug in Emacs itself.
> > * * !! Please file a bug report
against emacs22
> > * * !! and attach the file /tmp/emacs22.Dc6404
>>

>Try purging emacs first & then reinstalling:

>$ sudo apt-get purge emacs
>$ sudo apt-get install emacs

I tried purging emacs and got :

*** Byte-compiling add-on packages, please wait... failed.
** !! Byte-compilation for emacs22 failed!
** !! This indicates a bug in one of the add-on packages
** !! installed on your system, or a bug in Emacs itself.
** !! Please file a bug report against emacs22
** !! and attach the file /tmp/emacs22.wr6538

* Byte-compiling add-on packages, please wait... failed.

** !! Byte-compilation for emacs22 failed!
** !! This indicates a bug in one of the add-on packages
** !! installed on your system, or a bug in Emacs itself.
** !! Please
file a bug report against emacs22
** !! and attach the file /tmp/emacs22.Yh6563

I attach both /tmp/emacs22.wr6538 and /tmp/emacs22.Yh6563 here





好玩贺卡**发,邮箱贺卡全新上线 --
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 03-07-2009, 04:21 AM
Ziffer
 
Default Installing Emacs gets error!

On* Fri, 06 Mar 2009 16:46:57 Florian Diesch wrote

>Ziffer <ziffer@yahoo.cn> wrote:

> >Hi,
>>* My hardy works fine until I trying remove emacs. After doing ' sudo apt-get autoremove emacs' , I try install it again, then I get this:
>>
>>* * * * Byte-compiling add-on packages, please wait... failed.
>>
>>* * * !! Byte-compilation for emacs22 failed!
>>* * * !! This indicates a bug in one of the add-on packages
>>* * * !! installed
on your system, or a bug in Emacs itself.
>>* * * !! Please file a bug report against emacs22
>>* * * !! and attach the file /tmp/emacs22.Dc6404
>>
>>* Please help, thanks!

>Please post the file* /tmp/emacs22.Dc6404

I cannot find /tmp/emacs22.Dc6404, but I tried to install emacs again. It prompt there are error occur while dealing with emacs22-gtk, emacs22, emacs22-nox,emacs :





** Byte-compiling add-on packages, please wait... failed.

* !! Byte-compilation for emacs22 failed!
* !! This indicates a bug in one of the add-on packages
* !! installed on your system, or a bug in Emacs itself.
* !! Please file a bug report against emacs22
* !! and attach the file /tmp/emacs22.KV6999 ( While dealing with emacs22-gtk )

* ...
* ...
* !! and attach the file /tmp/emacs22.VB7024 ( While dealing with emacs22 )
* ...
* !! and attach the file /tmp/emacs22.Xv7049* ( While dealing with emacs22-nok )



I attach the files here.






好玩贺卡**发,邮箱贺卡全新上线 --
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 03-07-2009, 11:27 PM
Florian Diesch
 
Default Installing Emacs gets error!

Ziffer <ziffer@yahoo.cn> wrote:

> I tried purging emacs and got :
>
> Byte-compiling add-on packages, please wait... failed.
> !! Byte-compilation for emacs22 failed!
> !! This indicates a bug in one of the add-on packages
> !! installed on your system, or a bug in Emacs itself.
> !! Please file a bug report against emacs22
> !! and attach the file /tmp/emacs22.wr6538
>
> Byte-compiling add-on packages, please wait... failed.
>
> !! Byte-compilation for emacs22 failed!
> !! This indicates a bug in one of the add-on packages
> !! installed on your system, or a bug in Emacs itself.
> !! Please file a bug report against emacs22
> !! and attach the file /tmp/emacs22.Yh6563
>
> I attach both /tmp/emacs22.wr6538 and /tmp/emacs22.Yh6563 here

The file /etc/emacs/site-start.d/00debian-vars.el, which is in package
emacsen-common, seems to be missing.
Try reinstall emacsen-common



Florian
--
<http://www.florian-diesch.de/>

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 03-08-2009, 03:58 AM
Ziffer
 
Default Installing Emacs gets error!

On Sun, 08 Mar 2009 01:27:28 Florian Diesch wrote:
>Ziffer <ziffer@yahoo.cn> wrote:

>> I tried purging emacs and got :
>>
>>* * Byte-compiling add-on packages, please wait... failed.
>>* * !! Byte-compilation for emacs22 failed!
>>* * !! This indicates a bug in one of the add-on packages
>>* * !! installed on your system, or a bug in Emacs itself.
>>* * !! Please file a bug report against emacs22
>>* * !! and attach the file
/tmp/emacs22.wr6538
>>
>>* Byte-compiling add-on packages, please wait... failed.
>>
>>* * !! Byte-compilation for emacs22 failed!
>>* * !! This indicates a bug in one of the add-on packages
>>* * !! installed on your system, or a bug in Emacs itself.
>>* * !! Please file a bug report against emacs22
>>* * !! and attach the file /tmp/emacs22.Yh6563
>>
>> I attach both /tmp/emacs22.wr6538 and* /tmp/emacs22.Yh6563 here

>The file /etc/emacs/site-start.d/00debian-vars.el, which is in package
>emacsen-common, seems to be missing.
>Try reinstall emacsen-common

I tried your advisement to reinstall emacsen-mon and still got the same error. Is there anyway else to get it works? Thank Florian anyway.

Kevin




好玩贺卡**发,邮箱贺卡全新上线 --
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 03-08-2009, 12:19 PM
Florian Diesch
 
Default Installing Emacs gets error!

Ziffer <ziffer@yahoo.cn> wrote:

> On Sun, 08 Mar 2009 01:27:28 Florian Diesch wrote:
>
>>Ziffer <ziffer@yahoo.cn> wrote:
>
>>> I tried purging emacs and got :
>>>
>>> Byte-compiling add-on packages, please wait... failed.
>>> !! Byte-compilation for emacs22 failed!
>>> !! This indicates a bug in one of the add-on packages
>>> !! installed on your system, or a bug in Emacs itself.
>>> !! Please file a bug report against emacs22
>>> !! and attach the file /tmp/emacs22.wr6538
>>>
>>> Byte-compiling add-on packages, please wait... failed.
>>>
>>> !! Byte-compilation for emacs22 failed!
>>> !! This indicates a bug in one of the add-on packages
>>> !! installed on your system, or a bug in Emacs itself.
>>> !! Please file a bug report against emacs22
>>> !! and attach the file /tmp/emacs22.Yh6563
>>>
>>> I attach both /tmp/emacs22.wr6538 and /tmp/emacs22.Yh6563 here
>
>>The file /etc/emacs/site-start.d/00debian-vars.el, which is in package
>>emacsen-common, seems to be missing.
>>Try reinstall emacsen-common
>
> I tried your advisement to reinstall emacsen-mon and still got the
> same error. Is there anyway else to get it works? Thank Florian
> anyway.

Is the content of those /tmp/emacs22* files still the same?
What does
ls -l /etc/emacs/site-start.d/00debian-vars.el
say?


Florian
--
<http://www.florian-diesch.de/>

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 03-08-2009, 03:25 PM
Jorge Santos
 
Default Installing Emacs gets error!

Could you attach the file in /tmp that you get after trying to
reinstall emacsen-common ?

On Sun, Mar 8, 2009 at 9:19 AM, Florian Diesch <diesch@spamfence.net> wrote:
> Ziffer <ziffer@yahoo.cn> wrote:
>
>> On Sun, 08 Mar 2009 01:27:28 Florian Diesch wrote:
>>
>>>Ziffer <ziffer@yahoo.cn> wrote:
>>
>>>> I tried purging emacs and got :
>>>>
>>>> * * Byte-compiling add-on packages, please wait... failed.
>>>> * *!! Byte-compilation for emacs22 failed!
>>>> * *!! This indicates a bug in one of the add-on packages
>>>> * *!! installed on your system, or a bug in Emacs itself.
>>>> * *!! Please file a bug report against emacs22
>>>> * *!! and attach the file /tmp/emacs22.wr6538
>>>>
>>>> * Byte-compiling add-on packages, please wait... failed.
>>>>
>>>> * *!! Byte-compilation for emacs22 failed!
>>>> * *!! This indicates a bug in one of the add-on packages
>>>> * *!! installed on your system, or a bug in Emacs itself.
>>>> * *!! Please file a bug report against emacs22
>>>> * *!! and attach the file /tmp/emacs22.Yh6563
>>>>
>>>> I attach both /tmp/emacs22.wr6538 and */tmp/emacs22.Yh6563 here
>>
>>>The file /etc/emacs/site-start.d/00debian-vars.el, which is in package
>>>emacsen-common, seems to be missing.
>>>Try reinstall emacsen-common
>>
>> I tried your advisement to reinstall emacsen-mon and still got the
>> same error. Is there anyway else to get it works? Thank Florian
>> anyway.
>
> Is the content of those /tmp/emacs22* files still the same?
> What does
> *ls -l /etc/emacs/site-start.d/00debian-vars.el
> say?
>
>
> * Florian
> --
> <http://www.florian-diesch.de/>
>
> --
> ubuntu-users mailing list
> ubuntu-users@lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
>

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 03-09-2009, 01:28 AM
Ziffer
 
Default Installing Emacs gets error!

I have solved the problem. I got this problem because I remove emacs and emasc22 folds under /etc. After removing and installing with "aptitude" it works.*
Thanks for Florian Diesch, Jorge Santos and the other guys, thanks very much!




好玩贺卡**发,邮箱贺卡全新上线 --
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 01:21 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org