FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 02-26-2009, 03:50 PM
Dotan Cohen
 
Default Installing Stellarium 10.1 in Hardy

Although I do have the Backports repo enabled, I cannot install the
stellarium 10.1 .deb from Launchpad on Hardy, as I am missing many
dependencies:
dpkg: dependency problems prevent configuration of stellariu
m:
stellarium depends on libfreetype6 (>= 2.3.7); however:
Version of libfreetype6 on system is 2.3.5-1ubuntu4.8.04.1.
stellarium depends on libgcc1 (>= 1:4.3.2); however:
Version of libgcc1 on system is 1:4.2.4-1ubuntu4.
stellarium depends on libgl1-mesa-glx (>= 7.2-1); however:
Version of libgl1-mesa-glx on system is 7.0.3~rc2-1ubuntu3.
stellarium depends on libglu1-mesa (>= 7.2-1); however:
Version of libglu1-mesa on system is 7.0.3~rc2-1ubuntu3.
stellarium depends on libpng12-0 (>= 1.2.27-1); however:
Version of libpng12-0 on system is 1.2.15~beta5-3.
stellarium depends on libqt4-network (>= 4.4.3); however:
Version of libqt4-network on system is 4.4.0-1ubuntu5~hardy1.
stellarium depends on libqt4-opengl (>= 4.4.3); however:
Version of libqt4-opengl on system is 4.4.0-1ubuntu5~hardy1.
stellarium depends on libqt4-script (>= 4.4.3); however:
Version of libqt4-script on system is 4.4.0-1ubuntu5~hardy1.
stellarium depends on libqtcore4 (>= 4.4.3); however:
Version of libqtcore4 on system is 4.4.0-1ubuntu5~hardy1.
stellarium depends on libqtgui4 (>= 4.4.3); however:
Version of libqtgui4 on system is 4.4.0-1ubuntu5~hardy1.
stellarium depends on libsm6 (>= 2:1.0.3-2); however:
Version of libsm6 on system is 2:1.0.3-1.
stellarium depends on libstdc++6 (>= 4.3.2-1); however:
Version of libstdc++6 on system is 4.2.4-1ubuntu4.
stellarium depends on libx11-6 (>= 2:1.1.5-2); however:
Version of libx11-6 on system is 2:1.1.3-1ubuntu2.
stellarium depends on libxext6 (>= 2:1.0.4-1); however:
Version of libxext6 on system is 2:1.0.3-2build1.
dpkg: error processing stellarium (--install):
dependency problems - leaving unconfigured



Is there a quick way to solve this? I tried downloading and installing
some of the dependencies, but they do not install either (they also
have dependencies):
$ sudo dpkg -i libgcc1_4.2.3-2ubuntu7_i386.deb
dpkg - warning: downgrading libgcc1 from 1:4.2.4-1ubuntu4 to 1:4.2.3-2ubuntu7.
(Reading database ... 174265 files and directories currently installed.)
Preparing to replace libgcc1 1:4.2.4-1ubuntu4 (using
libgcc1_4.2.3-2ubuntu7_i386.deb) ...
Unpacking replacement libgcc1 ...
dpkg: dependency problems prevent configuration of libgcc1:
libgcc1 depends on gcc-4.2-base (= 4.2.3-2ubuntu7); however:
Version of gcc-4.2-base on system is 4.2.4-1ubuntu4.
dpkg: error processing libgcc1 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libgcc1
hardy1@hardy1-laptop:~/inOut/fromFirefox$

--
Dotan Cohen

http://what-is-what.com
http://gibberish.co.il

א-ב-ג-ד-ה-ו-ז-ח-ט-י-ך-כ-ל-ם-מ-ן-*-ס-ע-ף-פ-ץ-צ-ק-ר-ש-ת
ا-ب-ت-ث-ج-*-خ-د-ذ-ر-ز-س-ش-ص-ض-ط-ظ-ع-غ-ف-ق-ك-ل-م-ن-ه*-و-ي
А-Б-В-Г-Д-Е-Ё-Ж-З-И-Й-К-Л-М-Н-О-П-*-С-Т-У-Ф-Х-Ц-Ч-Ш-Щ-Ъ-Ы-Ь-*-Ю-Я
а-б-в-г-д-е-ё-ж-з-и-й-к-л-м-н-о-п-р-с-т-у-ф-х-ц-ч-ш-щ-ъ-ы-ь-э-ю-я
ä-ö-ü-ß-Ä-Ö-Ü

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 02-26-2009, 04:22 PM
 
Default Installing Stellarium 10.1 in Hardy

Dotan Cohen <dotancohen@gmail.com> writes:

> Although I do have the Backports repo enabled, I cannot install the
> stellarium 10.1 .deb from Launchpad on Hardy, as I am missing many
> dependencies:
> dpkg: dependency problems prevent configuration of stellariu
> m:
> stellarium depends on libfreetype6 (>= 2.3.7); however:
> Version of libfreetype6 on system is 2.3.5-1ubuntu4.8.04.1.
> stellarium depends on libgcc1 (>= 1:4.3.2); however:
> Version of libgcc1 on system is 1:4.2.4-1ubuntu4.
> stellarium depends on libgl1-mesa-glx (>= 7.2-1); however:
> Version of libgl1-mesa-glx on system is 7.0.3~rc2-1ubuntu3.
> stellarium depends on libglu1-mesa (>= 7.2-1); however:
> Version of libglu1-mesa on system is 7.0.3~rc2-1ubuntu3.
> stellarium depends on libpng12-0 (>= 1.2.27-1); however:
> Version of libpng12-0 on system is 1.2.15~beta5-3.
> stellarium depends on libqt4-network (>= 4.4.3); however:
> Version of libqt4-network on system is 4.4.0-1ubuntu5~hardy1.
> stellarium depends on libqt4-opengl (>= 4.4.3); however:
> Version of libqt4-opengl on system is 4.4.0-1ubuntu5~hardy1.
> stellarium depends on libqt4-script (>= 4.4.3); however:
> Version of libqt4-script on system is 4.4.0-1ubuntu5~hardy1.
> stellarium depends on libqtcore4 (>= 4.4.3); however:
> Version of libqtcore4 on system is 4.4.0-1ubuntu5~hardy1.
> stellarium depends on libqtgui4 (>= 4.4.3); however:
> Version of libqtgui4 on system is 4.4.0-1ubuntu5~hardy1.
> stellarium depends on libsm6 (>= 2:1.0.3-2); however:
> Version of libsm6 on system is 2:1.0.3-1.
> stellarium depends on libstdc++6 (>= 4.3.2-1); however:
> Version of libstdc++6 on system is 4.2.4-1ubuntu4.
> stellarium depends on libx11-6 (>= 2:1.1.5-2); however:
> Version of libx11-6 on system is 2:1.1.3-1ubuntu2.
> stellarium depends on libxext6 (>= 2:1.0.4-1); however:
> Version of libxext6 on system is 2:1.0.3-2build1.
> dpkg: error processing stellarium (--install):
> dependency problems - leaving unconfigured
>
try this:
sudo apt-get -f install
--
J@nek
jlitwinski(AT)gmail.com "Linux is like a wigwam, no gates,
http://www.litwinski.republika.pl/ no windows, but Apache inside"

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 02-26-2009, 04:33 PM
Brian McKee
 
Default Installing Stellarium 10.1 in Hardy

2009/2/26 Jan Litwiński <jlitwinski@vp.pl>:
> Dotan Cohen <dotancohen@gmail.com> writes:
>
>> Although I do have the Backports repo enabled, I cannot install the
>> stellarium 10.1 .deb from Launchpad on Hardy, as I am missing many
>> dependencies:

> try this:
> sudo apt-get -f install

Why? The guy that packaged that program thought it needed those
dependencies - what do you know than he didn't?

Recommending a forced install, especially without explaining what it's
doing to somebody less knowledgeable than Dotan could cause them a lot
of grief. Please don't do that!

Brian

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 02-26-2009, 04:36 PM
David Fox
 
Default Installing Stellarium 10.1 in Hardy

On Thu, Feb 26, 2009 at 8:50 AM, Dotan Cohen <dotancohen@gmail.com> wrote:
> Although I do have the Backports repo enabled, I cannot install the
> stellarium 10.1 .deb from Launchpad on Hardy, as I am missing many
> dependencies:
> dpkg: dependency problems prevent configuration of stellariu
> m:

You might want to inquire further on either the stellarium pubdevel
mailing list or the stellarium / sourceforge wiki. The best way (so
far) to solve most of these problems is to follow the wiki's
suggestions on building from source, and it will give you the files
needed to install to satisfy the dependencies

> *stellarium depends on libfreetype6 (>= 2.3.7); however:
> *Version of libfreetype6 on system is 2.3.5-1ubuntu4.8.04.1.
> *stellarium depends on libgcc1 (>= 1:4.3.2); however:
> *Version of libgcc1 on system is 1:4.2.4-1ubuntu4.

I'd hazard a guess that the packager built this against intrepid.


http://www.stellarium.org/wiki/index.php/Compilation_on_Linux

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 02-26-2009, 04:46 PM
 
Default Installing Stellarium 10.1 in Hardy

Brian McKee <brian.mckee@gmail.com> writes:

> 2009/2/26 Jan Litwiński <jlitwinski@vp.pl>:
>> Dotan Cohen <dotancohen@gmail.com> writes:
>>
>>> Although I do have the Backports repo enabled, I cannot install the
>>> stellarium 10.1 .deb from Launchpad on Hardy, as I am missing many
>>> dependencies:
>
>> try this:
>> sudo apt-get -f install
>
> Why? The guy that packaged that program thought it needed those
> dependencies - what do you know than he didn't?
>
> Recommending a forced install, especially without explaining what it's
> doing to somebody less knowledgeable than Dotan could cause them a lot
> of grief. Please don't do that!
don't warry,from the man page:

-f, --fix-broken
Fix; attempt to correct a system with broken dependencies in place.
This option, when used with install/remove, can omit any packages
to permit APT to deduce a likely solution. Any Package that are
specified must completely correct the problem. The option is
sometimes necessary when running APT for the first time; APT itself
does not allow broken package dependencies to exist on a system. It
is possible that a system´s dependency structure can be so corrupt
as to require manual intervention (which usually means using
dselect(8) or dpkg --remove to eliminate some of the offending
packages). Use of this option together with -m may produce an error
in some situations. Configuration Item: APT::Get::Fix-Broken.



--
J@nek
jlitwinski(AT)gmail.com "Linux is like a wigwam, no gates,
http://www.litwinski.republika.pl/ no windows, but Apache inside"

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 02-26-2009, 04:50 PM
Dotan Cohen
 
Default Installing Stellarium 10.1 in Hardy

> You might want to inquire further on either the stellarium pubdevel
> mailing list or the stellarium / sourceforge wiki. The best way (so
> far) to solve most of these problems is to follow the wiki's
> suggestions on building from source, and it will give you the files
> needed to install to satisfy the dependencies
>

The question is not so much a Stellarium question as an Ubuntu
question. Package X depends upon A, B, and C which in turn depend upon
L, M, and N. Package managers have taken care of this for ages
assuming that the proper repos are configured. If I don't have the
repos (I don't, it's an Intrepid package) how can I get them easily?

> *> *stellarium depends on libfreetype6 (>= 2.3.7); however:
>> *Version of libfreetype6 on system is 2.3.5-1ubuntu4.8.04.1.
>> *stellarium depends on libgcc1 (>= 1:4.3.2); however:
>> *Version of libgcc1 on system is 1:4.2.4-1ubuntu4.
>
> I'd hazard a guess that the packager built this against intrepid.
>

Yes, I should have mentioned that. But the question still stands: how
can I get a list of the required packages, then download them in one
move?

--
Dotan Cohen

http://what-is-what.com
http://gibberish.co.il

א-ב-ג-ד-ה-ו-ז-ח-ט-י-ך-כ-ל-ם-מ-ן-*-ס-ע-ף-פ-ץ-צ-ק-ר-ש-ת
ا-ب-ت-ث-ج-*-خ-د-ذ-ر-ز-س-ش-ص-ض-ط-ظ-ع-غ-ف-ق-ك-ل-م-ن-ه*-و-ي
А-Б-В-Г-Д-Е-Ё-Ж-З-И-Й-К-Л-М-Н-О-П-*-С-Т-У-Ф-Х-Ц-Ч-Ш-Щ-Ъ-Ы-Ь-*-Ю-Я
а-б-в-г-д-е-ё-ж-з-и-й-к-л-м-н-о-п-р-с-т-у-ф-х-ц-ч-ш-щ-ъ-ы-ь-э-ю-я
ä-ö-ü-ß-Ä-Ö-Ü

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 02-26-2009, 04:52 PM
Dotan Cohen
 
Default Installing Stellarium 10.1 in Hardy

>>> try this:
>>> sudo apt-get -f install
>>
>> Why? *The guy that packaged that program thought it needed those
>> dependencies - what do you know than he didn't?
>>
> -f, --fix-broken

Right, in apt-get -f is "fix", not "force" like it is in "yum"
(Redhat's package manager, derived from Yellow Dog). But this was not
the issue here.

--
Dotan Cohen

http://what-is-what.com
http://gibberish.co.il

א-ב-ג-ד-ה-ו-ז-ח-ט-י-ך-כ-ל-ם-מ-ן-*-ס-ע-ף-פ-ץ-צ-ק-ר-ש-ת
ا-ب-ت-ث-ج-*-خ-د-ذ-ر-ز-س-ش-ص-ض-ط-ظ-ع-غ-ف-ق-ك-ل-م-ن-ه*-و-ي
А-Б-В-Г-Д-Е-Ё-Ж-З-И-Й-К-Л-М-Н-О-П-*-С-Т-У-Ф-Х-Ц-Ч-Ш-Щ-Ъ-Ы-Ь-*-Ю-Я
а-б-в-г-д-е-ё-ж-з-и-й-к-л-м-н-о-п-р-с-т-у-ф-х-ц-ч-ш-щ-ъ-ы-ь-э-ю-я
ä-ö-ü-ß-Ä-Ö-Ü
--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 02-26-2009, 04:58 PM
Chris Mohler
 
Default Installing Stellarium 10.1 in Hardy

On Fri, Feb 27, 2009 at 11:50 AM, Dotan Cohen <dotancohen@gmail.com> wrote:
>> You might want to inquire further on either the stellarium pubdevel
>> mailing list or the stellarium / sourceforge wiki. The best way (so
>> far) to solve most of these problems is to follow the wiki's
>> suggestions on building from source, and it will give you the files
>> needed to install to satisfy the dependencies
>>
>
> The question is not so much a Stellarium question as an Ubuntu
> question. Package X depends upon A, B, and C which in turn depend upon
> L, M, and N. Package managers have taken care of this for ages
> assuming that the proper repos are configured. If I don't have the
> repos (I don't, it's an Intrepid package) how can I get them easily?
>
>> *> *stellarium depends on libfreetype6 (>= 2.3.7); however:
>>> *Version of libfreetype6 on system is 2.3.5-1ubuntu4.8.04.1.
>>> *stellarium depends on libgcc1 (>= 1:4.3.2); however:
>>> *Version of libgcc1 on system is 1:4.2.4-1ubuntu4.
>>
>> I'd hazard a guess that the packager built this against intrepid.
>>
>
> Yes, I should have mentioned that. But the question still stands: how
> can I get a list of the required packages, then download them in one
> move?

Umm - I think the only "one move" solution is dist-upgrade (upgrade to
Intrepid). Some of those dependencies are pretty heavy - qt and
libstdc++ for two - and will affect the packages that you currently
have installed (in Hardy).

Out of curiosity (laziness), what's new in the later version of
Stellarium (that's not in the Hardy version)?

Chris

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 02-26-2009, 05:15 PM
Brian McKee
 
Default Installing Stellarium 10.1 in Hardy

2009/2/26 Jan Litwiński <jlitwinski@vp.pl>:
> Brian McKee <brian.mckee@gmail.com> writes:
>
>> 2009/2/26 Jan Litwiński <jlitwinski@vp.pl>:
>>> Dotan Cohen <dotancohen@gmail.com> writes:
>>>
>>>> Although I do have the Backports repo enabled, I cannot install the
>>>> stellarium 10.1 .deb from Launchpad on Hardy, as I am missing many
>>>> dependencies:
>>
>>> try this:
>>> sudo apt-get -f install
>>
>> Why? *The guy that packaged that program thought it needed those
>> dependencies - what do you know than he didn't?
>>
>> Recommending a forced install, especially without explaining what it's
>> doing to somebody less knowledgeable than Dotan could cause them a lot
>> of grief. *Please don't do that!
> don't warry,from the man page:
>
> -f, --fix-broken

Duh.... sorry.... I'll go crawl back under a rock... I keep reading
that as 'force' :-(

Brian

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 02-26-2009, 05:24 PM
Derek Broughton
 
Default Installing Stellarium 10.1 in Hardy

Dotan Cohen wrote:

> Although I do have the Backports repo enabled, I cannot install the
> stellarium 10.1 .deb from Launchpad on Hardy, as I am missing many
> dependencies:
> dpkg: dependency problems prevent configuration of stellariu
> m:
...
> stellarium depends on libgcc1 (>= 1:4.3.2); however:
> Version of libgcc1 on system is 1:4.2.4-1ubuntu4.
...
> Is there a quick way to solve this? I tried downloading and installing
> some of the dependencies, but they do not install either (they also
> have dependencies):
> $ sudo dpkg -i libgcc1_4.2.3-2ubuntu7_i386.deb
> dpkg - warning: downgrading libgcc1 from 1:4.2.4-1ubuntu4 to
> 1:4.2.3-2ubuntu7.

Well it _did_ ask for 4.3.2, not 4.2.3 :-) ("downgrading" is a clue)
--
derek


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 05:20 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org