FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 12-20-2008, 10:02 PM
"Sandy Harris"
 
Default Kernel upgrade problem?

Core 2 duo, 2 gig, onboard Intel video, Xubuntu 7.10, 8.04 ran fine,
8.10 mostly OK.

Recently, after telling it to get all upgrades, I started seeing these messages:

E: linux-image-2.6.27-9-generic: subprocess post-installation script
returned error exit status 2
E: linux-headers-2.6.27-9-generic: subprocess post-installation script
returned error exit status 2
E: linux-headers-generic: dependency problems - leaving unconfigured
E: linux-image-generic: dependency problems - leaving unconfigured

Checking in Synaptic, I found various older things installed, like
2.6.24 modules.
I tagged those for removal and the current stuff for re-install. Somewhat to my
surprise, this did not solve the problem.

--
Sandy Harris,
Quanzhou, Fujian, China

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-20-2008, 10:19 PM
"Chris Mohler"
 
Default Kernel upgrade problem?

On Sun, Dec 21, 2008 at 5:02 PM, Sandy Harris <sandyinchina@gmail.com> wrote:
> Core 2 duo, 2 gig, onboard Intel video, Xubuntu 7.10, 8.04 ran fine,
> 8.10 mostly OK.
>
> Recently, after telling it to get all upgrades, I started seeing these messages:
>
> E: linux-image-2.6.27-9-generic: subprocess post-installation script
> returned error exit status 2
> E: linux-headers-2.6.27-9-generic: subprocess post-installation script
> returned error exit status 2
> E: linux-headers-generic: dependency problems - leaving unconfigured
> E: linux-image-generic: dependency problems - leaving unconfigured
>
> Checking in Synaptic, I found various older things installed, like
> 2.6.24 modules.
> I tagged those for removal and the current stuff for re-install. Somewhat to my
> surprise, this did not solve the problem.

Have you by any chance upgraded to 8.10? I ran into something similar
when I ran out of space in /boot. Try 'df -lh' to check. I had to
specifically remove the older kernels, then reinstall the latest
kernel.

HTH,
CHris

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-20-2008, 10:25 PM
"Sandy Harris"
 
Default Kernel upgrade problem?

On Sun, Dec 21, 2008 at 7:02 AM, Sandy Harris <sandyinchina@gmail.com> wrote:
> Core 2 duo, 2 gig, onboard Intel video, Xubuntu 7.10, 8.04 ran fine,
> 8.10 mostly OK.
>
> Recently, after telling it to get all upgrades, I started seeing these messages:
>
> E: linux-image-2.6.27-9-generic: subprocess post-installation script
> returned error exit status 2
> E: linux-headers-2.6.27-9-generic: subprocess post-installation script
> returned error exit status 2
> E: linux-headers-generic: dependency problems - leaving unconfigured
> E: linux-image-generic: dependency problems - leaving unconfigured
>
> Checking in Synaptic, I found various older things installed, like
> 2.6.24 modules.
> I tagged those for removal and the current stuff for re-install. Somewhat to my
> surprise, this did not solve the problem.

For linux-image-generic and linux-headers-generic, it shows latest version
as 2.6.27.9.13 but linux-image-2.6.27.9-generic and matching headers
show 2.6.27.9.19.



--
Sandy Harris,
Quanzhou, Fujian, China

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-20-2008, 11:39 PM
"Sandy Harris"
 
Default Kernel upgrade problem?

Chris Mohler <cr33dog@gmail.com> wrote:

> Have you by any chance upgraded to 8.10?

Yes.

> I ran into something similar
> when I ran out of space in /boot. Try 'df -lh' to check.

/boot is not a separate partition and / has plenty of space.

> I had to specifically remove the older kernels, then
> reinstall the latest kernel.

List of files looks OK

sandy@sandy-desktop:~$ ls /boot
abi-2.6.27-9-generic memtest86+.bin
config-2.6.27-9-generic System.map-2.6.27-9-generic
grub vmcoreinfo-2.6.27-9-generic
initrd.img-2.6.27-9-generic vmlinuz-2.6.27-9-generic


--
Sandy Harris,
Quanzhou, Fujian, China

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-21-2008, 12:01 AM
"Sandy Harris"
 
Default Kernel upgrade problem?

On Sun, Dec 21, 2008 at 7:19 AM, Chris Mohler <cr33dog@gmail.com> wrote:

>> Checking in Synaptic, I found various older things installed, like
>> 2.6.24 modules.
>> I tagged those for removal and the current stuff for re-install. Somewhat to my
>> surprise, this did not solve the problem.
>
> ... I had to specifically remove the older kernels, then reinstall the latest
> kernel.

I removed /boot/*generic* then removed all the image and headers files
in Synaptic, then re-installed them. All the *generic* files in /boot are
back & look to be sensible sizes, but I still get error messages.



--
Sandy Harris,
Quanzhou, Fujian, China

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-21-2008, 03:54 PM
Florian Diesch
 
Default Kernel upgrade problem?

"Sandy Harris" <sandyinchina@gmail.com> wrote:

> Recently, after telling it to get all upgrades, I started seeing these messages:
>
> E: linux-image-2.6.27-9-generic: subprocess post-installation script
> returned error exit status 2
> E: linux-headers-2.6.27-9-generic: subprocess post-installation script
> returned error exit status 2

Please install linux-image-2.6.27-9-generic again and then post from
/var/log/apt/term.log anything after the *last* line that looks
like
Log started: 2008-12-21 01:13:43


Florian
--
<http://www.florian-diesch.de/>
-----------------------------------------------------------------------
** Hi! I'm a signature virus! Copy me into your signature, please! **
-----------------------------------------------------------------------

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-21-2008, 09:06 PM
"Sandy Harris"
 
Default Kernel upgrade problem?

On Mon, Dec 22, 2008 at 12:54 AM, Florian Diesch <diesch@spamfence.net> wrote:

> Please install linux-image-2.6.27-9-generic again and then post from
> /var/log/apt/term.log anything after the *last* line that looks
> like Log started: 2008-12-21 01:13:43

This is from telling Synaptic to re-install linux-image-2.6.27-9-generic

I notice an error with nividia-common. I do not have an nvidia card.

Log started: 2008-12-22 05:58:40
Setting up linux-image-2.6.27-9-generic (2.6.27-9.19) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.27-9-generic
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.27-9-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/nvidia-common
run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10
Failed to process /etc/kernel/postinst.d at
/var/lib/dpkg/info/linux-image-2.6.27-9-generic.postinst line 1002.
dpkg: error processing linux-image-2.6.27-9-generic (--configure):
subprocess post-installation script returned error exit status 2
Setting up linux-headers-2.6.27-9-generic (2.6.27-9.19) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common
run-parts: /etc/kernel/header_postinst.d/nvidia-common exited with
return code 10
Failed to process /etc/kernel/header_postinst.d at
/var/lib/dpkg/info/linux-headers-2.6.27-9-generic.postinst line 110.
dpkg: error processing linux-headers-2.6.27-9-generic (--configure):
subprocess post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-headers-generic:
linux-headers-generic depends on linux-headers-2.6.27-9-generic; however:
Package linux-headers-2.6.27-9-generic is not configured yet.
dpkg: error processing linux-headers-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic:
linux-image-generic depends on linux-image-2.6.27-9-generic; however:
Package linux-image-2.6.27-9-generic is not configured yet.
dpkg: error processing linux-image-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image:
linux-image depends on linux-image-generic (= 2.6.27.9.13); however:
Package linux-image-generic is not configured yet.
dpkg: error processing linux-image (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
linux-image-2.6.27-9-generic
linux-headers-2.6.27-9-generic
linux-headers-generic
linux-image-generic
linux-image
Log ended: 2008-12-22 05:58:52

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-26-2008, 12:49 PM
sandyinchina
 
Default Kernel upgrade problem?

On Mon, Dec 22, 2008 at 6:06 AM, Sandy Harris <sandyinchina@gmail.com> wrote:
> On Mon, Dec 22, 2008 at 12:54 AM, Florian Diesch <diesch@spamfence.net> wrote:
>
>> Please install linux-image-2.6.27-9-generic again and then post from
>> /var/log/apt/term.log anything after the *last* line that looks
>> like Log started: 2008-12-21 01:13:43
>
> This is from telling Synaptic to re-install linux-image-2.6.27-9-generic
>
> I notice an error with nividia-common. I do not have an nvidia card.
>
> Log started: 2008-12-22 05:58:40
> Setting up linux-image-2.6.27-9-generic (2.6.27-9.19) ...
> ...
>
> Examining /etc/kernel/postinst.d.
> run-parts: executing /etc/kernel/postinst.d/nvidia-common
> run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10
> Failed to process /etc/kernel/postinst.d at
> /var/lib/dpkg/info/linux-image-2.6.27-9-generic.postinst line 1002.
> dpkg: error processing linux-image-2.6.27-9-generic (--configure):
> subprocess post-installation script returned error exit status 2
> Setting up linux-headers-2.6.27-9-generic (2.6.27-9.19) ...
> Examining /etc/kernel/header_postinst.d.
> run-parts: executing /etc/kernel/header_postinst.d/nvidia-common
> run-parts: /etc/kernel/header_postinst.d/nvidia-common exited with
> return code 10
> Failed to process /etc/kernel/header_postinst.d at
> /var/lib/dpkg/info/linux-headers-2.6.27-9-generic.postinst line 110.
> dpkg: error processing linux-headers-2.6.27-9-generic (--configure):
> subprocess post-installation script returned error exit status 2
> dpkg: dependency problems prevent configuration of linux-headers-generic:
> linux-headers-generic depends on linux-headers-2.6.27-9-generic; however:
> Package linux-headers-2.6.27-9-generic is not configured yet.
> dpkg: error processing linux-headers-generic (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of linux-image-generic:
> linux-image-generic depends on linux-image-2.6.27-9-generic; however:
> Package linux-image-2.6.27-9-generic is not configured yet.
> dpkg: error processing linux-image-generic (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of linux-image:
> linux-image depends on linux-image-generic (= 2.6.27.9.13); however:
> Package linux-image-generic is not configured yet.
> dpkg: error processing linux-image (--configure):
> dependency problems - leaving unconfigured
> Errors were encountered while processing:
> linux-image-2.6.27-9-generic
> linux-headers-2.6.27-9-generic
> linux-headers-generic
> linux-image-generic
> linux-image
> Log ended: 2008-12-22 05:58:52

Whatever this is, it is continuing. Removing all the stuff that seemed
relevant in Synaptic and then re-installing made no difference. Nor
did removing /boot/*generic* System still boots happily, though,
and other updates seem to complete just fine.

--
Sandy Harris,
Quanzhou, Fujian, China

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 06:15 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org