FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 12-11-2008, 10:10 PM
Derek Broughton
 
Default udev rules not working

mparrilla@ono.com wrote:

> I have a usb pen drive and I want it to be mounted in a
> particular directory when I plug it.
>
> I have written a udev rule in the
> file /etc/udev/rules.d/50-MyRule.rules:
>
> BUS=="usb", KERNEL=="sd?1",
> ATTRS{product}=="USB DISK 2.0", ATTRS{serial}=="078A184502BD", NAME="%
> k", SYMLINK+="usb16GB%n"

OK, but there's no mount command there...
>
> and added to /etc/fstab the line:
>
>
> /dev/usb16GB1 /mnt/usbdisk ext3 users,noauto,exec,suid 0 0

It's "noauto" - how do you expect it to be automatically mounted there?

> But when I plug the pen drive, it is automounted in /media/usb0,
> ignoring my udev rule.

Itclearly didn't ignore the rule, because...
>
> If I umount the device and do:
>
> mount
> /mnt/usbdisk
>
> It is correctly mounted.

How could it be mounted on /dev/usb16GB1, unless your udev rule worked?

> How can I get what I want?

You could probably execute a "mount" command from udev, but you probably
really should be modify hal's .fdi files (and I have no idea how to do
that). fwiw, I thought gnome let you just rename the /media mountpoint
by renaming the mounted device icon on your desktop (KDE 3.5 did, I have
no idea about 4.1).
--
derek


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 12-13-2008, 07:52 PM
"mparrilla@ono.com"
 
Default udev rules not working

El Friday 12 December 2008 00:10:04 Derek Broughton escribió:
>
mparrilla@ono.com wrote:
> > I have a usb pen drive and I want it to be
mounted in a
> > particular directory when I plug it.
> >
> > I have
written a udev rule in the
> > file /etc/udev/rules.d/50-MyRule.rules:

> >
> > BUS=="usb", KERNEL=="sd?1",
> > ATTRS{product}=="USB DISK 2.0",
ATTRS{serial}=="078A184502BD", NAME="%
> > k", SYMLINK+="usb16GB%n"
>
>
OK, but there's no mount command there...
>
What do you mean? Where can
I get information about that?

> > and added to /etc/fstab the line:
>
>
> >
> > /dev/usb16GB1 /mnt/usbdisk ext3 users,noauto,exec,suid
0 0
>
> It's "noauto" - how do you expect it to be automatically
mounted there?
>
It is automatically mounted, but not in the place I
want.

> > But when I plug the pen drive, it is automounted in
/media/usb0,
> > ignoring my udev rule.
>
> Itclearly didn't ignore the
rule, because...
>
> > If I umount the device and do:
> >
> > mount
> >
/mnt/usbdisk
> >
> > It is correctly mounted.
>
> How could it be
mounted on /dev/usb16GB1, unless your udev rule worked?
>
Ok, the udev
rule works, but not in the way I'd like.

> > How can I get what I
want?
>
> You could probably execute a "mount" command from udev, but
you probably
> really should be modify hal's .fdi files (and I have no
idea how to do
> that). fwiw, I thought gnome let you just rename the
/media mountpoint
> by renaming the mounted device icon on your desktop
(KDE 3.5 did, I have
> no idea about 4.1).
>
I'll do some research
about it.

> --
> derek
>
Thank you

Manuel Parrilla


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 02:51 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org