FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 12-12-2007, 07:25 AM
ice`
 
Default new HP Laptop: frequency scaling not supported on C2D T7500 -> High CPU Temps

Hi,
I've just bought an HP Pavillon DV26xx (DV2500 series).
My ubuntu 7.10 64bit is working perfectly apart from CPU Frequency scaling.
This is CPU data:

brex@ubuntu-box:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz
stepping : 11
cpu MHz : 2194.736
cache size : 4096 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall
nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips : 4393.94
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

(same for Processor 1 - the second core)

this is when I try to load acpi-cpufreq

brex@ubuntu-box:~$ sudo modprobe acpi-cpufreq
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.22-14-generic/kernel/arch/x86_64/kernel/cpufreq/acpi-cpufreq.ko):
No such device

no other modules for frequency scaling work....

I also get this errors about ACPI when loading acpi-cpufreq:

[ 1008.017253] ACPI Error (psargs-0355): [\_PR_.CPU0._PSS] Namespace
lookup failure, AE_NOT_FOUND
[ 1008.017259] ACPI Error (psparse-0551): Method parse/execution failed
[\_PR_.CPU1._PSS] (Node ffff81007cf59de0), AE_NOT_FOUND
[ 1008.017293] ACPI Exception (processor_perflib-0234): AE_NOT_FOUND,
Evaluating _PSS [20070126]

I'm already using latest BIOS for my laptop (F.21...there was a F.13
standard when I bought it but I didn't pay attention if speedstep was
working on it.)

This problem is quite annoying since when CPU runs at 100% for long time
I get temps about 70-80C and the laptop gets quite hot.

Any suggestion?
Thanks

--
DrBrex
Was Debianizzato! -.- Now Ubuntizzato! -.-
Il blog di tutti i Debianizzati && Ubuntizzati && famiglia :
Do it in the Debian way! - http://debianway.wordpress.com


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 07:54 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org