FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 09-15-2008, 07:48 PM
"Bas Jacobs"
 
Default AGP issue (Ubuntu 8.04, AMD Athlon 3000+, ATI Radeon 9800 pro, nforce3)

Hello,

I'm having some trouble with my Ubuntu installation (8.04, the latest LTS release). The video drivers do not function properly. When I use the radeon driver, i can't get DRI. When I use the fglrx (proprietary) driver from ATI, the only thing I get is a white screen after logging in, with my cursor on it.


I use the following hardware configuration: AMD Athlon 64 3000+ processor, nforce3 chipset, 512 MB memory and an ATI Radeon 9800 pro graphics card. (More information about my hardware can be found at http://ubuntuforums.org/showthread.php?t=917810, the thread at the forums I started about this subject. It is attached in "hardware.txt".)


Tracing various logs I've found the following suspected messages:

messages, kern.log, syslog, dmesg:

agpgart: Detected AGP bridge 0
agpgart: Setting up Nforce3 AGP.
agpgart: aperture base > 4G
And in xorg.0.log (using the radeon driver):

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
drmOpenByBusid: Searching for BusID pci:0000:01:00.0

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenByBusid: drmOpenMinor returns 7
drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0

[...]

//This seems ok

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenByBusid: Searching for BusID pci:0000:01:00.0

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenByBusid: drmOpenMinor returns 7
drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0

[...]

(EE) RADEON(0): [agp] AGP failed to initialize. Disabling the DRI.

(II) RADEON(0): [agp] You may want to make sure the agpgart kernel module
is loaded before the radeon kernel module.

[...]

(WW) RADEON(0): Direct rendering disabled
(II) RADEON(0): Render acceleration unsupported on Radeon 9500/9700 and newer.

(II) RADEON(0): Render acceleration disabled

[...]

(II) AIGLX: Screen 0 is not DRI capable

Before sending this mail i've done a lot of research. Not only on google, but also on various fora (also on ubuntuforums and on the unofficial ATI forum). The info I found there was not appliable on my hardware.


Thanks in advance,

Bas Jacobs

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 07:18 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org