FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 08-24-2008, 11:36 PM
Noah
 
Default php warning:: Unable to load dynamic library

Hi there,

when I run some php executables I receive the following warning. what
do I need to do to get the warning to stop?

Cheers,

Noah



Warning: PHP Startup: Unable to load dynamic library
'/usr/local/lib/php/20060613/sqlite.so' -
/usr/local/lib/php/20060613/sqlite.so: Undefined symbol
"spl_ce_Countable" in Unknown on line 0

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-25-2008, 01:45 AM
Leonard Chatagnier
 
Default php warning:: Unable to load dynamic library

--- Noah <admin2@enabled.com> wrote:

> Hi there,
>
> when I run some php executables I receive the
> following warning. what
> do I need to do to get the warning to stop?
>
> Cheers,
>
> Noah
>
>
>
> Warning: PHP Startup: Unable to load dynamic library
>
> '/usr/local/lib/php/20060613/sqlite.so' -
> /usr/local/lib/php/20060613/sqlite.so: Undefined
> symbol
> "spl_ce_Countable" in Unknown on line 0
>
After doing some aptitude and wajig searching, I see
there are 2 versions of php, php and php5, and several
programs with those names in them. Same for sglite.
I don't have php* installed and wouldn't now what to
do with it. You may however do and aptitude search and
show on the specific php* program you have installed
for information on depends and conflicts and same on
splite and perhaps find a solution. Sorry, I couldn't
be more help.

Leonard Chatagnier
lenc5570@sbcglobal.net

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-25-2008, 08:31 PM
"Mumia W."
 
Default php warning:: Unable to load dynamic library

On 08/24/2008 06:36 PM, Noah wrote:
> Hi there,
>
> when I run some php executables I receive the following warning. what
> do I need to do to get the warning to stop?
>
> Cheers,
>
> Noah
>
>
>
> Warning: PHP Startup: Unable to load dynamic library
> '/usr/local/lib/php/20060613/sqlite.so' -
> /usr/local/lib/php/20060613/sqlite.so: Undefined symbol
> "spl_ce_Countable" in Unknown on line 0
>

What php executables? What php binary? What package does that binary
come from?

Evidently you've installed a non-Ubuntu version of sqlite, and it's
conflicting with PHP. You might need to uninstall it and install a
Ubuntu, modern version of sqlite.



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 05:40 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org