FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 08-24-2008, 06:25 PM
Dvorzhetsky
 
Default amarok on ubuntu hardy takes 15 minutes to startup

Hi, I'am running ubuntu hardy (gnome), I installed amarok from the
regular repositories.

I got a serious problem with it: it takes about 15 minutes to startup,
about 2 minutes for the icon to get in the status bar and then it is
still unusable for about 10-15 minutes (mouse over the icon show the
application is busy). Then it works fine.

I tried to remove the packages clearing config file but it didn't help.
I even tried running it as root I built the collection then I have the
same problem.
The worse is that neither memory nor cpu is 100% used when it loads, I
can still use my system, as long as I don't click on the amarok icon and
ask him something (in that case I have to wait that it loads fully to
regain control on the system).
I check it do not reload collection in the mean time, HD are not busy.

----------------------------------------------------------
me@bunlaptop:~$ amarok
Amarok: [Loader] Starting amarokapp..
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use
amarokapp.
DCOPClient::attachInternal. Attach failed Could not open network socket
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file
/home/me/.local/share/applications/alacarte-made.desktop has Type=Link
instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service :
/home/me/.local/share/applications/alacarte-made.desktop
kio (KService*): WARNING: The desktop entry file
/home/me/.local/share/applications/alacarte-made-1.desktop has Type=Link
instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service :
/home/me/.local/share/applications/alacarte-made-1.desktop
kio (KService*): WARNING: The desktop entry file
/home/me/.local/share/applications/alacarte-made-2.desktop has Type=Link
instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service :
/home/me/.local/share/applications/alacarte-made-2.desktop
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x8126c78 ):
KAccel object already contains an action name "play_pause"
QLayout "unnamed" added to QVBox "unnamed", which already has a layout
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x8126c78 ):
KAccel object already contains an action name "play_pause"
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout
for PlaylistWindow/PlaylistWindow
QObject::connect: Incompatible sender/receiver arguments
StarManager::ratingsColorsChanged() -->
ContextBrowser::ratingOrScoreOrLabelsChanged(const QString&)
me@bunlaptop:~$ amarok: WARNING: Pixmap not found for mimetype
application/ogg
amarok: WARNING: Pixmap not found for mimetype application/ogg
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KLauncher): ERROR: SlavePool: No communication with slave.
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KLauncher): ERROR: SlavePool: No communication with slave.
QObject::disconnect: Unexpected null parameter
QObject::connect: Cannot connect (null)::activePartChanged( KParts::Part
* ) to KHTMLPart::slotActiveFrameChanged( KParts::Part * )
ssh mediawiki@gaDDkio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KIOConnection): ERROR: Could not write data
kio (KLauncher): ERROR: SlavePool: No communication with slave.
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KLauncher): ERROR: SlavePool: No communication with slave.
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KIOConnection): ERROR: Could not write data
kio (KLauncher): ERROR: SlavePool: No communication with slave.
DCOP aborting call from 'anonymous-19721' to 'amarok'
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x580001c
----------------------------------------------------------


----------------------------------------------------------
me@bunlaptop:~$ amarokapp
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x81347f0 ):
KAccel object already contains an action name "play_pause"
QLayout "unnamed" added to QVBox "unnamed", which already has a layout
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x81347f0 ):
KAccel object already contains an action name "play_pause"
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout
for PlaylistWindow/PlaylistWindow
QObject::connect: Incompatible sender/receiver arguments
StarManager::ratingsColorsChanged() -->
ContextBrowser::ratingOrScoreOrLabelsChanged(const QString&)
STARTUP
amarok: WARNING: Pixmap not found for mimetype application/ogg
amarok: WARNING: Pixmap not found for mimetype application/ogg
QObject::disconnect: Unexpected null parameter
QObject::connect: Cannot connect (null)::activePartChanged( KParts::Part
* ) to KHTMLPart::slotActiveFrameChanged( KParts::Part * )
me@bunlaptop:~$ amarokapp
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x809cdd8 ):
KAccel object already contains an action name "play_pause"
QLayout "unnamed" added to QVBox "unnamed", which already has a layout
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x809cdd8 ):
KAccel object already contains an action name "play_pause"
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout
for PlaylistWindow/PlaylistWindow
QObject::connect: Incompatible sender/receiver arguments
StarManager::ratingsColorsChanged() -->
ContextBrowser::ratingOrScoreOrLabelsChanged(const QString&)
STARTUP
amarok: WARNING: Pixmap not found for mimetype application/ogg
amarok: WARNING: Pixmap not found for mimetype application/ogg
QObject::disconnect: Unexpected null parameter
QObject::connect: Cannot connect (null)::activePartChanged( KParts::Part
* ) to KHTMLPart::slotActiveFrameChanged( KParts::Part * )
----------------------------------------------------------

Copying this in google didn't help me much.
Can someone give me an hand? this is driving me nuts!

I can provide other log if necessary

Cheers!

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-26-2008, 02:13 AM
musicman
 
Default amarok on ubuntu hardy takes 15 minutes to startup

I found moving from the SQLLite backend to the MySQL backend worked
pretty well in reagrds to speeding up load times significantly. You
might want to try that.

It's a fairly simple process that is very well documented in the forums.

see this for example:

http://mikesubuntu.blogspot.com/2007/09/how-to-set-up-mysql-database-in-amarok.html

or from the KDE crowd: http://amarok.kde.org/wiki/MySQL_HowTo

cheers
L.

On Mon, Aug 25, 2008 at 4:25 AM, Dvorzhetsky <dvorzhetsky@airpost.net> wrote:
> Hi, I'am running ubuntu hardy (gnome), I installed amarok from the
> regular repositories.
>
> I got a serious problem with it: it takes about 15 minutes to startup,
> about 2 minutes for the icon to get in the status bar and then it is
> still unusable for about 10-15 minutes (mouse over the icon show the
> application is busy). Then it works fine.
>
> I tried to remove the packages clearing config file but it didn't help.
> I even tried running it as root I built the collection then I have the
> same problem.
> The worse is that neither memory nor cpu is 100% used when it loads, I
> can still use my system, as long as I don't click on the amarok icon and
> ask him something (in that case I have to wait that it loads fully to
> regain control on the system).
> I check it do not reload collection in the mean time, HD are not busy.
>
> ----------------------------------------------------------
> me@bunlaptop:~$ amarok
> Amarok: [Loader] Starting amarokapp..
> Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use
> amarokapp.
> DCOPClient::attachInternal. Attach failed Could not open network socket
> kbuildsycoca running...
> Reusing existing ksycoca
> kio (KService*): WARNING: The desktop entry file
> /home/me/.local/share/applications/alacarte-made.desktop has Type=Link
> instead of "Application" or "Service"
> kio (KService*): WARNING: Invalid Service :
> /home/me/.local/share/applications/alacarte-made.desktop
> kio (KService*): WARNING: The desktop entry file
> /home/me/.local/share/applications/alacarte-made-1.desktop has Type=Link
> instead of "Application" or "Service"
> kio (KService*): WARNING: Invalid Service :
> /home/me/.local/share/applications/alacarte-made-1.desktop
> kio (KService*): WARNING: The desktop entry file
> /home/me/.local/share/applications/alacarte-made-2.desktop has Type=Link
> instead of "Application" or "Service"
> kio (KService*): WARNING: Invalid Service :
> /home/me/.local/share/applications/alacarte-made-2.desktop
> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x8126c78 ):
> KAccel object already contains an action name "play_pause"
> QLayout "unnamed" added to QVBox "unnamed", which already has a layout
> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x8126c78 ):
> KAccel object already contains an action name "play_pause"
> QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout
> for PlaylistWindow/PlaylistWindow
> QObject::connect: Incompatible sender/receiver arguments
> StarManager::ratingsColorsChanged() -->
> ContextBrowser::ratingOrScoreOrLabelsChanged(const QString&)
> me@bunlaptop:~$ amarok: WARNING: Pixmap not found for mimetype
> application/ogg
> amarok: WARNING: Pixmap not found for mimetype application/ogg
> kio (KIOConnection): ERROR: Header read failed, errno=104
> kio (KIOConnection): ERROR: Header has invalid size (-1)
> kio (KIOConnection): ERROR: Header read failed, errno=104
> kio (KIOConnection): ERROR: Header has invalid size (-1)
> kio (KLauncher): ERROR: SlavePool: No communication with slave.
> kio (KIOConnection): ERROR: Header read failed, errno=104
> kio (KIOConnection): ERROR: Header has invalid size (-1)
> kio (KIOConnection): ERROR: Header read failed, errno=104
> kio (KIOConnection): ERROR: Header has invalid size (-1)
> kio (KLauncher): ERROR: SlavePool: No communication with slave.
> QObject::disconnect: Unexpected null parameter
> QObject::connect: Cannot connect (null)::activePartChanged( KParts::Part
> * ) to KHTMLPart::slotActiveFrameChanged( KParts::Part * )
> ssh mediawiki@gaDDkio (KIOConnection): ERROR: Header read failed, errno=104
> kio (KIOConnection): ERROR: Header has invalid size (-1)
> kio (KIOConnection): ERROR: Could not write data
> kio (KLauncher): ERROR: SlavePool: No communication with slave.
> kio (KIOConnection): ERROR: Header read failed, errno=104
> kio (KIOConnection): ERROR: Header has invalid size (-1)
> kio (KIOConnection): ERROR: Header read failed, errno=104
> kio (KIOConnection): ERROR: Header has invalid size (-1)
> kio (KLauncher): ERROR: SlavePool: No communication with slave.
> kio (KIOConnection): ERROR: Header read failed, errno=104
> kio (KIOConnection): ERROR: Header has invalid size (-1)
> kio (KIOConnection): ERROR: Could not write data
> kio (KLauncher): ERROR: SlavePool: No communication with slave.
> DCOP aborting call from 'anonymous-19721' to 'amarok'
> kio (KIOConnection): ERROR: Header read failed, errno=104
> kio (KIOConnection): ERROR: Header has invalid size (-1)
> X Error: BadWindow (invalid Window parameter) 3
> Major opcode: 7
> Minor opcode: 0
> Resource id: 0x580001c
> ----------------------------------------------------------
>
>
> ----------------------------------------------------------
> me@bunlaptop:~$ amarokapp
> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x81347f0 ):
> KAccel object already contains an action name "play_pause"
> QLayout "unnamed" added to QVBox "unnamed", which already has a layout
> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x81347f0 ):
> KAccel object already contains an action name "play_pause"
> QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout
> for PlaylistWindow/PlaylistWindow
> QObject::connect: Incompatible sender/receiver arguments
> StarManager::ratingsColorsChanged() -->
> ContextBrowser::ratingOrScoreOrLabelsChanged(const QString&)
> STARTUP
> amarok: WARNING: Pixmap not found for mimetype application/ogg
> amarok: WARNING: Pixmap not found for mimetype application/ogg
> QObject::disconnect: Unexpected null parameter
> QObject::connect: Cannot connect (null)::activePartChanged( KParts::Part
> * ) to KHTMLPart::slotActiveFrameChanged( KParts::Part * )
> me@bunlaptop:~$ amarokapp
> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x809cdd8 ):
> KAccel object already contains an action name "play_pause"
> QLayout "unnamed" added to QVBox "unnamed", which already has a layout
> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x809cdd8 ):
> KAccel object already contains an action name "play_pause"
> QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout
> for PlaylistWindow/PlaylistWindow
> QObject::connect: Incompatible sender/receiver arguments
> StarManager::ratingsColorsChanged() -->
> ContextBrowser::ratingOrScoreOrLabelsChanged(const QString&)
> STARTUP
> amarok: WARNING: Pixmap not found for mimetype application/ogg
> amarok: WARNING: Pixmap not found for mimetype application/ogg
> QObject::disconnect: Unexpected null parameter
> QObject::connect: Cannot connect (null)::activePartChanged( KParts::Part
> * ) to KHTMLPart::slotActiveFrameChanged( KParts::Part * )
> ----------------------------------------------------------
>
> Copying this in google didn't help me much.
> Can someone give me an hand? this is driving me nuts!
>
> I can provide other log if necessary
>
> Cheers!
>
> --
> ubuntu-users mailing list
> ubuntu-users@lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
>



--
I am a rock, I am an "archipelago of the informal"

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-26-2008, 02:34 AM
Ryan Toler
 
Default amarok on ubuntu hardy takes 15 minutes to startup

Note that running mysql just to speed up one program might slowdown
the rest of the system. I'm not sure but the default install starts at
least 5 but may be up to 10 processes each eating up ram and CPU
Cycles. This might not be a problem for your machine but you should
weigh the pros and cons of a faster music player or faster system as a
whole.

On Aug 25, 2008, at 9:13 PM, musicman <datakid@gmail.com> wrote:

> I found moving from the SQLLite backend to the MySQL backend worked
> pretty well in reagrds to speeding up load times significantly. You
> might want to try that.
>
> It's a fairly simple process that is very well documented in the
> forums.
>
> see this for example:
>
> http://mikesubuntu.blogspot.com/2007/09/how-to-set-up-mysql-database-in-amarok.html
>
> or from the KDE crowd: http://amarok.kde.org/wiki/MySQL_HowTo
>
> cheers
> L.
>
> On Mon, Aug 25, 2008 at 4:25 AM, Dvorzhetsky
> <dvorzhetsky@airpost.net> wrote:
>> Hi, I'am running ubuntu hardy (gnome), I installed amarok from the
>> regular repositories.
>>
>> I got a serious problem with it: it takes about 15 minutes to
>> startup,
>> about 2 minutes for the icon to get in the status bar and then it is
>> still unusable for about 10-15 minutes (mouse over the icon show the
>> application is busy). Then it works fine.
>>
>> I tried to remove the packages clearing config file but it didn't
>> help.
>> I even tried running it as root I built the collection then I have
>> the
>> same problem.
>> The worse is that neither memory nor cpu is 100% used when it
>> loads, I
>> can still use my system, as long as I don't click on the amarok
>> icon and
>> ask him something (in that case I have to wait that it loads fully to
>> regain control on the system).
>> I check it do not reload collection in the mean time, HD are not
>> busy.
>>
>> ----------------------------------------------------------
>> me@bunlaptop:~$ amarok
>> Amarok: [Loader] Starting amarokapp..
>> Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary!
>> Use
>> amarokapp.
>> DCOPClient::attachInternal. Attach failed Could not open network
>> socket
>> kbuildsycoca running...
>> Reusing existing ksycoca
>> kio (KService*): WARNING: The desktop entry file
>> /home/me/.local/share/applications/alacarte-made.desktop has
>> Type=Link
>> instead of "Application" or "Service"
>> kio (KService*): WARNING: Invalid Service :
>> /home/me/.local/share/applications/alacarte-made.desktop
>> kio (KService*): WARNING: The desktop entry file
>> /home/me/.local/share/applications/alacarte-made-1.desktop has
>> Type=Link
>> instead of "Application" or "Service"
>> kio (KService*): WARNING: Invalid Service :
>> /home/me/.local/share/applications/alacarte-made-1.desktop
>> kio (KService*): WARNING: The desktop entry file
>> /home/me/.local/share/applications/alacarte-made-2.desktop has
>> Type=Link
>> instead of "Application" or "Service"
>> kio (KService*): WARNING: Invalid Service :
>> /home/me/.local/share/applications/alacarte-made-2.desktop
>> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel =
>> 0x8126c78 ):
>> KAccel object already contains an action name "play_pause"
>> QLayout "unnamed" added to QVBox "unnamed", which already has a
>> layout
>> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel =
>> 0x8126c78 ):
>> KAccel object already contains an action name "play_pause"
>> QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to
>> layout
>> for PlaylistWindow/PlaylistWindow
>> QObject::connect: Incompatible sender/receiver arguments
>> StarManager::ratingsColorsChanged() -->
>> ContextBrowser::ratingOrScoreOrLabelsChanged(const QString&)
>> me@bunlaptop:~$ amarok: WARNING: Pixmap not found for mimetype
>> application/ogg
>> amarok: WARNING: Pixmap not found for mimetype application/ogg
>> kio (KIOConnection): ERROR: Header read failed, errno=104
>> kio (KIOConnection): ERROR: Header has invalid size (-1)
>> kio (KIOConnection): ERROR: Header read failed, errno=104
>> kio (KIOConnection): ERROR: Header has invalid size (-1)
>> kio (KLauncher): ERROR: SlavePool: No communication with slave.
>> kio (KIOConnection): ERROR: Header read failed, errno=104
>> kio (KIOConnection): ERROR: Header has invalid size (-1)
>> kio (KIOConnection): ERROR: Header read failed, errno=104
>> kio (KIOConnection): ERROR: Header has invalid size (-1)
>> kio (KLauncher): ERROR: SlavePool: No communication with slave.
>> QObject::disconnect: Unexpected null parameter
>> QObject::connect: Cannot connect
>> (null)::activePartChanged( KParts::Part
>> * ) to KHTMLPart::slotActiveFrameChanged( KParts::Part * )
>> ssh mediawiki@gaDDkio (KIOConnection): ERROR: Header read failed,
>> errno=104
>> kio (KIOConnection): ERROR: Header has invalid size (-1)
>> kio (KIOConnection): ERROR: Could not write data
>> kio (KLauncher): ERROR: SlavePool: No communication with slave.
>> kio (KIOConnection): ERROR: Header read failed, errno=104
>> kio (KIOConnection): ERROR: Header has invalid size (-1)
>> kio (KIOConnection): ERROR: Header read failed, errno=104
>> kio (KIOConnection): ERROR: Header has invalid size (-1)
>> kio (KLauncher): ERROR: SlavePool: No communication with slave.
>> kio (KIOConnection): ERROR: Header read failed, errno=104
>> kio (KIOConnection): ERROR: Header has invalid size (-1)
>> kio (KIOConnection): ERROR: Could not write data
>> kio (KLauncher): ERROR: SlavePool: No communication with slave.
>> DCOP aborting call from 'anonymous-19721' to 'amarok'
>> kio (KIOConnection): ERROR: Header read failed, errno=104
>> kio (KIOConnection): ERROR: Header has invalid size (-1)
>> X Error: BadWindow (invalid Window parameter) 3
>> Major opcode: 7
>> Minor opcode: 0
>> Resource id: 0x580001c
>> ----------------------------------------------------------
>>
>>
>> ----------------------------------------------------------
>> me@bunlaptop:~$ amarokapp
>> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel =
>> 0x81347f0 ):
>> KAccel object already contains an action name "play_pause"
>> QLayout "unnamed" added to QVBox "unnamed", which already has a
>> layout
>> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel =
>> 0x81347f0 ):
>> KAccel object already contains an action name "play_pause"
>> QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to
>> layout
>> for PlaylistWindow/PlaylistWindow
>> QObject::connect: Incompatible sender/receiver arguments
>> StarManager::ratingsColorsChanged() -->
>> ContextBrowser::ratingOrScoreOrLabelsChanged(const QString&)
>> STARTUP
>> amarok: WARNING: Pixmap not found for mimetype application/ogg
>> amarok: WARNING: Pixmap not found for mimetype application/ogg
>> QObject::disconnect: Unexpected null parameter
>> QObject::connect: Cannot connect
>> (null)::activePartChanged( KParts::Part
>> * ) to KHTMLPart::slotActiveFrameChanged( KParts::Part * )
>> me@bunlaptop:~$ amarokapp
>> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel =
>> 0x809cdd8 ):
>> KAccel object already contains an action name "play_pause"
>> QLayout "unnamed" added to QVBox "unnamed", which already has a
>> layout
>> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel =
>> 0x809cdd8 ):
>> KAccel object already contains an action name "play_pause"
>> QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to
>> layout
>> for PlaylistWindow/PlaylistWindow
>> QObject::connect: Incompatible sender/receiver arguments
>> StarManager::ratingsColorsChanged() -->
>> ContextBrowser::ratingOrScoreOrLabelsChanged(const QString&)
>> STARTUP
>> amarok: WARNING: Pixmap not found for mimetype application/ogg
>> amarok: WARNING: Pixmap not found for mimetype application/ogg
>> QObject::disconnect: Unexpected null parameter
>> QObject::connect: Cannot connect
>> (null)::activePartChanged( KParts::Part
>> * ) to KHTMLPart::slotActiveFrameChanged( KParts::Part * )
>> ----------------------------------------------------------
>>
>> Copying this in google didn't help me much.
>> Can someone give me an hand? this is driving me nuts!
>>
>> I can provide other log if necessary
>>
>> Cheers!
>>
>> --
>> ubuntu-users mailing list
>> ubuntu-users@lists.ubuntu.com
>> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
>>
>
>
>
> --
> I am a rock, I am an "archipelago of the informal"
>
> --
> ubuntu-users mailing list
> ubuntu-users@lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-26-2008, 11:41 AM
"Brian McKee"
 
Default amarok on ubuntu hardy takes 15 minutes to startup

On Mon, Aug 25, 2008 at 10:34 PM, Ryan Toler <jester465@gmail.com> wrote:
> Note that running mysql just to speed up one program might slowdown
> the rest of the system. I'm not sure but the default install starts at
> least 5 but may be up to 10 processes each eating up ram and CPU
> Cycles. This might not be a problem for your machine but you should
> weigh the pros and cons of a faster music player or faster system as a
> whole.

I've found mysql to be pretty good at doing nothing when it's doing
nothing... I doubt the effect is very noticeable on system
performance as a whole, execpt when actively used for more complicated
things like searches. It's got to be heavier than SQLite, but I
haven't noticed it.

Brian

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-26-2008, 12:31 PM
Dvorzhetsky
 
Default amarok on ubuntu hardy takes 15 minutes to startup

> I've found mysql to be pretty good at doing nothing when it's doing
> nothing... I doubt the effect is very noticeable on system
> performance as a whole, execpt when actively used for more complicated
> things like searches. It's got to be heavier than SQLite, but I
> haven't noticed it.
>
> Brian
>

I don't think it is a problem of performance of the database since
neither cpu nor memory or hd are in full use while loading.

15 minutes is really not normal, that must be something else.

Anything else to propose ?
Should I give more info ?

Thanks!




--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-26-2008, 12:52 PM
Derek Broughton
 
Default amarok on ubuntu hardy takes 15 minutes to startup

Brian McKee wrote:

> On Mon, Aug 25, 2008 at 10:34 PM, Ryan Toler <jester465@gmail.com> wrote:
>> Note that running mysql just to speed up one program might slowdown
>> the rest of the system. I'm not sure but the default install starts at
>> least 5 but may be up to 10 processes each eating up ram and CPU
>> Cycles. This might not be a problem for your machine but you should
>> weigh the pros and cons of a faster music player or faster system as a
>> whole.
>
> I've found mysql to be pretty good at doing nothing when it's doing
> nothing... I doubt the effect is very noticeable on system
> performance as a whole, execpt when actively used for more complicated
> things like searches. It's got to be heavier than SQLite, but I
> haven't noticed it.

I try to avoid MySQL simply because I'm already running too many rDBs (most
of my current work is PostGres, and I still need to occasionally start up
Oracle - and _that's_ a resource hog), but it's installed because Amarok's
dependencies are imo broken, and every now & then I see it's running and I
have no indication that it's actually consuming resources.
--
derek


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-26-2008, 01:35 PM
Derek Broughton
 
Default amarok on ubuntu hardy takes 15 minutes to startup

Derek Broughton wrote:

> Brian McKee wrote:
>
>> On Mon, Aug 25, 2008 at 10:34 PM, Ryan Toler <jester465@gmail.com> wrote:
>>> Note that running mysql just to speed up one program might slowdown
>>> the rest of the system. I'm not sure but the default install starts at
>>> least 5 but may be up to 10 processes each eating up ram and CPU
>>> Cycles. This might not be a problem for your machine but you should
>>> weigh the pros and cons of a faster music player or faster system as a
>>> whole.
>>
>> I've found mysql to be pretty good at doing nothing when it's doing
>> nothing... I doubt the effect is very noticeable on system
>> performance as a whole, execpt when actively used for more complicated
>> things like searches. It's got to be heavier than SQLite, but I
>> haven't noticed it.
>
> I try to avoid MySQL simply because I'm already running too many rDBs
> (most of my current work is PostGres, and I still need to occasionally
> start up Oracle - and _that's_ a resource hog), but it's installed because
> Amarok's dependencies are imo broken, and every now & then I see it's
> running and I have no indication that it's actually consuming resources.

Oops. That got me looking a little more carefully. Amarok and others only
depend on libmysqlclient15off, which is probably little more than a stub.
I was just trying to remove too much from my system. I have been able to
remove both the server and mysql-client.
--
derek


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-26-2008, 03:45 PM
"Steve Lamb"
 
Default amarok on ubuntu hardy takes 15 minutes to startup

On Tue, Aug 26, 2008 at 09:52:58AM -0300, Derek Broughton wrote:
> I try to avoid MySQL simply because I'm already running too many rDBs (most
> of my current work is PostGres, and I still need to occasionally start up
> Oracle - and _that's_ a resource hog), but it's installed because Amarok's
> dependencies are imo broken, and every now & then I see it's running and I
> have no indication that it's actually consuming resources.

Don't worry, MySQL is soon going to be standard fare. KDE 4.x, which
includes some "addressbook" API which is supposed to unify things for all
applications, is based on MySQL. So any app which relies on that API (which
is, yeah, lots of things from 4.1 and up) require MySQL to be installed.

--
Steve C. Lamb | I'm your priest, I'm your shrink, I'm your
PGP Key: 1FC01004 | main connection to the switchboard of souls.
-------------------------------+---------------------------------------------
--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 08-27-2008, 01:18 AM
Derek Broughton
 
Default amarok on ubuntu hardy takes 15 minutes to startup

Steve Lamb wrote:

> On Tue, Aug 26, 2008 at 09:52:58AM -0300, Derek Broughton wrote:
>> I try to avoid MySQL simply because I'm already running too many rDBs
>> (most of my current work is PostGres, and I still need to occasionally
>> start up Oracle - and _that's_ a resource hog), but it's installed
>> because Amarok's dependencies are imo broken, and every now & then I see
>> it's running and I have no indication that it's actually consuming
>> resources.
>
> Don't worry, MySQL is soon going to be standard fare. KDE 4.x, which
> includes some "addressbook" API which is supposed to unify things for all
> applications, is based on MySQL. So any app which relies on that API
> (which is, yeah, lots of things from 4.1 and up) require MySQL to be
> installed.

That's nuts. There's no conceivable reason they should rely on a _specific_
rDB. I'm going to be some pissed if it doesn't support PostGres.
--
derek


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 01:07 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org