FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 07-31-2008, 08:42 PM
Patrick Drechsler
 
Default 8.04 and vmware 1.0.6 libpng12.so (was: Version 8.04 and VMware 1.0.6)

Hi,

Tom <lau@woh.rr.com> writes:

> I installed VMware version 1.0.6 on mentioned platform and received the
> following error:
>
> /usr/lib/VMware/bin/vmware: /usr/lib/vmware/lib/libgcc_S.SO.1/libgcc_S.SO.1:Version 'GCC_3.4' not found (required by /usr/lib/libcairo.SO.2), also, same message for version 'GCC_4.2.0'

I am having similar problems with the combination of Ubuntu 8.04 LTS and
VMware server version 1.0.6.

Aside from the current issue, the machine was upgraded successfully from
Ubuntu 6.06 LTS. Also, vmware server version 1.0.5 worked fine with
the late Ubuntu 6.06.

I was able to fix the error described above by soft linking the system
gcc lib as described in many posts and web pages[1].

Then I got this error message:

,----
| process 10982: Attempt to remove filter function 0xb6a4ecd0 user data
| 0x88c8520, but no such filter has been added
`----

I have found 2 proposed solutions for this problem:

1. Soft linking the system libpng12.so to vmware's location

sudo ln -s /usr/lib/libpng12.so.0 /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0

Also tried this:

sudo ln -s /usr/lib/libpng12.so.0 /usr/lib/vmware/lib/libpng12.so.0

Result: Both attempts did not work and returned the same error message.

2. Stopping D-BUS

sudo /etc/init.d/dbus stop && vmware

Result: This worked and allowed my to access my guest OSes.

BUT: Stopping dbus resulted in a loss of "Meta"-key (Control, Meta,
Alt, Shift keys) functionality in the server OS (Ubuntu). Note that
these keys were still functional in the guest OS (Windows XP). Since
dbus seems to be play in important role in Ubuntu's IPC, I obviously
do not feel comfortable with this workaround.


Has anybody (a) encountered the same problem and (b) found a solution?

I have also searched the vmware forums, but I could not find a solution
to this problem.

Don't hesitate to ask for more infos.

Thankful for any pointers,

Patrick

OS:
Linux golem 2.6.24-20-generic #1 SMP Mon Jul 28 13:49:52 UTC 2008 i686 GNU/Linux


Footnotes:
[1] https://help.ubuntu.com/community/VMware/Server

--
An idea is like a cup of coffee, it's not going to stay hot forever.



--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 12:52 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org