Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Ubuntu User (http://www.linux-archive.org/ubuntu-user/)
-   -   please help, desperate, weird problem realting to ftp and samba shares and filesystem access thx :) (http://www.linux-archive.org/ubuntu-user/130037-please-help-desperate-weird-problem-realting-ftp-samba-shares-filesystem-access-thx.html)

Ed Greshko 07-23-2008 09:54 AM

please help, desperate, weird problem realting to ftp and samba shares and filesystem access thx :)
 
Jody Gugelhupf wrote:
> hi ppl :)
> I have a fresh install of ubuntu hardy (let's call this machine 1), i have several machines mainly unix machines on the network, i have setup samba, it works without problem between all clients. I also have a ftp running on machine 1, in the ftp dir i have all sorts of directories, including shares from other machines, which i mounted there with samba, i can see all files access everything and the rights are set correctly too, i can also download anything from machine 1's ftp directory as long as it is physically in that machines, when i try to download something from a mounted directory i get 2 different errors from several clients i have tried:
>
> some clients give me this error:
> 150 Opening BINARY mode data connection for Arms.avi (734472192 bytes).
> 426 Sendfile error: Value too large for defined data type.
>
> other clients give me this error:
> 150 Opening BINARY mode data connection for Fov.avi (731535360 bytes)
> 426 Transfer aborted. Operation not permitted
>
> however when i download files which are only a couple kb it works, but i think no more then 10kb
> then i tried uploading files to the ftp's directory into the directories which were mounted, and from which i can only downloadver small files or get the mentioned errors, uploading works, regardless the size
> I have tried proftpd and glftpd on machine1 same problem, i have also installed an ftp on another ubuntu machine and have mounted directories from other machines (to recreate same circumstance) and there is no problem, so what the hell is the issue here, any hints tips?
> thx,
> jody :)

On your shares do you have "use sendfile" set to yes?

From the smb.conf man page...

use sendfile (S)

If this parameter is yes, and the sendfile() system call is supported
by the underlying operating system, then some SMB read calls (mainly
ReadAndX and ReadRaw) will use the more efficient sendfile system call for
files that are exclusively oplocked. This may make more efficient use of the
system CPU's and cause Samba to be faster. Samba automatically turns this
off for clients that use protocol levels lower than NT LM 0.12 and when it
detects a client is Windows 9x (using sendfile from Linux will cause these
clients to fail).

--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users


All times are GMT. The time now is 03:05 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.