FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu User

 
 
LinkBack Thread Tools
 
Old 07-20-2008, 04:33 PM
Alex Janssen
 
Default bitpim - fatal error after phonebook download

I'm running bitpim set for a V3cm phone on Ubuntu 8.04.
I't seems to download the data ok, but crashes when it tries to draw the
screen for the phonebook.
Anyone else had this problem?
I created a bug report file if you would like to look at it.
The error message is below.

Thanks for any help,
Alex
************************************************** **********************
BitPim version: 1.0.2-Debian
An unexpected exception has occurred.
Please see the help for details on what to do.

Traceback (most recent call last):
File "/usr/share/bitpim/code/phonebook.py", line 1495, in Draw
text, font=self.facename, size=self.facesize)
File "/usr/share/bitpim/code/bphtml.py", line 488, in drawhtml
hdc.Render(rect.x, rect.y, 0, False)
File
"/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/html.py", line
1265, in Render
return _html.HtmlDCRenderer_Render(*args, **kwargs)
TypeError: Sequence of integers expected.

Variables by last 8 frames, innermost last

Frame Draw in /usr/share/bitpim/code/phonebook.py at line 1495
attr = <wx.grid.GridCellAttr; proxy of <Swig Object of type
'wxGridCellAttr *' at 0x9ab
text = '<font color="#000000"><strike>987-0837
[31]</strike></font>'
colour = wx.Colour(0, 0, 0, 255)
dc = <wx._gdi.PaintDC; proxy of <Swig Object of type
'wxPaintDC *' at 0xbfa72dec> >
self = <phonebook.ImportCellRenderer; proxy of <Swig Object
of type 'wxPyGridCellRender
isSelected = 0
rowtype = 0
grid = <wx.grid.Grid; proxy of <Swig Object of type 'wxGrid
*' at 0x9ae1000> >
col = 5
rect = wx.Rect(400, 450, 80, 25)
row = 18

Frame drawhtml in /usr/share/bitpim/code/bphtml.py at line 488
basepath = '
dc = <wx._gdi.PaintDC; proxy of <Swig Object of type
'wxPaintDC *' at 0xbfa72dec> >
html = '<font color="#000000"><strike>987-0837
[31]</strike></font>'
hdc = <wx.html.HtmlDCRenderer; proxy of <Swig Object of
type 'wxHtmlDCRenderer *' at 0
rect = wx.Rect(402, 451, 76, 23)
x = 1.6000000000000001
font = u'Sans'
origscale = (1.0, 1.0)
size = 10

Frame Render in
/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/html.py at line 1265
args = (<wx.html.HtmlDCRenderer; proxy of <Swig Object of
type 'wxHtmlDCRenderer *' at
kwargs = Keys []
{}

--
Ourwoods.org
Behind every argument is someone's ignorance. (59)


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 07-24-2008, 03:03 AM
Alex Janssen
 
Default bitpim - fatal error after phonebook download

Alex Janssen said the following on 07/20/2008 12:33 PM:
> I'm running bitpim set for a V3cm phone on Ubuntu 8.04.
> I't seems to download the data ok, but crashes when it tries to draw the
> screen for the phonebook.
> Anyone else had this problem?
> I created a bug report file if you would like to look at it.
> The error message is below.
>
> Thanks for any help,
> Alex
> ************************************************** **********************
>
Please pardon me for replying to my own message, but is their a better
place to ask this question? This was where the package indicated I
should ask first.

Alex

--
Ourwoods.org
All of me is beautiful and valuable, even the ugly, stupid, and disgusting parts. - Marsha Mellow (164)


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 
Old 07-25-2008, 02:29 AM
Alex Janssen
 
Default bitpim - fatal error after phonebook download

Alex Janssen said the following on 07/20/2008 12:33 PM:
> I'm running bitpim set for a V3cm phone on Ubuntu 8.04.
> I't seems to download the data ok, but crashes when it tries to draw the
> screen for the phonebook.
> Anyone else had this problem?
> I created a bug report file if you would like to look at it.
> The error message is below.
>
> Thanks for any help,
> Alex
>
>
Apparently, the Ubuntu repository version of bitpim(v1.02) is broken. I
un-installed it and install the version(1.05) from bitpim.org and the
problems did not show themselves. All is well, now.

It seems that even with all the great effort that Mark Shuttleworth's
Ubuntu crew puts into it, that even they cannot keep up with all the
packages that are offered in the distribution. The individual project
leaders cannot be expected to keep up with all the GNU/Linux
distibutions, either. Maybe the distributions should just link to the
project web sites instead of trying to maintain a repository of apps,
although, this model has been very successful for the most part.

Alex

--
Ourwoods.org
Only a lack of imagination saves me from immobilizing myself with imaginary fears. - Rick Schizo (274)


--
ubuntu-users mailing list
ubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
 

Thread Tools




All times are GMT. The time now is 04:56 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org