FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Studio User

 
 
LinkBack Thread Tools
 
Old 09-17-2012, 12:12 PM
"brian.collins@alice.it"
 
Default R: Audio issues in 10.04

Message: 2
Date: Mon, 17 Sep 2012 10:52:51 +0200
From: Thomas Orgis <thomas-forum@orgis.org>
To: Ubuntu Studio Users Help and Discussion
<ubuntu-studio-users@lists.ubuntu.com>
Subject: Horrific jackd xrun behaviour after upgrade from US 10.04 to
12.04
Message-ID: <20120917105251.1214a1c9@orgis.org>
Content-Type: text/plain; charset="us-ascii"

Hi,

the subject says it all ... I had an install of 10.04 that worked. Only
issue seemed to be instability when recording while a USB drive is
connected. So, considering that perhaps this is a sign to replace a
mainboard with broken onboard USB (used a PCI add-on card, which might
have worsened the interrupt situation), I did replace it and the
machine worked fine during a session.

Now with the fully replaced hardware (Asus AM3 board with 780G chipset,
Athlon || X3 460, 8 Gig of Kingston DDR3 ValueRAM, 250 G Seagate SATA
boot, 2 WD EADS on mdraid for recordings and not to forget VIA firewire
on PCI-E (same card as before)) and the update to ubuntu 12.04 (yes,
should have tested the final hardware with 10.04 first, eh?), the
performance is hindered by jackd not being able to keep steady without
generating xruns at a some rate. Not really constant rate, though, also
its behaviour depends on client connections (even when just connecting
meterbridge, this seems to help triggering xruns a lot).

A very interesting fact is that using 3x512 periods (or bigger) is less
stable even than going down to 3x32! With big periods, I get xruns
right away, while with the low setting, I was able to get an hour of
recording done, but that ended prematurely -- I _guess_ that this was
because of some software glitch (like xrun handling) and not due to the
bass player nudging the keyboard by chance. But I cannot be sure about
that.

Now, I do have the lowlatency kernel already installed, also fresh
jack/ardour from kxstudio ... have rtirq setup updated by dpkg
(firewire in there instead of ohci1394). What are the ubuntu studio
folks' thoughts on this? Did you encounter _more_ stable jack with
extremely low latencies? But since it is not really stable and
glitch-free in any config, this interesting characteristic does not
help. Oh, and it happens independent of cpufreq governor. I do use XFCE
and the integrated radeon with open source driver.

Any help on getting that setup stable again is appreciated ... or
should I simply go back to 10.04 (and hand-install current ardour/jack,
as I did before)? I figure that I shouldn't even need a lowlat kernel
for getting basic 3x512 recording work!


Alrighty then,

Thomas.


PS: Why upgrade at all? Well, I have always a spark of hope that some
iteration of the GNU/Linux audio ecosystem will be really stable,
without random crashes of Ardour, for example. But I guess one has to
live with crashing multimedia apps ... not been that different during
my days doing video with Ulead Media Studio on Windows (and the fact
that version 5 was less usable than 2.5).
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20120917/8b38691f/attachment-0001.pgp>

------------------------------

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users


End of Ubuntu-Studio-users Digest, Vol 65, Issue 11
************************************************** *

Hello Thomas,
I use KXStudio on top of UbuntuStudio, but the 12.04 version. I haven't had any of the problems you mentioned at all.
You might want to post your question on linuxmusicians forum here: http://linuxmusicians.com/viewtopic.php?f=47&t=8012
I think you'll get more specific help with KXStudio there..

brian

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 

Thread Tools




All times are GMT. The time now is 07:34 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org