FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Studio User

 
 
LinkBack Thread Tools
 
Old 08-06-2012, 07:50 AM
Benjamin Martin
 
Default Pulseaudio, qjackctl .. nearly working :(

hello all,

I have UbuntuStudio12.04 on a P4 machine with 2GB of memory and 2 sounds
cards (1xBuilt in, 1xSoundBlaster)


On the whole it works well and i can change the sound output using the
PulseAudio mixer.


I setup a Rivendell by following this guide
(http://bluedrava.com/rivendell-on-ubuntu-12.04) and it too works well,
therefore showing that jack is working


When qjackctl is running all seems to be fine and shows the correct
connections with PulseAudio JACK Sink etc.


The problem comes when using Audacious, it will act as if it is playing
an mp3, but it is sort of stuck and althou I have clicked 'Play' the
tack time does not move... when I stop qjackctl, Audacious will kick in
and become un-stuck and just play as normal.


When qjackctl is running, I have checked that jack is "set as fallback"
in PulseAudio mixer


My problem sounds like this invalid bug report:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/925257

I guess this is Audacious trying to use PulseAudio which it can't until
qjackctl have killed jackd .. but I think they "should" play nicely
together?? (providing the PulseAudio JACK Sink is setup correctly) ...
what could the problem be?


I have googled about for abit and read some stuff on the ubuntu studio
wiki but I am abit stuck for a solution... can anyone offer any pointers?


Thanks for any help you can offer,

-Ben








--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 08-06-2012, 10:06 AM
Hakan Koseoglu
 
Default Pulseaudio, qjackctl .. nearly working :(

The problem comes when using Audacious, it will act as if it is playing an mp3, but it is sort of stuck and althou I have clicked 'Play' the tack time does not move... when I stop qjackctl, Audacious will kick in and become un-stuck and just play as normal.



Open pavucontrol, then select the pulse sink as the device for Audacious since it's not going through the Jack but waits for the real audio device to be ready. As soon as you switch to the sink, you'll be fine.
*
When qjackctl is running, I have checked that jack is "set as fallback" in PulseAudio mixer


I believe "fallback" means if the default audio device doesn't exist, use this one. It exists but in use by jack. Happy to be corrected.
--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 08-07-2012, 06:56 AM
Benjamin Martin
 
Default Pulseaudio, qjackctl .. nearly working :(

On 06/08/12 11:06, Hakan Koseoglu wrote:
Open pavucontrol, then select the pulse sink as the device for
Audacious since it's not going through the Jack but waits for the real
audio device to be ready. As soon as you switch to the sink, you'll be
fine.


Exactly as you said!

Thanks very much for the help, shocking that I did not spot this before

Everything seems to working so smoothly now, I am stocked I tried out
UbuntuStudio, it's brilliant and a audio/video editors heaven .. well
done and thanks to the people behind US.


--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 

Thread Tools




All times are GMT. The time now is 03:47 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org