FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Studio User

 
 
LinkBack Thread Tools
 
Old 05-29-2011, 08:37 PM
Alexandros Bitoulas
 
Default Ardour Segmentation fault- won't start at all!

On Sunday 29 of May 2011 23:30:36 Mike Holstein wrote:
> On Sun, May 29, 2011 at 4:08 PM, Alexandros Bitoulas
<albitoulas@yahoo.gr>wrote:
> > Hello to everyone!
> >
> > I am using Kubuntu 11.04 (fresh install, added single audio packages
> > needed)
> > on my pc where I have been able to work perfectly with my guitar (rakarak
> > and
> > record in ardour with generic kernel) until some days ago.
> >
> > However, since the last two days I cannot start Ardour! AFAIK, I haven't
> > done
> > something that could cause this problem. From the terminal I get only
> > this output.
> >
> > alex@Kubuntu-pc:~$ ardour2
> > Ardour 2.8.11
> >
> > (built using 7387 and GCC version 4.5.1)
> >
> > Copyright (C) 1999-2008 Paul Davis
> > Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel
> > Baker
> >
> > Ardour comes with ABSOLUTELY NO WARRANTY
> > not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
> > This is free software, and you are welcome to redistribute it
> > under certain conditions; see the source for copying conditions.
> > Segmentation fault
> > alex@Kubuntu-pc:~$
> >
> > I searched on the internet and haven't found something about it...I don't
> > even
> > know with what it could be related with or what caused it!
> >
> > I want to note that everything else works perfectly (Jack, Rakarack).
> >
> > Could somebody provide some help, guidelines or any information? Does
> > anyone
> > has/had the same proble with Natty?
> >
> > Thank you all in advance,
> >
> > Alex
>
> try reinstalling ardour... there should be an .ardour2 directory in your
> /home, try moving or renaming it and see if that fixes it...
>
MIke,

I have already reinstalled Ardour an hour ago but nothing happened. I have
also tried your idea renaming and moving the whole folder, but I still get the
same message in my terminal and Ardour wont start at all!

> > --
> > Ubuntu-Studio-users mailing list
> > Ubuntu-Studio-users@lists.ubuntu.com
> > Modify settings or unsubscribe at:
> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 05-29-2011, 08:38 PM
Mike Holstein
 
Default Ardour Segmentation fault- won't start at all!

On Sun, May 29, 2011 at 4:37 PM, Alexandros Bitoulas <albitoulas@yahoo.gr> wrote:

On Sunday 29 of May 2011 23:30:36 Mike Holstein wrote:

> On Sun, May 29, 2011 at 4:08 PM, Alexandros Bitoulas

<albitoulas@yahoo.gr>wrote:

> > Hello to everyone!

> >

> > I am using Kubuntu 11.04 (fresh install, added single audio packages

> > needed)

> > on my pc where I have been able to work perfectly with my guitar (rakarak

> > and

> > record in ardour with generic kernel) until some days ago.

> >

> > However, since the last two days I cannot start Ardour! AFAIK, I haven't

> > done

> > something that could cause this problem. From the terminal I get only

> > this output.

> >

> > alex@Kubuntu-pc:~$ ardour2

> > Ardour 2.8.11

> >

> > * (built using 7387 and GCC version 4.5.1)

> >

> > Copyright (C) 1999-2008 Paul Davis

> > Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel

> > Baker

> >

> > Ardour comes with ABSOLUTELY NO WARRANTY

> > not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

> > This is free software, and you are welcome to redistribute it

> > under certain conditions; see the source for copying conditions.

> > Segmentation fault

> > alex@Kubuntu-pc:~$

> >

> > I searched on the internet and haven't found something about it...I don't

> > even

> > know with what it could be related with or what caused it!

> >

> > I want to note that everything else works perfectly (Jack, Rakarack).

> >

> > Could somebody provide some help, guidelines or any information? Does

> > anyone

> > has/had the same proble with Natty?

> >

> > Thank you all in advance,

> >

> > Alex

>

> try reinstalling ardour... there should be an .ardour2 directory in your

> /home, try moving or renaming it and see if that fixes it...

>

MIke,



I have already reinstalled Ardour an hour ago but nothing happened. I have

also tried your idea renaming and moving the whole folder, but I still get the

same message in my terminal and Ardour wont start at all!

i would hop on freenode and ask in #ardour*



> > --

> > Ubuntu-Studio-users mailing list

> > Ubuntu-Studio-users@lists.ubuntu.com

> > Modify settings or unsubscribe at:

> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users



--

Ubuntu-Studio-users mailing list

Ubuntu-Studio-users@lists.ubuntu.com

Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users



--
MH
http://opensourcemusician.libsyn.com/http://wnclug.ourproject.org/


--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 05-29-2011, 08:44 PM
Gustin Johnson
 
Default Ardour Segmentation fault- won't start at all!

How did you do the reinstall? Try purging the current install and
then reinstall Ardour.

I had similar issues with Ardour once that turned out to be a bad
stick of RAM. You may want to consider running memtest on your
computer.

On Sun, May 29, 2011 at 2:37 PM, Alexandros Bitoulas
<albitoulas@yahoo.gr> wrote:
> On Sunday 29 of May 2011 23:30:36 Mike Holstein wrote:
>> On Sun, May 29, 2011 at 4:08 PM, Alexandros Bitoulas
> <albitoulas@yahoo.gr>wrote:
>> > Hello to everyone!
>> >
>> > I am using Kubuntu 11.04 (fresh install, added single audio packages
>> > needed)
>> > on my pc where I have been able to work perfectly with my guitar (rakarak
>> > and
>> > record in ardour with generic kernel) until some days ago.
>> >
>> > However, since the last two days I cannot start Ardour! AFAIK, I haven't
>> > done
>> > something that could cause this problem. From the terminal I get only
>> > this output.
>> >
>> > alex@Kubuntu-pc:~$ ardour2
>> > Ardour 2.8.11
>> >
>> > * (built using 7387 and GCC version 4.5.1)
>> >
>> > Copyright (C) 1999-2008 Paul Davis
>> > Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel
>> > Baker
>> >
>> > Ardour comes with ABSOLUTELY NO WARRANTY
>> > not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
>> > This is free software, and you are welcome to redistribute it
>> > under certain conditions; see the source for copying conditions.
>> > Segmentation fault
>> > alex@Kubuntu-pc:~$
>> >
>> > I searched on the internet and haven't found something about it...I don't
>> > even
>> > know with what it could be related with or what caused it!
>> >
>> > I want to note that everything else works perfectly (Jack, Rakarack).
>> >
>> > Could somebody provide some help, guidelines or any information? Does
>> > anyone
>> > has/had the same proble with Natty?
>> >
>> > Thank you all in advance,
>> >
>> > Alex
>>
>> try reinstalling ardour... there should be an .ardour2 directory in your
>> /home, try moving or renaming it and see if that fixes it...
>>
> MIke,
>
> I have already reinstalled Ardour an hour ago but nothing happened. I have
> also tried your idea renaming and moving the whole folder, but I still get the
> same message in my terminal and Ardour wont start at all!
>
>> > --
>> > Ubuntu-Studio-users mailing list
>> > Ubuntu-Studio-users@lists.ubuntu.com
>> > Modify settings or unsubscribe at:
>> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>
> --
> Ubuntu-Studio-users mailing list
> Ubuntu-Studio-users@lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 05-29-2011, 08:49 PM
Alexandros Bitoulas
 
Default Ardour Segmentation fault- won't start at all!

I just did:

"sudo apt-get remove ardour" and then "sudo apt-get autoremove" for removing.

After that I did "sudo apt-get install ardour".

How can I purge the current install? With which command?

Thanks,

Alex

On Sunday 29 of May 2011 23:44:39 Gustin Johnson wrote:
> How did you do the reinstall? Try purging the current install and
> then reinstall Ardour.
>
> I had similar issues with Ardour once that turned out to be a bad
> stick of RAM. You may want to consider running memtest on your
> computer.
>
> On Sun, May 29, 2011 at 2:37 PM, Alexandros Bitoulas
>
> <albitoulas@yahoo.gr> wrote:
> > On Sunday 29 of May 2011 23:30:36 Mike Holstein wrote:
> >> On Sun, May 29, 2011 at 4:08 PM, Alexandros Bitoulas
> >
> > <albitoulas@yahoo.gr>wrote:
> >> > Hello to everyone!
> >> >
> >> > I am using Kubuntu 11.04 (fresh install, added single audio packages
> >> > needed)
> >> > on my pc where I have been able to work perfectly with my guitar
> >> > (rakarak and
> >> > record in ardour with generic kernel) until some days ago.
> >> >
> >> > However, since the last two days I cannot start Ardour! AFAIK, I
> >> > haven't done
> >> > something that could cause this problem. From the terminal I get only
> >> > this output.
> >> >
> >> > alex@Kubuntu-pc:~$ ardour2
> >> > Ardour 2.8.11
> >> >
> >> > (built using 7387 and GCC version 4.5.1)
> >> >
> >> > Copyright (C) 1999-2008 Paul Davis
> >> > Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren,
> >> > Joel Baker
> >> >
> >> > Ardour comes with ABSOLUTELY NO WARRANTY
> >> > not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
> >> > This is free software, and you are welcome to redistribute it
> >> > under certain conditions; see the source for copying conditions.
> >> > Segmentation fault
> >> > alex@Kubuntu-pc:~$
> >> >
> >> > I searched on the internet and haven't found something about it...I
> >> > don't even
> >> > know with what it could be related with or what caused it!
> >> >
> >> > I want to note that everything else works perfectly (Jack, Rakarack).
> >> >
> >> > Could somebody provide some help, guidelines or any information? Does
> >> > anyone
> >> > has/had the same proble with Natty?
> >> >
> >> > Thank you all in advance,
> >> >
> >> > Alex
> >>
> >> try reinstalling ardour... there should be an .ardour2 directory in your
> >> /home, try moving or renaming it and see if that fixes it...
> >
> > MIke,
> >
> > I have already reinstalled Ardour an hour ago but nothing happened. I
> > have also tried your idea renaming and moving the whole folder, but I
> > still get the same message in my terminal and Ardour wont start at all!
> >
> >> > --
> >> > Ubuntu-Studio-users mailing list
> >> > Ubuntu-Studio-users@lists.ubuntu.com
> >> > Modify settings or unsubscribe at:
> >> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
> >
> > --
> > Ubuntu-Studio-users mailing list
> > Ubuntu-Studio-users@lists.ubuntu.com
> > Modify settings or unsubscribe at:
> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 05-29-2011, 09:06 PM
Janne Jokitalo
 
Default Ardour Segmentation fault- won't start at all!

On Sun, May 29, 2011 at 11:49:21PM +0300, Alexandros Bitoulas wrote:
<snip>
> How can I purge the current install? With which command?

$ sudo aptitude purge ardour

...should do the trick. If you don't want to use aptitude, I think:

$ sudo apt-get remove --purge ardour

...works too.


--
Jaska

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 05-29-2011, 09:32 PM
Alexandros Bitoulas
 
Default Ardour Segmentation fault- won't start at all!

On Monday 30 of May 2011 00:06:55 Janne Jokitalo wrote:
> On Sun, May 29, 2011 at 11:49:21PM +0300, Alexandros Bitoulas wrote:
> <snip>
>
> > How can I purge the current install? With which command?
>
> $ sudo aptitude purge ardour
>
> ...should do the trick. If you don't want to use aptitude, I think:
>
> $ sudo apt-get remove --purge ardour
>
> ...works too.


Thanks guys, but this doesn't either solves the problem. I have purged-removed
and installed again, but nothing.

I will try a memtest...

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 05-29-2011, 09:37 PM
Mike Holstein
 
Default Ardour Segmentation fault- won't start at all!

On Sun, May 29, 2011 at 5:32 PM, Alexandros Bitoulas <albitoulas@yahoo.gr> wrote:

On Monday 30 of May 2011 00:06:55 Janne Jokitalo wrote:

> On Sun, May 29, 2011 at 11:49:21PM +0300, Alexandros Bitoulas wrote:

> <snip>

>

> > How can I purge the current install? With which command?

>

> $ sudo aptitude purge ardour

>

> ...should do the trick. If you don't want to use aptitude, I think:

>

> $ sudo apt-get remove --purge ardour

>

> ...works too.





Thanks guys, but this doesn't either solves the problem. I have purged-removed

and installed again, but nothing.



I will try a memtest...

try a different version of ardour... go in synaptic and force an older version, or look for one from PPA*



--

Ubuntu-Studio-users mailing list

Ubuntu-Studio-users@lists.ubuntu.com

Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users



--
MH
http://opensourcemusician.libsyn.com/http://wnclug.ourproject.org/


--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 05-29-2011, 09:38 PM
Janne Jokitalo
 
Default Ardour Segmentation fault- won't start at all!

On Mon, May 30, 2011 at 12:32:20AM +0300, Alexandros Bitoulas wrote:
> Thanks guys, but this doesn't either solves the problem. I have purged-removed
> and installed again, but nothing.

Then you could try running strace on the application.

$ strace ardour2

It should show what system call ends up crashing the application.

> I will try a memtest...

That's a good thing too, but if you do not have problems elsewhere, might give
strace a shot first. Though, as Gustin implied, his RAM problem appeared only on
using ardour, so... Who knows.


--
Jaska

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 05-29-2011, 09:38 PM
Pablo Fernández
 
Default Ardour Segmentation fault- won't start at all!

> Thanks guys, but this doesn't either solves the problem. I have purged-removed
> and installed again, but nothing.
>
> I will try a memtest...
>

Hi,

Also, take a look at /dev/shm

ls -l /dev/shm

You might need a

rm -f /dev/shm/pulse*

Cheers, Pablo

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 

Thread Tools




All times are GMT. The time now is 06:03 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org