FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Ubuntu > Ubuntu Studio User

 
 
LinkBack Thread Tools
 
Old 05-04-2011, 12:23 PM
Ralf
 
Default Version update from 10.10 to 11.04 - Is it better to re-build the kernel-rt?

After a version upgrade, would it be better to re-build the kernel-rt or
is using the kernels I build with Maverick ok? What's about a self-build
jackd from svn etc.?

Hm? 495 new packages? Order of packages isn't sorted by the alphabet,
hence it's hard to check for issues. The proprietary nvidia driver is
removed, so I expect Ubuntu not to startup (kernel-generic) after the
update, regarding to:

$ cat /etc/rcS.d/S69*
#! /bin/sh
# /etc/rcS.d/Switch_xorg_conf

rm /etc/X11/xorg.conf
case $(uname -r) in
*rt*)
cp /etc/X11/xorg.conf.nv /etc/X11/xorg.conf
;;
*)
cp /etc/X11/xorg.conf.nvidia /etc/X11/xorg.conf
;;
esac

I also wonder what will happen to pulseaudio and envy24 tweaks, my
desktop theme etc..

No longer supported by Canonical (8)
libgnome2-perl
docbook-xsl-doc-html
hal-info
libhal1
hal
libhal-storage1
phonon-backend-xine
smartdimmer
Remove (7)
git1.0-glib-2.0
libpolkit-qt-1-0
libmarblewidget10
gnome-user-guide-de
gnome-user-guide-en
libgirespository1.0-1
libdrm-nouveau1
No longer needed (15)
libwebkit-1.0-common
libqtscript4-phonon
libavformat52
openoffice.org-style-human
libwebkit-1.0-2
libgladeui-1-9
libswscale0
libavutil50
openoffice.org-core
libindicator1
libimobiledevice1
openoffice.org-base-core
nvidia-current-modaliases
nvidia-1773-modaliases
libavcodec52
Install (495)
[snip]
Upgrade (1655)
[snip]

Of cause there're two backups and one is brand-new:

$ ls edubuntu*tar.gz -hl
-rw-r--r-- 1 root root 2.6G 2011-04-14 12:58
edubuntu_maverick_apr-14-2011.tar.gz
-rw-r--r-- 1 root root 2.7G 2011-05-04 10:45
edubuntu_maverick_may-04-2011_stable_midi_daw.tar.gz

Ralf




--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 
Old 05-04-2011, 07:16 PM
Gustin Johnson
 
Default Version update from 10.10 to 11.04 - Is it better to re-build the kernel-rt?

At the very least you should recompile the kernel as the version of
GCC changes with each release. This can cause issues if you need to
compile a module against your kernel or if you use binary driver
blobs.

No idea about the rest.

On Wed, May 4, 2011 at 6:23 AM, Ralf <ralf.mardorf@alice-dsl.net> wrote:
> After a version upgrade, would it be better to re-build the kernel-rt or
> is using the kernels I build with Maverick ok? What's about a self-build
> jackd from svn etc.?
>
> Hm? 495 new packages? Order of packages isn't sorted by the alphabet,
> hence it's hard to check for issues. The proprietary nvidia driver is
> removed, so I expect Ubuntu not to startup (kernel-generic) after the
> update, regarding to:
>
> $ cat /etc/rcS.d/S69*
> #! /bin/sh
> # /etc/rcS.d/Switch_xorg_conf
>
> rm /etc/X11/xorg.conf
> case $(uname -r) in
> * **rt*)
> * * * *cp /etc/X11/xorg.conf.nv /etc/X11/xorg.conf
> * * * *;;
> * **)
> * * * *cp /etc/X11/xorg.conf.nvidia /etc/X11/xorg.conf
> * * * *;;
> esac
>
> I also wonder what will happen to pulseaudio and envy24 tweaks, my
> desktop theme etc..
>
> No longer supported by Canonical (8)
> * * * *libgnome2-perl
> * * * *docbook-xsl-doc-html
> * * * *hal-info
> * * * *libhal1
> * * * *hal
> * * * *libhal-storage1
> * * * *phonon-backend-xine
> * * * *smartdimmer
> Remove (7)
> * * * *git1.0-glib-2.0
> * * * *libpolkit-qt-1-0
> * * * *libmarblewidget10
> * * * *gnome-user-guide-de
> * * * *gnome-user-guide-en
> * * * *libgirespository1.0-1
> * * * *libdrm-nouveau1
> No longer needed (15)
> * * * *libwebkit-1.0-common
> * * * *libqtscript4-phonon
> * * * *libavformat52
> * * * *openoffice.org-style-human
> * * * *libwebkit-1.0-2
> * * * *libgladeui-1-9
> * * * *libswscale0
> * * * *libavutil50
> * * * *openoffice.org-core
> * * * *libindicator1
> * * * *libimobiledevice1
> * * * *openoffice.org-base-core
> * * * *nvidia-current-modaliases
> * * * *nvidia-1773-modaliases
> * * * *libavcodec52
> Install (495)
> * * * *[snip]
> Upgrade (1655)
> * * * *[snip]
>
> Of cause there're two backups and one is brand-new:
>
> $ ls edubuntu*tar.gz -hl
> -rw-r--r-- 1 root root 2.6G 2011-04-14 12:58
> edubuntu_maverick_apr-14-2011.tar.gz
> -rw-r--r-- 1 root root 2.7G 2011-05-04 10:45
> edubuntu_maverick_may-04-2011_stable_midi_daw.tar.gz
>
> Ralf
>
>
>
>
> --
> Ubuntu-Studio-users mailing list
> Ubuntu-Studio-users@lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
 

Thread Tools




All times are GMT. The time now is 12:06 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org