Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Ubuntu Studio User (http://www.linux-archive.org/ubuntu-studio-user/)
-   -   Ubuntu Audio Tweaks error (http://www.linux-archive.org/ubuntu-studio-user/303702-ubuntu-audio-tweaks-error.html)

"Colectivo Sonidos Libertarios" 01-03-2010 05:22 PM

Ubuntu Audio Tweaks error
 
Hi

I download
http://sourceforge.net/projects/dssi/files/dssi-vst/0.8/dssi-vst-0.8.tar.gz/download
make and make installl return this error:

sonidoslibertarios@salacontrol:~/Escritorio/dssi-vst-0.8$ make
wineg++ -m32 -Ivestige -Wall -fPIC remotepluginclient.cpp -c -o
remotepluginclient.w32.o
remotepluginclient.cpp: In constructor
?RemotePluginClient::RemotePluginClient()?:
remotepluginclient.cpp:41: error: ?sprintf? was not declared in this scope
remotepluginclient.cpp:50: error: ?perror? was not declared in this scope
remotepluginclient.cpp:64: error: ?perror? was not declared in this scope
remotepluginclient.cpp:78: error: ?perror? was not declared in this scope
winegcc: g++ failed
make: *** [remotepluginclient.w32.o] Error 2
sonidoslibertarios@salacontrol:~/Escritorio/dssi-vst-0.8$ sudo make install
wineg++ -m32 -Ivestige -Wall -fPIC remotepluginclient.cpp -c -o
remotepluginclient.w32.o
remotepluginclient.cpp: In constructor
?RemotePluginClient::RemotePluginClient()?:
remotepluginclient.cpp:41: error: ?sprintf? was not declared in this scope
remotepluginclient.cpp:50: error: ?perror? was not declared in this scope
remotepluginclient.cpp:64: error: ?perror? was not declared in this scope
remotepluginclient.cpp:78: error: ?perror? was not declared in this scope
winegcc: g++ failed
make: *** [remotepluginclient.w32.o] Error 2

Thanks
Camilo

> Hi, for 64 bits you've got to compil dssi-vst, which is quite simple.
> Download sources here:
> http://sourceforge.net/projects/dssi/files/dssi-vst/
> cd ==>make==>sudo make install.
>
> To run a vst, open a terminal, type vsthost your vst, and connect to jack.
>
> Regards.
> Teza.
>
>
> //////////////////////////////////////////////////////////////////
>
> Colectivo Sonidos Libertarios a écrit :
>> I have ubuntustudio 9.10 64 bits on an amd athlon x2 250 and lanparty dk
>> 790gx with 3gb ram
>>
>> cant install dssi-vst: Error: Arquitecture incorrect 'i386
>> any 64 options?
>>
>>
>>> Hi all, fiew times ago we where talking about having "Raccarack" in the
>>> next Ubuntu Studio Lucid instead "Creox" which is a very good idea. But
>>> there's another soft build by Sandie Sandgreen, "Ubuntu Audio
>>> Tweaks" who will be great to have in the next issue.
>>> You can test the soft here
>>> http://www.sandgreen.dk/index.php?side=python_uat
>>> Tell us what you think about.
>>> Amts
>>> Teza.
>>>
>>>
>>>
>>> --
>>> Ubuntu-Studio-users mailing list
>>> Ubuntu-Studio-users@lists.ubuntu.com
>>> Modify settings or unsubscribe at:
>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>>>
>>>
>>
>>
>>
>
>
>
>
> --
> Ubuntu-Studio-users mailing list
> Ubuntu-Studio-users@lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>


--
Colectivo Sonidos Libertarios
www.sonidoslibertarios.org
Lucha y difusión Popular!!!

--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users

teza 01-03-2010 07:07 PM

Ubuntu Audio Tweaks error
 
Ok Camilo, as I can you're under Karmic Koala 9.10 64 bits, and there's
a bug, but you can fix it like this. You've got to modify the following
files in the dssi-vst folder.

remotepluginclient.cpp
dssi-vst.cpp
rdwrops.cpp
remotevstclient.cpp
remotepluginserver.cpp

and had this ligne #include <stdio.h> , save all the files and start a new compilation.

Regards.

Teza from Paris








/////////////////////////////////////////////........................................///////////////////////////////
Colectivo Sonidos Libertarios a écrit :
> Hi
>
> I download
> http://sourceforge.net/projects/dssi/files/dssi-vst/0.8/dssi-vst-0.8.tar.gz/download
> make and make installl return this error:
>
> sonidoslibertarios@salacontrol:~/Escritorio/dssi-vst-0.8$ make
> wineg++ -m32 -Ivestige -Wall -fPIC remotepluginclient.cpp -c -o
> remotepluginclient.w32.o
> remotepluginclient.cpp: In constructor
> ‘RemotePluginClient::RemotePluginClient()’:
> remotepluginclient.cpp:41: error: ‘sprintf’ was not declared in this scope
> remotepluginclient.cpp:50: error: ‘perror’ was not declared in this scope
> remotepluginclient.cpp:64: error: ‘perror’ was not declared in this scope
> remotepluginclient.cpp:78: error: ‘perror’ was not declared in this scope
> winegcc: g++ failed
> make: *** [remotepluginclient.w32.o] Error 2
> sonidoslibertarios@salacontrol:~/Escritorio/dssi-vst-0.8$ sudo make install
> wineg++ -m32 -Ivestige -Wall -fPIC remotepluginclient.cpp -c -o
> remotepluginclient.w32.o
> remotepluginclient.cpp: In constructor
> ‘RemotePluginClient::RemotePluginClient()’:
> remotepluginclient.cpp:41: error: ‘sprintf’ was not declared in this scope
> remotepluginclient.cpp:50: error: ‘perror’ was not declared in this scope
> remotepluginclient.cpp:64: error: ‘perror’ was not declared in this scope
> remotepluginclient.cpp:78: error: ‘perror’ was not declared in this scope
> winegcc: g++ failed
> make: *** [remotepluginclient.w32.o] Error 2
>
> Thanks
> Camilo
>
>
>> Hi, for 64 bits you've got to compil dssi-vst, which is quite simple.
>> Download sources here:
>> http://sourceforge.net/projects/dssi/files/dssi-vst/
>> cd ==>make==>sudo make install.
>>
>> To run a vst, open a terminal, type vsthost your vst, and connect to jack.
>>
>> Regards.
>> Teza.
>>
>>
>> //////////////////////////////////////////////////////////////////
>>
>> Colectivo Sonidos Libertarios a écrit :
>>
>>> I have ubuntustudio 9.10 64 bits on an amd athlon x2 250 and lanparty dk
>>> 790gx with 3gb ram
>>>
>>> cant install dssi-vst: Error: Arquitecture incorrect 'i386
>>> any 64 options?
>>>
>>>
>>>
>>>> Hi all, fiew times ago we where talking about having "Raccarack" in the
>>>> next Ubuntu Studio Lucid instead "Creox" which is a very good idea. But
>>>> there's another soft build by Sandie Sandgreen, "Ubuntu Audio
>>>> Tweaks" who will be great to have in the next issue.
>>>> You can test the soft here
>>>> http://www.sandgreen.dk/index.php?side=python_uat
>>>> Tell us what you think about.
>>>> Amts
>>>> Teza.
>>>>
>>>>
>>>>
>>>> --
>>>> Ubuntu-Studio-users mailing list
>>>> Ubuntu-Studio-users@lists.ubuntu.com
>>>> Modify settings or unsubscribe at:
>>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>> --
>> Ubuntu-Studio-users mailing list
>> Ubuntu-Studio-users@lists.ubuntu.com
>> Modify settings or unsubscribe at:
>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>>
>>
>
>
>




--
Ubuntu-Studio-users mailing list
Ubuntu-Studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users


All times are GMT. The time now is 04:42 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.